~ubuntu-branches/ubuntu/lucid/awn-extras-applets/lucid

« back to all changes in this revision

Viewing changes to debian/patches/03-remove-cairo-menu-pref.patch

  • Committer: Bazaar Package Importer
  • Author(s): Julien Lavergne
  • Date: 2010-03-30 20:26:40 UTC
  • mfrom: (1.1.5 upstream)
  • Revision ID: james.westby@ubuntu.com-20100330202640-vza3bdnv9gc9bg5z
Tags: 0.4.0~rc1-0ubuntu1
* New upstream release (rc1) (LP: #551309)
 - Stack applet close on click (LP: #261520)
* debian/patches/
 - 03-remove-cairo-menu-pref.patch: From upstream (r1244 + r1245 + r1252),
   remove menu entry for cairo-menu preferences, it's not implemented
   (LP: #511254)
 - 04-tomboy-threading-free.patch: From upstream (r1246), remove threading to
   make the applet working. 
* debian/*.install: Update installation location of comics and digital 
  applets.
* debian/control: 
 - Move digital applet from python to C, and add proper Replaces.
 - Add Replaces for awn-applets-c-core to handle migration from 0.3.2.2.
   (LP: #524559)

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Index: awn-extras-0.4.0~rc1/applets/maintained/cairo-menu/cairo-aux-icon.c
 
2
===================================================================
 
3
--- awn-extras-0.4.0~rc1.orig/applets/maintained/cairo-menu/cairo-aux-icon.c    2010-03-29 00:09:17.000000000 +0200
 
4
+++ awn-extras-0.4.0~rc1/applets/maintained/cairo-menu/cairo-aux-icon.c 2010-03-30 00:46:20.000000000 +0200
 
5
@@ -334,16 +334,17 @@
 
6
     if (!priv->context_menu)
 
7
     {
 
8
       priv->context_menu = awn_applet_create_default_menu (AWN_APPLET(priv->applet));
 
9
+      gtk_menu_set_screen(GTK_MENU(priv->context_menu), NULL);
 
10
+      
 
11
       item = awn_themed_icon_create_remove_custom_icon_item (AWN_THEMED_ICON(icon),NULL);
 
12
       gtk_menu_shell_append (GTK_MENU_SHELL(priv->context_menu), item);
 
13
-      
 
14
+/*      
 
15
       item = gtk_image_menu_item_new_with_label("Applet Preferences");
 
16
       gtk_image_menu_item_set_image (GTK_IMAGE_MENU_ITEM(item), 
 
17
                                      gtk_image_new_from_stock (GTK_STOCK_PREFERENCES,GTK_ICON_SIZE_MENU));
 
18
       gtk_widget_show(item);
 
19
+      gtk_menu_shell_append(GTK_MENU_SHELL(priv->context_menu), item);*/
 
20
       gtk_menu_set_screen(GTK_MENU(priv->context_menu), NULL);
 
21
-      gtk_menu_shell_append(GTK_MENU_SHELL(priv->context_menu), item);
 
22
-
 
23
       item = gtk_image_menu_item_new_with_label("Remove Icon");
 
24
       gtk_image_menu_item_set_image (GTK_IMAGE_MENU_ITEM(item), 
 
25
                                      gtk_image_new_from_stock (GTK_STOCK_REMOVE,GTK_ICON_SIZE_MENU));
 
26
Index: awn-extras-0.4.0~rc1/applets/maintained/cairo-menu/cairo-main-icon.c
 
27
===================================================================
 
28
--- awn-extras-0.4.0~rc1.orig/applets/maintained/cairo-menu/cairo-main-icon.c   2010-03-29 00:09:17.000000000 +0200
 
29
+++ awn-extras-0.4.0~rc1/applets/maintained/cairo-menu/cairo-main-icon.c        2010-03-30 00:46:20.000000000 +0200
 
30
@@ -319,14 +319,15 @@
 
31
     if (!priv->context_menu)
 
32
     {
 
33
       priv->context_menu = awn_applet_create_default_menu (AWN_APPLET(priv->applet));
 
34
+      gtk_menu_set_screen(GTK_MENU(priv->context_menu), NULL);
 
35
       item = awn_themed_icon_create_remove_custom_icon_item (AWN_THEMED_ICON(icon),NULL);
 
36
       gtk_menu_shell_append (GTK_MENU_SHELL(priv->context_menu), item);
 
37
-      item = gtk_image_menu_item_new_with_label("Applet Preferences");
 
38
+/*      item = gtk_image_menu_item_new_with_label("Applet Preferences");
 
39
       gtk_image_menu_item_set_image (GTK_IMAGE_MENU_ITEM(item), 
 
40
                                      gtk_image_new_from_stock (GTK_STOCK_PREFERENCES,GTK_ICON_SIZE_MENU));
 
41
       gtk_widget_show(item);
 
42
-      gtk_menu_set_screen(GTK_MENU(priv->context_menu), NULL);
 
43
       gtk_menu_shell_append(GTK_MENU_SHELL(priv->context_menu), item);
 
44
+       */
 
45
 //      g_signal_connect(G_OBJECT(item), "button-press-event", G_CALLBACK(_show_prefs), NULL);
 
46
       item=awn_applet_create_about_item_simple(AWN_APPLET(priv->applet),
 
47
                                                "Copyright 2007,2008, 2009 Rodney Cryderman <rcryderman@gmail.com>",