~ubuntu-branches/ubuntu/maverick/gnome-terminal/maverick-proposed

« back to all changes in this revision

Viewing changes to debian/patches/01_lpi.patch

  • Committer: Bazaar Package Importer
  • Author(s): Michael Vogt
  • Date: 2008-06-18 10:33:45 UTC
  • mfrom: (1.3.20 upstream)
  • Revision ID: james.westby@ubuntu.com-20080618103345-ife89bdnaa2ttfyk
Tags: 2.23.4.2-0ubuntu1
* new upstream version
* changed debian/patches/01_lpi.patch to work with GtkUIManager
* dropped debian/patches/03_ubuntu_lpi_fix_crash.diff because the
  UIManager makes it obsolete
* updated and renamed debian/patches/02_autoconf.patch to
  debian/patches/99_autoreconf.patch
* debian/control.in:
  - add Vcs-Bzr header
* debian/watch:
  - look for uneven version numbers too to make bzr-buildpackage
    auto download the right tarball
* debian/gnome-terminal-data.install:
  - drop /usr/share/pixmaps, its no longer used

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
diff -Nur -x '*.orig' -x '*~' gnome-terminal-2.21.91/configure.in gnome-terminal-2.21.91.new/configure.in
2
 
--- gnome-terminal-2.21.91/configure.in 2008-02-11 22:01:33.000000000 +0000
3
 
+++ gnome-terminal-2.21.91.new/configure.in     2008-02-11 23:14:14.000000000 +0000
4
 
@@ -37,6 +37,7 @@
 
1
diff -Nur -x '*.orig' -x '*~' ubuntu/configure.ac ubuntu.new/configure.ac
 
2
--- ubuntu/configure.ac 2008-06-17 20:38:09.000000000 +0200
 
3
+++ ubuntu.new/configure.ac     2008-06-18 11:28:33.000000000 +0200
 
4
@@ -48,6 +48,7 @@
5
5
  glib-2.0 >= $GLIB_REQUIRED dnl
6
6
  gtk+-2.0 >= $GTK_REQUIRED dnl
7
7
  gconf-2.0 >= $GCONF_REQUIRED dnl
8
8
+ launchpad-integration
9
9
  gio-2.0 dnl
10
 
  libglade-2.0 dnl
11
10
  libgnomeui-2.0 dnl
12
 
diff -Nur -x '*.orig' -x '*~' gnome-terminal-2.21.91/src/terminal-window.c gnome-terminal-2.21.91.new/src/terminal-window.c
13
 
--- gnome-terminal-2.21.91/src/terminal-window.c        2008-01-15 00:20:37.000000000 +0000
14
 
+++ gnome-terminal-2.21.91.new/src/terminal-window.c    2008-02-11 23:12:32.000000000 +0000
15
 
@@ -29,6 +29,7 @@
16
 
 #include <string.h>
17
 
 #include <stdlib.h>
18
 
 #include <libgnome/gnome-program.h>
19
 
+#include <launchpad-integration.h>
20
 
 #include <gtk/gtklabel.h>
 
11
  libgnome-2.0 >= $LIBGNOME_REQUIRED dnl
 
12
diff -Nur -x '*.orig' -x '*~' ubuntu/src/terminal-window.c ubuntu.new/src/terminal-window.c
 
13
--- ubuntu/src/terminal-window.c        2008-06-17 21:02:47.000000000 +0200
 
14
+++ ubuntu.new/src/terminal-window.c    2008-06-18 11:29:51.000000000 +0200
 
15
@@ -25,6 +25,7 @@
21
16
 #include <gdk/gdkx.h>
22
17
 #include <gdk/gdkkeysyms.h>
23
 
@@ -1067,7 +1068,9 @@
24
 
   mi = append_stock_menuitem (menu, GTK_STOCK_ABOUT, NULL,
25
 
                               G_CALLBACK (about_callback), window);
26
 
   set_menuitem_text (mi, _("_About"), FALSE);
27
 
-  
28
 
+
29
 
+  launchpad_integration_add_items (menu, -1, TRUE, TRUE);
30
 
+
31
 
   terminal_window_reread_profile_list (window);
32
 
   
33
 
   terminal_window_set_menubar_visible (window, TRUE);
 
18
 #include <libsn/sn-launchee.h>
 
19
+#include <launchpad-integration.h>
 
20
 
 
21
 #include "encoding.h"
 
22
 #include "skey-popup.h"
 
23
@@ -1479,11 +1480,11 @@
 
24
       g_printerr ("Failed to load UI: %s\n", error->message);
 
25
       g_error_free (error);
 
26
     }
 
27
-
 
28
   priv->menubar = gtk_ui_manager_get_widget (manager, "/menubar");
 
29
   gtk_box_pack_start (GTK_BOX (main_vbox),
 
30
                      priv->menubar,
 
31
                      FALSE, FALSE, 0);
 
32
+  launchpad_integration_add_ui (manager, "/menubar/Help/LaunchpadItems");
 
33
 
 
34
   /* Add tabs menu */
 
35
   priv->tabs_menu = terminal_tabs_menu_new (window);
 
36
diff -Nur -x '*.orig' -x '*~' ubuntu/src/terminal.xml ubuntu.new/src/terminal.xml
 
37
--- ubuntu/src/terminal.xml     2008-06-17 20:38:09.000000000 +0200
 
38
+++ ubuntu.new/src/terminal.xml 2008-06-18 11:28:55.000000000 +0200
 
39
@@ -51,6 +51,7 @@
 
40
     </menu>
 
41
     <menu action="Help">
 
42
       <menuitem action="HelpContents" />
 
43
+      <placeholder name='LaunchpadItems'/>
 
44
       <menuitem action="HelpAbout" />
 
45
     </menu>
 
46
   </menubar>