~ubuntu-branches/ubuntu/oneiric/gnupg2/oneiric-proposed

« back to all changes in this revision

Viewing changes to debian/patches/debian-changes-2.0.14-1ubuntu1

  • Committer: Bazaar Package Importer
  • Author(s): Michael Bienia
  • Date: 2010-01-22 21:49:55 UTC
  • mfrom: (1.1.14 upstream) (7.1.3 squeeze)
  • Revision ID: james.westby@ubuntu.com-20100122214955-r2ab5it9rts5gqjf
Tags: 2.0.14-1ubuntu1
* Merge with Debian testing (lp: #511356). Remaining changes:
  - debian/gnupg2.dev: udev rules to set ACLs on SCM smartcard readers.
  - debian/rules: Call dh_installudev.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
--- gnupg2-2.0.14.orig/config.guess
 
2
+++ gnupg2-2.0.14/config.guess
 
3
@@ -1,10 +1,10 @@
 
4
 #! /bin/sh
 
5
 # Attempt to guess a canonical system name.
 
6
 #   Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999,
 
7
-#   2000, 2001, 2002, 2003, 2004, 2005, 2006 Free Software Foundation,
 
8
-#   Inc.
 
9
+#   2000, 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009
 
10
+#   Free Software Foundation, Inc.
 
11
 
 
12
-timestamp='2006-07-02'
 
13
+timestamp='2009-06-10'
 
14
 
 
15
 # This file is free software; you can redistribute it and/or modify it
 
16
 # under the terms of the GNU General Public License as published by
 
17
@@ -56,8 +56,8 @@ version="\
 
18
 GNU config.guess ($timestamp)
 
19
 
 
20
 Originally written by Per Bothner.
 
21
-Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2004, 2005
 
22
-Free Software Foundation, Inc.
 
23
+Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001,
 
24
+2002, 2003, 2004, 2005, 2006, 2007, 2008 Free Software Foundation, Inc.
 
25
 
 
26
 This is free software; see the source for copying conditions.  There is NO
 
27
 warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE."
 
28
@@ -161,6 +161,7 @@ case "${UNAME_MACHINE}:${UNAME_SYSTEM}:$
 
29
            arm*) machine=arm-unknown ;;
 
30
            sh3el) machine=shl-unknown ;;
 
31
            sh3eb) machine=sh-unknown ;;
 
32
+           sh5el) machine=sh5le-unknown ;;
 
33
            *) machine=${UNAME_MACHINE_ARCH}-unknown ;;
 
34
        esac
 
35
        # The Operating System including object format, if it has switched
 
36
@@ -169,7 +170,7 @@ case "${UNAME_MACHINE}:${UNAME_SYSTEM}:$
 
37
            arm*|i386|m68k|ns32k|sh3*|sparc|vax)
 
38
                eval $set_cc_for_build
 
39
                if echo __ELF__ | $CC_FOR_BUILD -E - 2>/dev/null \
 
40
-                       | grep __ELF__ >/dev/null
 
41
+                       | grep -q __ELF__
 
42
                then
 
43
                    # Once all utilities can be ECOFF (netbsdecoff) or a.out (netbsdaout).
 
44
                    # Return netbsd for either.  FIX?
 
45
@@ -323,14 +324,30 @@ case "${UNAME_MACHINE}:${UNAME_SYSTEM}:$
 
46
        case `/usr/bin/uname -p` in
 
47
            sparc) echo sparc-icl-nx7; exit ;;
 
48
        esac ;;
 
49
+    s390x:SunOS:*:*)
 
50
+       echo ${UNAME_MACHINE}-ibm-solaris2`echo ${UNAME_RELEASE}|sed -e 's/[^.]*//'`
 
51
+       exit ;;
 
52
     sun4H:SunOS:5.*:*)
 
53
        echo sparc-hal-solaris2`echo ${UNAME_RELEASE}|sed -e 's/[^.]*//'`
 
54
        exit ;;
 
55
     sun4*:SunOS:5.*:* | tadpole*:SunOS:5.*:*)
 
56
        echo sparc-sun-solaris2`echo ${UNAME_RELEASE}|sed -e 's/[^.]*//'`
 
57
        exit ;;
 
58
-    i86pc:SunOS:5.*:*)
 
59
-       echo i386-pc-solaris2`echo ${UNAME_RELEASE}|sed -e 's/[^.]*//'`
 
60
+    i86pc:SunOS:5.*:* | i86xen:SunOS:5.*:*)
 
61
+       eval $set_cc_for_build
 
62
+       SUN_ARCH="i386"
 
63
+       # If there is a compiler, see if it is configured for 64-bit objects.
 
64
+       # Note that the Sun cc does not turn __LP64__ into 1 like gcc does.
 
65
+       # This test works for both compilers.
 
66
+       if [ "$CC_FOR_BUILD" != 'no_compiler_found' ]; then
 
67
+           if (echo '#ifdef __amd64'; echo IS_64BIT_ARCH; echo '#endif') | \
 
68
+               (CCOPTS= $CC_FOR_BUILD -E - 2>/dev/null) | \
 
69
+               grep IS_64BIT_ARCH >/dev/null
 
70
+           then
 
71
+               SUN_ARCH="x86_64"
 
72
+           fi
 
73
+       fi
 
74
+       echo ${SUN_ARCH}-pc-solaris2`echo ${UNAME_RELEASE}|sed -e 's/[^.]*//'`
 
75
        exit ;;
 
76
     sun4*:SunOS:6*:*)
 
77
        # According to config.sub, this is the proper way to canonicalize
 
78
@@ -531,7 +548,7 @@ EOF
 
79
                echo rs6000-ibm-aix3.2
 
80
        fi
 
81
        exit ;;
 
82
-    *:AIX:*:[45])
 
83
+    *:AIX:*:[456])
 
84
        IBM_CPU_ID=`/usr/sbin/lsdev -C -c processor -S available | sed 1q | awk '{ print $1 }'`
 
85
        if /usr/sbin/lsattr -El ${IBM_CPU_ID} | grep ' POWER' >/dev/null 2>&1; then
 
86
                IBM_ARCH=rs6000
 
87
@@ -639,7 +656,7 @@ EOF
 
88
            # => hppa64-hp-hpux11.23
 
89
 
 
90
            if echo __LP64__ | (CCOPTS= $CC_FOR_BUILD -E - 2>/dev/null) |
 
91
-               grep __LP64__ >/dev/null
 
92
+               grep -q __LP64__
 
93
            then
 
94
                HP_ARCH="hppa2.0w"
 
95
            else
 
96
@@ -780,7 +797,7 @@ EOF
 
97
     i*:CYGWIN*:*)
 
98
        echo ${UNAME_MACHINE}-pc-cygwin
 
99
        exit ;;
 
100
-    i*:MINGW*:*)
 
101
+    *:MINGW*:*)
 
102
        echo ${UNAME_MACHINE}-pc-mingw32
 
103
        exit ;;
 
104
     i*:windows32*:*)
 
105
@@ -790,15 +807,24 @@ EOF
 
106
     i*:PW*:*)
 
107
        echo ${UNAME_MACHINE}-pc-pw32
 
108
        exit ;;
 
109
-    x86:Interix*:[3456]*)
 
110
-       echo i586-pc-interix${UNAME_RELEASE}
 
111
-       exit ;;
 
112
-    EM64T:Interix*:[3456]*)
 
113
-       echo x86_64-unknown-interix${UNAME_RELEASE}
 
114
-       exit ;;
 
115
+    *:Interix*:[3456]*)
 
116
+       case ${UNAME_MACHINE} in
 
117
+           x86)
 
118
+               echo i586-pc-interix${UNAME_RELEASE}
 
119
+               exit ;;
 
120
+           EM64T | authenticamd | genuineintel)
 
121
+               echo x86_64-unknown-interix${UNAME_RELEASE}
 
122
+               exit ;;
 
123
+           IA64)
 
124
+               echo ia64-unknown-interix${UNAME_RELEASE}
 
125
+               exit ;;
 
126
+       esac ;;
 
127
     [345]86:Windows_95:* | [345]86:Windows_98:* | [345]86:Windows_NT:*)
 
128
        echo i${UNAME_MACHINE}-pc-mks
 
129
        exit ;;
 
130
+    8664:Windows_NT:*)
 
131
+       echo x86_64-pc-mks
 
132
+       exit ;;
 
133
     i*:Windows_NT*:* | Pentium*:Windows_NT*:*)
 
134
        # How do we know it's Interix rather than the generic POSIX subsystem?
 
135
        # It also conflicts with pre-2.0 versions of AT&T UWIN. Should we
 
136
@@ -829,7 +855,14 @@ EOF
 
137
        echo ${UNAME_MACHINE}-pc-minix
 
138
        exit ;;
 
139
     arm*:Linux:*:*)
 
140
-       echo ${UNAME_MACHINE}-unknown-linux-gnu
 
141
+       eval $set_cc_for_build
 
142
+       if echo __ARM_EABI__ | $CC_FOR_BUILD -E - 2>/dev/null \
 
143
+           | grep -q __ARM_EABI__
 
144
+       then
 
145
+           echo ${UNAME_MACHINE}-unknown-linux-gnu
 
146
+       else
 
147
+           echo ${UNAME_MACHINE}-unknown-linux-gnueabi
 
148
+       fi
 
149
        exit ;;
 
150
     avr32*:Linux:*:*)
 
151
        echo ${UNAME_MACHINE}-unknown-linux-gnu
 
152
@@ -852,40 +885,17 @@ EOF
 
153
     m68*:Linux:*:*)
 
154
        echo ${UNAME_MACHINE}-unknown-linux-gnu
 
155
        exit ;;
 
156
-    mips:Linux:*:*)
 
157
+    mips:Linux:*:* | mips64:Linux:*:*)
 
158
        eval $set_cc_for_build
 
159
        sed 's/^        //' << EOF >$dummy.c
 
160
        #undef CPU
 
161
-       #undef mips
 
162
-       #undef mipsel
 
163
+       #undef ${UNAME_MACHINE}
 
164
+       #undef ${UNAME_MACHINE}el
 
165
        #if defined(__MIPSEL__) || defined(__MIPSEL) || defined(_MIPSEL) || defined(MIPSEL)
 
166
-       CPU=mipsel
 
167
+       CPU=${UNAME_MACHINE}el
 
168
        #else
 
169
        #if defined(__MIPSEB__) || defined(__MIPSEB) || defined(_MIPSEB) || defined(MIPSEB)
 
170
-       CPU=mips
 
171
-       #else
 
172
-       CPU=
 
173
-       #endif
 
174
-       #endif
 
175
-EOF
 
176
-       eval "`$CC_FOR_BUILD -E $dummy.c 2>/dev/null | sed -n '
 
177
-           /^CPU/{
 
178
-               s: ::g
 
179
-               p
 
180
-           }'`"
 
181
-       test x"${CPU}" != x && { echo "${CPU}-unknown-linux-gnu"; exit; }
 
182
-       ;;
 
183
-    mips64:Linux:*:*)
 
184
-       eval $set_cc_for_build
 
185
-       sed 's/^        //' << EOF >$dummy.c
 
186
-       #undef CPU
 
187
-       #undef mips64
 
188
-       #undef mips64el
 
189
-       #if defined(__MIPSEL__) || defined(__MIPSEL) || defined(_MIPSEL) || defined(MIPSEL)
 
190
-       CPU=mips64el
 
191
-       #else
 
192
-       #if defined(__MIPSEB__) || defined(__MIPSEB) || defined(_MIPSEB) || defined(MIPSEB)
 
193
-       CPU=mips64
 
194
+       CPU=${UNAME_MACHINE}
 
195
        #else
 
196
        CPU=
 
197
        #endif
 
198
@@ -917,10 +927,13 @@ EOF
 
199
          EV67)  UNAME_MACHINE=alphaev67 ;;
 
200
          EV68*) UNAME_MACHINE=alphaev68 ;;
 
201
         esac
 
202
-       objdump --private-headers /bin/sh | grep ld.so.1 >/dev/null
 
203
+       objdump --private-headers /bin/sh | grep -q ld.so.1
 
204
        if test "$?" = 0 ; then LIBC="libc1" ; else LIBC="" ; fi
 
205
        echo ${UNAME_MACHINE}-unknown-linux-gnu${LIBC}
 
206
        exit ;;
 
207
+    padre:Linux:*:*)
 
208
+       echo sparc-unknown-linux-gnu
 
209
+       exit ;;
 
210
     parisc:Linux:*:* | hppa:Linux:*:*)
 
211
        # Look for CPU level
 
212
        case `grep '^cpu[^a-z]*:' /proc/cpuinfo 2>/dev/null | cut -d' ' -f2` in
 
213
@@ -950,6 +963,9 @@ EOF
 
214
     x86_64:Linux:*:*)
 
215
        echo x86_64-unknown-linux-gnu
 
216
        exit ;;
 
217
+    xtensa*:Linux:*:*)
 
218
+       echo ${UNAME_MACHINE}-unknown-linux-gnu
 
219
+       exit ;;
 
220
     i*86:Linux:*:*)
 
221
        # The BFD linker knows what the default object file format is, so
 
222
        # first see if it will tell us. cd to the root directory to prevent
 
223
@@ -965,17 +981,6 @@ EOF
 
224
          elf32-i386)
 
225
                TENTATIVE="${UNAME_MACHINE}-pc-linux-gnu"
 
226
                ;;
 
227
-         a.out-i386-linux)
 
228
-               echo "${UNAME_MACHINE}-pc-linux-gnuaout"
 
229
-               exit ;;
 
230
-         coff-i386)
 
231
-               echo "${UNAME_MACHINE}-pc-linux-gnucoff"
 
232
-               exit ;;
 
233
-         "")
 
234
-               # Either a pre-BFD a.out linker (linux-gnuoldld) or
 
235
-               # one that does not give us useful --help.
 
236
-               echo "${UNAME_MACHINE}-pc-linux-gnuoldld"
 
237
-               exit ;;
 
238
        esac
 
239
        # Determine whether the default compiler is a.out or elf
 
240
        eval $set_cc_for_build
 
241
@@ -1041,7 +1046,7 @@ EOF
 
242
     i*86:syllable:*:*)
 
243
        echo ${UNAME_MACHINE}-pc-syllable
 
244
        exit ;;
 
245
-    i*86:LynxOS:2.*:* | i*86:LynxOS:3.[01]*:* | i*86:LynxOS:4.0*:*)
 
246
+    i*86:LynxOS:2.*:* | i*86:LynxOS:3.[01]*:* | i*86:LynxOS:4.[02]*:*)
 
247
        echo i386-unknown-lynxos${UNAME_RELEASE}
 
248
        exit ;;
 
249
     i*86:*DOS:*:*)
 
250
@@ -1085,8 +1090,11 @@ EOF
 
251
     pc:*:*:*)
 
252
        # Left here for compatibility:
 
253
         # uname -m prints for DJGPP always 'pc', but it prints nothing about
 
254
-        # the processor, so we play safe by assuming i386.
 
255
-       echo i386-pc-msdosdjgpp
 
256
+        # the processor, so we play safe by assuming i586.
 
257
+       # Note: whatever this is, it MUST be the same as what config.sub
 
258
+       # prints for the "djgpp" host, or else GDB configury will decide that
 
259
+       # this is a cross-build.
 
260
+       echo i586-pc-msdosdjgpp
 
261
         exit ;;
 
262
     Intel:Mach:3*:*)
 
263
        echo i386-pc-mach3
 
264
@@ -1124,6 +1132,16 @@ EOF
 
265
     3[34]??:*:4.0:* | 3[34]??,*:*:4.0:*)
 
266
         /bin/uname -p 2>/dev/null | grep 86 >/dev/null \
 
267
           && { echo i486-ncr-sysv4; exit; } ;;
 
268
+    NCR*:*:4.2:* | MPRAS*:*:4.2:*)
 
269
+       OS_REL='.3'
 
270
+       test -r /etc/.relid \
 
271
+           && OS_REL=.`sed -n 's/[^ ]* [^ ]* \([0-9][0-9]\).*/\1/p' < /etc/.relid`
 
272
+       /bin/uname -p 2>/dev/null | grep 86 >/dev/null \
 
273
+           && { echo i486-ncr-sysv4.3${OS_REL}; exit; }
 
274
+       /bin/uname -p 2>/dev/null | /bin/grep entium >/dev/null \
 
275
+           && { echo i586-ncr-sysv4.3${OS_REL}; exit; }
 
276
+       /bin/uname -p 2>/dev/null | /bin/grep pteron >/dev/null \
 
277
+           && { echo i586-ncr-sysv4.3${OS_REL}; exit; } ;;
 
278
     m68*:LynxOS:2.*:* | m68*:LynxOS:3.0*:*)
 
279
        echo m68k-unknown-lynxos${UNAME_RELEASE}
 
280
        exit ;;
 
281
@@ -1136,7 +1154,7 @@ EOF
 
282
     rs6000:LynxOS:2.*:*)
 
283
        echo rs6000-unknown-lynxos${UNAME_RELEASE}
 
284
        exit ;;
 
285
-    PowerPC:LynxOS:2.*:* | PowerPC:LynxOS:3.[01]*:* | PowerPC:LynxOS:4.0*:*)
 
286
+    PowerPC:LynxOS:2.*:* | PowerPC:LynxOS:3.[01]*:* | PowerPC:LynxOS:4.[02]*:*)
 
287
        echo powerpc-unknown-lynxos${UNAME_RELEASE}
 
288
        exit ;;
 
289
     SM[BE]S:UNIX_SV:*:*)
 
290
@@ -1199,6 +1217,9 @@ EOF
 
291
     BePC:BeOS:*:*)     # BeOS running on Intel PC compatible.
 
292
        echo i586-pc-beos
 
293
        exit ;;
 
294
+    BePC:Haiku:*:*)    # Haiku running on Intel PC compatible.
 
295
+       echo i586-pc-haiku
 
296
+       exit ;;
 
297
     SX-4:SUPER-UX:*:*)
 
298
        echo sx4-nec-superux${UNAME_RELEASE}
 
299
        exit ;;
 
300
@@ -1208,6 +1229,15 @@ EOF
 
301
     SX-6:SUPER-UX:*:*)
 
302
        echo sx6-nec-superux${UNAME_RELEASE}
 
303
        exit ;;
 
304
+    SX-7:SUPER-UX:*:*)
 
305
+       echo sx7-nec-superux${UNAME_RELEASE}
 
306
+       exit ;;
 
307
+    SX-8:SUPER-UX:*:*)
 
308
+       echo sx8-nec-superux${UNAME_RELEASE}
 
309
+       exit ;;
 
310
+    SX-8R:SUPER-UX:*:*)
 
311
+       echo sx8r-nec-superux${UNAME_RELEASE}
 
312
+       exit ;;
 
313
     Power*:Rhapsody:*:*)
 
314
        echo powerpc-apple-rhapsody${UNAME_RELEASE}
 
315
        exit ;;
 
316
@@ -1298,6 +1328,9 @@ EOF
 
317
     i*86:rdos:*:*)
 
318
        echo ${UNAME_MACHINE}-pc-rdos
 
319
        exit ;;
 
320
+    i*86:AROS:*:*)
 
321
+       echo ${UNAME_MACHINE}-pc-aros
 
322
+       exit ;;
 
323
 esac
 
324
 
 
325
 #echo '(No uname command or uname output not recognized.)' 1>&2
 
326
@@ -1458,9 +1491,9 @@ This script, last modified $timestamp, h
 
327
 the operating system you are using. It is advised that you
 
328
 download the most up to date version of the config scripts from
 
329
 
 
330
-  http://savannah.gnu.org/cgi-bin/viewcvs/*checkout*/config/config/config.guess
 
331
+  http://git.savannah.gnu.org/gitweb/?p=config.git;a=blob_plain;f=config.guess;hb=HEAD
 
332
 and
 
333
-  http://savannah.gnu.org/cgi-bin/viewcvs/*checkout*/config/config/config.sub
 
334
+  http://git.savannah.gnu.org/gitweb/?p=config.git;a=blob_plain;f=config.sub;hb=HEAD
 
335
 
 
336
 If the version you run ($0) is already up to date, please
 
337
 send the following data and any information you think might be
 
338
--- gnupg2-2.0.14.orig/config.sub
 
339
+++ gnupg2-2.0.14/config.sub
 
340
@@ -1,10 +1,10 @@
 
341
 #! /bin/sh
 
342
 # Configuration validation subroutine script.
 
343
 #   Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999,
 
344
-#   2000, 2001, 2002, 2003, 2004, 2005, 2006 Free Software Foundation,
 
345
-#   Inc.
 
346
+#   2000, 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009
 
347
+#   Free Software Foundation, Inc.
 
348
 
 
349
-timestamp='2006-09-20'
 
350
+timestamp='2009-06-11'
 
351
 
 
352
 # This file is (in principle) common to ALL GNU software.
 
353
 # The presence of a machine in this file suggests that SOME GNU software
 
354
@@ -72,8 +72,8 @@ Report bugs and patches to <config-patch
 
355
 version="\
 
356
 GNU config.sub ($timestamp)
 
357
 
 
358
-Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2004, 2005
 
359
-Free Software Foundation, Inc.
 
360
+Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001,
 
361
+2002, 2003, 2004, 2005, 2006, 2007, 2008 Free Software Foundation, Inc.
 
362
 
 
363
 This is free software; see the source for copying conditions.  There is NO
 
364
 warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE."
 
365
@@ -122,6 +122,7 @@ maybe_os=`echo $1 | sed 's/^\(.*\)-\([^-
 
366
 case $maybe_os in
 
367
   nto-qnx* | linux-gnu* | linux-dietlibc | linux-newlib* | linux-uclibc* | \
 
368
   uclinux-uclibc* | uclinux-gnu* | kfreebsd*-gnu* | knetbsd*-gnu* | netbsd*-gnu* | \
 
369
+  kopensolaris*-gnu* | \
 
370
   storm-chaos* | os2-emx* | rtmk-nova*)
 
371
     os=-$maybe_os
 
372
     basic_machine=`echo $1 | sed 's/^\(.*\)-\([^-]*-[^-]*\)$/\1/'`
 
373
@@ -152,6 +153,9 @@ case $os in
 
374
                os=
 
375
                basic_machine=$1
 
376
                ;;
 
377
+        -bluegene*)
 
378
+               os=-cnk
 
379
+               ;;
 
380
        -sim | -cisco | -oki | -wec | -winbond)
 
381
                os=
 
382
                basic_machine=$1
 
383
@@ -245,17 +249,20 @@ case $basic_machine in
 
384
        | bfin \
 
385
        | c4x | clipper \
 
386
        | d10v | d30v | dlx | dsp16xx \
 
387
-       | fr30 | frv \
 
388
+       | fido | fr30 | frv \
 
389
        | h8300 | h8500 | hppa | hppa1.[01] | hppa2.0 | hppa2.0[nw] | hppa64 \
 
390
        | i370 | i860 | i960 | ia64 \
 
391
        | ip2k | iq2000 \
 
392
+       | lm32 \
 
393
        | m32c | m32r | m32rle | m68000 | m68k | m88k \
 
394
-       | maxq | mb | microblaze | mcore \
 
395
+       | maxq | mb | microblaze | mcore | mep | metag \
 
396
        | mips | mipsbe | mipseb | mipsel | mipsle \
 
397
        | mips16 \
 
398
        | mips64 | mips64el \
 
399
-       | mips64vr | mips64vrel \
 
400
+       | mips64octeon | mips64octeonel \
 
401
        | mips64orion | mips64orionel \
 
402
+       | mips64r5900 | mips64r5900el \
 
403
+       | mips64vr | mips64vrel \
 
404
        | mips64vr4100 | mips64vr4100el \
 
405
        | mips64vr4300 | mips64vr4300el \
 
406
        | mips64vr5000 | mips64vr5000el \
 
407
@@ -268,6 +275,7 @@ case $basic_machine in
 
408
        | mipsisa64sr71k | mipsisa64sr71kel \
 
409
        | mipstx39 | mipstx39el \
 
410
        | mn10200 | mn10300 \
 
411
+       | moxie \
 
412
        | mt \
 
413
        | msp430 \
 
414
        | nios | nios2 \
 
415
@@ -277,7 +285,7 @@ case $basic_machine in
 
416
        | powerpc | powerpc64 | powerpc64le | powerpcle | ppcbe \
 
417
        | pyramid \
 
418
        | score \
 
419
-       | sh | sh[1234] | sh[24]a | sh[23]e | sh[34]eb | sheb | shbe | shle | sh[1234]le | sh3ele \
 
420
+       | sh | sh[1234] | sh[24]a | sh[24]aeb | sh[23]e | sh[34]eb | sheb | shbe | shle | sh[1234]le | sh3ele \
 
421
        | sh64 | sh64le \
 
422
        | sparc | sparc64 | sparc64b | sparc64v | sparc86x | sparclet | sparclite \
 
423
        | sparcv8 | sparcv9 | sparcv9b | sparcv9v \
 
424
@@ -286,7 +294,7 @@ case $basic_machine in
 
425
        | v850 | v850e \
 
426
        | we32k \
 
427
        | x86 | xc16x | xscale | xscalee[bl] | xstormy16 | xtensa \
 
428
-       | z8k)
 
429
+       | z8k | z80)
 
430
                basic_machine=$basic_machine-unknown
 
431
                ;;
 
432
        m6811 | m68hc11 | m6812 | m68hc12)
 
433
@@ -324,19 +332,22 @@ case $basic_machine in
 
434
        | clipper-* | craynv-* | cydra-* \
 
435
        | d10v-* | d30v-* | dlx-* \
 
436
        | elxsi-* \
 
437
-       | f30[01]-* | f700-* | fr30-* | frv-* | fx80-* \
 
438
+       | f30[01]-* | f700-* | fido-* | fr30-* | frv-* | fx80-* \
 
439
        | h8300-* | h8500-* \
 
440
        | hppa-* | hppa1.[01]-* | hppa2.0-* | hppa2.0[nw]-* | hppa64-* \
 
441
        | i*86-* | i860-* | i960-* | ia64-* \
 
442
        | ip2k-* | iq2000-* \
 
443
+       | lm32-* \
 
444
        | m32c-* | m32r-* | m32rle-* \
 
445
        | m68000-* | m680[012346]0-* | m68360-* | m683?2-* | m68k-* \
 
446
-       | m88110-* | m88k-* | maxq-* | mcore-* \
 
447
+       | m88110-* | m88k-* | maxq-* | mcore-* | metag-* \
 
448
        | mips-* | mipsbe-* | mipseb-* | mipsel-* | mipsle-* \
 
449
        | mips16-* \
 
450
        | mips64-* | mips64el-* \
 
451
-       | mips64vr-* | mips64vrel-* \
 
452
+       | mips64octeon-* | mips64octeonel-* \
 
453
        | mips64orion-* | mips64orionel-* \
 
454
+       | mips64r5900-* | mips64r5900el-* \
 
455
+       | mips64vr-* | mips64vrel-* \
 
456
        | mips64vr4100-* | mips64vr4100el-* \
 
457
        | mips64vr4300-* | mips64vr4300el-* \
 
458
        | mips64vr5000-* | mips64vr5000el-* \
 
459
@@ -358,20 +369,24 @@ case $basic_machine in
 
460
        | powerpc-* | powerpc64-* | powerpc64le-* | powerpcle-* | ppcbe-* \
 
461
        | pyramid-* \
 
462
        | romp-* | rs6000-* \
 
463
-       | sh-* | sh[1234]-* | sh[24]a-* | sh[23]e-* | sh[34]eb-* | sheb-* | shbe-* \
 
464
+       | sh-* | sh[1234]-* | sh[24]a-* | sh[24]aeb-* | sh[23]e-* | sh[34]eb-* | sheb-* | shbe-* \
 
465
        | shle-* | sh[1234]le-* | sh3ele-* | sh64-* | sh64le-* \
 
466
        | sparc-* | sparc64-* | sparc64b-* | sparc64v-* | sparc86x-* | sparclet-* \
 
467
        | sparclite-* \
 
468
        | sparcv8-* | sparcv9-* | sparcv9b-* | sparcv9v-* | strongarm-* | sv1-* | sx?-* \
 
469
        | tahoe-* | thumb-* \
 
470
-       | tic30-* | tic4x-* | tic54x-* | tic55x-* | tic6x-* | tic80-* \
 
471
+       | tic30-* | tic4x-* | tic54x-* | tic55x-* | tic6x-* | tic80-* | tile-* \
 
472
        | tron-* \
 
473
        | v850-* | v850e-* | vax-* \
 
474
        | we32k-* \
 
475
        | x86-* | x86_64-* | xc16x-* | xps100-* | xscale-* | xscalee[bl]-* \
 
476
-       | xstormy16-* | xtensa-* \
 
477
+       | xstormy16-* | xtensa*-* \
 
478
        | ymp-* \
 
479
-       | z8k-*)
 
480
+       | z8k-* | z80-*)
 
481
+               ;;
 
482
+       # Recognize the basic CPU types without company name, with glob match.
 
483
+       xtensa*)
 
484
+               basic_machine=$basic_machine-unknown
 
485
                ;;
 
486
        # Recognize the various machine names and aliases which stand
 
487
        # for a CPU type and a company and sometimes even an OS.
 
488
@@ -435,6 +450,10 @@ case $basic_machine in
 
489
                basic_machine=m68k-apollo
 
490
                os=-bsd
 
491
                ;;
 
492
+       aros)
 
493
+               basic_machine=i386-pc
 
494
+               os=-aros
 
495
+               ;;
 
496
        aux)
 
497
                basic_machine=m68k-apple
 
498
                os=-aux
 
499
@@ -443,10 +462,26 @@ case $basic_machine in
 
500
                basic_machine=ns32k-sequent
 
501
                os=-dynix
 
502
                ;;
 
503
+       blackfin)
 
504
+               basic_machine=bfin-unknown
 
505
+               os=-linux
 
506
+               ;;
 
507
+       blackfin-*)
 
508
+               basic_machine=bfin-`echo $basic_machine | sed 's/^[^-]*-//'`
 
509
+               os=-linux
 
510
+               ;;
 
511
+       bluegene*)
 
512
+               basic_machine=powerpc-ibm
 
513
+               os=-cnk
 
514
+               ;;
 
515
        c90)
 
516
                basic_machine=c90-cray
 
517
                os=-unicos
 
518
                ;;
 
519
+        cegcc)
 
520
+               basic_machine=arm-unknown
 
521
+               os=-cegcc
 
522
+               ;;
 
523
        convex-c1)
 
524
                basic_machine=c1-convex
 
525
                os=-bsd
 
526
@@ -475,8 +510,8 @@ case $basic_machine in
 
527
                basic_machine=craynv-cray
 
528
                os=-unicosmp
 
529
                ;;
 
530
-       cr16c)
 
531
-               basic_machine=cr16c-unknown
 
532
+       cr16)
 
533
+               basic_machine=cr16-unknown
 
534
                os=-elf
 
535
                ;;
 
536
        crds | unos)
 
537
@@ -514,6 +549,10 @@ case $basic_machine in
 
538
                basic_machine=m88k-motorola
 
539
                os=-sysv3
 
540
                ;;
 
541
+       dicos)
 
542
+               basic_machine=i686-pc
 
543
+               os=-dicos
 
544
+               ;;
 
545
        djgpp)
 
546
                basic_machine=i586-pc
 
547
                os=-msdosdjgpp
 
548
@@ -668,6 +707,14 @@ case $basic_machine in
 
549
                basic_machine=m68k-isi
 
550
                os=-sysv
 
551
                ;;
 
552
+       m68knommu)
 
553
+               basic_machine=m68k-unknown
 
554
+               os=-linux
 
555
+               ;;
 
556
+       m68knommu-*)
 
557
+               basic_machine=m68k-`echo $basic_machine | sed 's/^[^-]*-//'`
 
558
+               os=-linux
 
559
+               ;;
 
560
        m88k-omron*)
 
561
                basic_machine=m88k-omron
 
562
                ;;
 
563
@@ -683,6 +730,10 @@ case $basic_machine in
 
564
                basic_machine=i386-pc
 
565
                os=-mingw32
 
566
                ;;
 
567
+       mingw32ce)
 
568
+               basic_machine=arm-unknown
 
569
+               os=-mingw32ce
 
570
+               ;;
 
571
        miniframe)
 
572
                basic_machine=m68000-convergent
 
573
                ;;
 
574
@@ -809,6 +860,14 @@ case $basic_machine in
 
575
                basic_machine=i860-intel
 
576
                os=-osf
 
577
                ;;
 
578
+       parisc)
 
579
+               basic_machine=hppa-unknown
 
580
+               os=-linux
 
581
+               ;;
 
582
+       parisc-*)
 
583
+               basic_machine=hppa-`echo $basic_machine | sed 's/^[^-]*-//'`
 
584
+               os=-linux
 
585
+               ;;
 
586
        pbd)
 
587
                basic_machine=sparc-tti
 
588
                ;;
 
589
@@ -925,6 +984,9 @@ case $basic_machine in
 
590
                basic_machine=sh-hitachi
 
591
                os=-hms
 
592
                ;;
 
593
+       sh5el)
 
594
+               basic_machine=sh5le-unknown
 
595
+               ;;
 
596
        sh64)
 
597
                basic_machine=sh64-unknown
 
598
                ;;
 
599
@@ -1014,6 +1076,10 @@ case $basic_machine in
 
600
                basic_machine=tic6x-unknown
 
601
                os=-coff
 
602
                ;;
 
603
+       tile*)
 
604
+               basic_machine=tile-unknown
 
605
+               os=-linux-gnu
 
606
+               ;;
 
607
        tx39)
 
608
                basic_machine=mipstx39-unknown
 
609
                ;;
 
610
@@ -1089,6 +1155,10 @@ case $basic_machine in
 
611
                basic_machine=z8k-unknown
 
612
                os=-sim
 
613
                ;;
 
614
+       z80-*-coff)
 
615
+               basic_machine=z80-unknown
 
616
+               os=-sim
 
617
+               ;;
 
618
        none)
 
619
                basic_machine=none-none
 
620
                os=-none
 
621
@@ -1127,7 +1197,7 @@ case $basic_machine in
 
622
        we32k)
 
623
                basic_machine=we32k-att
 
624
                ;;
 
625
-       sh[1234] | sh[24]a | sh[34]eb | sh[1234]le | sh[23]ele)
 
626
+       sh[1234] | sh[24]a | sh[24]aeb | sh[34]eb | sh[1234]le | sh[23]ele)
 
627
                basic_machine=sh-unknown
 
628
                ;;
 
629
        sparc | sparcv8 | sparcv9 | sparcv9b | sparcv9v)
 
630
@@ -1197,10 +1267,11 @@ case $os in
 
631
        # Each alternative MUST END IN A *, to match a version number.
 
632
        # -sysv* is not here because it comes later, after sysvr4.
 
633
        -gnu* | -bsd* | -mach* | -minix* | -genix* | -ultrix* | -irix* \
 
634
-             | -*vms* | -sco* | -esix* | -isc* | -aix* | -sunos | -sunos[34]*\
 
635
+             | -*vms* | -sco* | -esix* | -isc* | -aix* | -cnk* | -sunos | -sunos[34]*\
 
636
              | -hpux* | -unos* | -osf* | -luna* | -dgux* | -solaris* | -sym* \
 
637
+             | -kopensolaris* \
 
638
              | -amigaos* | -amigados* | -msdos* | -newsos* | -unicos* | -aof* \
 
639
-             | -aos* \
 
640
+             | -aos* | -aros* \
 
641
              | -nindy* | -vxsim* | -vxworks* | -ebmon* | -hms* | -mvs* \
 
642
              | -clix* | -riscos* | -uniplus* | -iris* | -rtu* | -xenix* \
 
643
              | -hiux* | -386bsd* | -knetbsd* | -mirbsd* | -netbsd* \
 
644
@@ -1209,7 +1280,7 @@ case $os in
 
645
              | -bosx* | -nextstep* | -cxux* | -aout* | -elf* | -oabi* \
 
646
              | -ptx* | -coff* | -ecoff* | -winnt* | -domain* | -vsta* \
 
647
              | -udi* | -eabi* | -lites* | -ieee* | -go32* | -aux* \
 
648
-             | -chorusos* | -chorusrdb* \
 
649
+             | -chorusos* | -chorusrdb* | -cegcc* \
 
650
              | -cygwin* | -pe* | -psos* | -moss* | -proelf* | -rtems* \
 
651
              | -mingw32* | -linux-gnu* | -linux-newlib* | -linux-uclibc* \
 
652
              | -uxpv* | -beos* | -mpeix* | -udk* \
 
653
@@ -1219,7 +1290,7 @@ case $os in
 
654
              | -os2* | -vos* | -palmos* | -uclinux* | -nucleus* \
 
655
              | -morphos* | -superux* | -rtmk* | -rtmk-nova* | -windiss* \
 
656
              | -powermax* | -dnix* | -nx6 | -nx7 | -sei* | -dragonfly* \
 
657
-             | -skyos* | -haiku* | -rdos* | -toppers*)
 
658
+             | -skyos* | -haiku* | -rdos* | -toppers* | -drops*)
 
659
        # Remember, each alternative MUST END IN *, to match a version number.
 
660
                ;;
 
661
        -qnx*)
 
662
@@ -1349,6 +1420,9 @@ case $os in
 
663
        -zvmoe)
 
664
                os=-zvmoe
 
665
                ;;
 
666
+       -dicos*)
 
667
+               os=-dicos
 
668
+               ;;
 
669
        -none)
 
670
                ;;
 
671
        *)
 
672
@@ -1414,6 +1488,9 @@ case $basic_machine in
 
673
        m68*-cisco)
 
674
                os=-aout
 
675
                ;;
 
676
+        mep-*)
 
677
+               os=-elf
 
678
+               ;;
 
679
        mips*-cisco)
 
680
                os=-elf
 
681
                ;;
 
682
@@ -1543,7 +1620,7 @@ case $basic_machine in
 
683
                        -sunos*)
 
684
                                vendor=sun
 
685
                                ;;
 
686
-                       -aix*)
 
687
+                       -cnk*|-aix*)
 
688
                                vendor=ibm
 
689
                                ;;
 
690
                        -beos*)