~ubuntu-branches/ubuntu/precise/virt-manager/precise-proposed

« back to all changes in this revision

Viewing changes to debian/patches/fix-cpu-wrong-types.patch

  • Committer: Bazaar Package Importer
  • Author(s): Marc Deslauriers
  • Date: 2011-05-18 14:11:16 UTC
  • mfrom: (2.1.24 sid)
  • Revision ID: james.westby@ubuntu.com-20110518141116-3457j7twra3zlpve
Tags: 0.8.7-1ubuntu1
* Merge from debian unstable. Remaining changes: (LP: #747078)
  - debian/control: Depend on python-appindicator for appindicator
    support.
  - Add a /usr/share/pixmaps/virt-manager-icon.svg symlink to link icon to
    where the Application Indicator can find it.
  - debian/patches/more_helpful_error_message.patch: explain to the user
    why he can't connect to qemu:///system and what he can do fix it.
  - debian/control: lower libvirt-bin from Recommends to Suggests; seems
    some users (like netbooks) want to manage VMs, but not host them; see
    meta packages (ubuntu-virt, ubuntu-virt-server, ubuntu-virt-mgmt) for
    group installation of virt package sets.
  - debian/patches/use_ubuntu_package_names.patch: Suggest installing the
    packages that are actually available in Ubuntu.
  - debian/rules: Set qemu user to libvirt-qemu so appropriate
    permissions get set.
  - debian/rules: Set Ubuntu as the preferred distro so we appear first
    in the list.
  - debian/rules: disable TUI for now, since the required dependencies
    are not available (Newt Syrup).
  - debian/rules: Drop patchsys-quilt include since dpkg-source does the
    quilt dance for us.
  - debian/patches/fork_before_using_gconf.patch: fork earlier to resolve
    cpu usage issue and appindicator issue.
  - Removed python-ipy dependency as it is in universe:
    - debian/control: remove python-ipy from Depends
    - debian/series: disable 0002-Use-IPy-from-python-ipy.patch patch so
      we use the one that's included in the virt-manager source.
    - debian/rules: don't delete the IPy file.
* Removed patches:
  - debian/patches/dont-always-launch-consoles.patch: Upstream
  - debian/patches/fix_apparmor_details.patch: Upstream
  - debian/patches/fix-cpu-wrong-types.patch: Upstream
  - debian/patches/no_hal_traceback.patch: Upstream

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Description: fix "value is of wrong type for this column" error by making
2
 
 sure we are using strings.
3
 
Author: Marc Deslauriers <marc.deslauriers@canonical.com>
4
 
Forwarded: https://www.redhat.com/archives/virt-tools-list/2011-February/msg00039.html
5
 
 
6
 
Index: virt-manager-0.8.6/src/virtManager/details.py
7
 
===================================================================
8
 
--- virt-manager-0.8.6.orig/src/virtManager/details.py  2011-02-03 10:34:24.000000000 -0500
9
 
+++ virt-manager-0.8.6/src/virtManager/details.py       2011-02-03 10:34:56.000000000 -0500
10
 
@@ -2047,8 +2047,8 @@
11
 
             return pinstr.strip(",")
12
 
 
13
 
         for idx in range(len(vcpu_info)):
14
 
-            vcpu = vcpu_info[idx][0]
15
 
-            vcpucur = vcpu_info[idx][3]
16
 
+            vcpu = str(vcpu_info[idx][0])
17
 
+            vcpucur = str(vcpu_info[idx][3])
18
 
             vcpupin = build_cpuset_str(vcpu_pinning[idx])
19
 
 
20
 
             vcpu_model.append([vcpu, vcpucur, vcpupin])