~ubuntu-branches/ubuntu/quantal/ruby1.9.1/quantal

« back to all changes in this revision

Viewing changes to debian/patches/203_adjust_base_of_search_path.diff

  • Committer: Bazaar Package Importer
  • Author(s): Lucas Nussbaum
  • Date: 2011-09-24 19:16:17 UTC
  • mfrom: (1.1.8 upstream) (13.1.7 experimental)
  • Revision ID: james.westby@ubuntu.com-20110924191617-o1qz4rcmqjot8zuy
Tags: 1.9.3~rc1-1
* New upstream release: 1.9.3 RC1.
  + Includes load.c fixes. Closes: #639959.
* Upload to unstable.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## 203_adjust_base_of_search_path.dpatch by akira yamada <akira@debian.org>
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: change basedir of search path to /usr/lib/ruby from /usr/lib/ruby1.9.
6
 
 
7
 
@DPATCH@
8
 
Index: b/configure.in
9
 
===================================================================
10
 
--- a/configure.in      2010-07-20 21:45:46.000000000 +0900
11
 
+++ b/configure.in      2010-07-20 21:46:13.000000000 +0900
12
 
@@ -2003,7 +2003,7 @@
13
 
     rubyw_install_name="$RUBYW_INSTALL_NAME"
14
 
     ;;
15
 
 esac
16
 
-RUBY_LIB_PREFIX=`eval echo \\"${libdir}/${RUBY_INSTALL_NAME}\\"`
17
 
+RUBY_LIB_PREFIX=`eval echo \\"${libdir}/ruby\\"`
18
 
 
19
 
 AC_ARG_WITH(ruby-version,
20
 
            [  --with-ruby-version=STR ruby version string for version specific directories [[full]] (full|minor|STR)],
21
 
Index: b/mkconfig.rb
22
 
===================================================================
23
 
--- a/mkconfig.rb       2010-07-20 21:45:46.000000000 +0900
24
 
+++ b/mkconfig.rb       2010-07-20 21:46:13.000000000 +0900
25
 
@@ -140,7 +140,7 @@
26
 
 print(*v_fast)
27
 
 print(*v_others)
28
 
 print <<EOS
29
 
-  CONFIG["rubylibdir"] = "$(libdir)/$(ruby_install_name)/$(ruby_version)"
30
 
+  CONFIG["rubylibdir"] = "$(libdir)/ruby/$(ruby_version)"
31
 
   CONFIG["archdir"] = "$(rubylibdir)/$(arch)"
32
 
   CONFIG["sitelibdir"] = "$(sitedir)/$(ruby_version)"
33
 
   CONFIG["sitearchdir"] = "$(sitelibdir)/$(sitearch)"