~ubuntu-branches/ubuntu/quantal/ruby1.9.1/quantal

« back to all changes in this revision

Viewing changes to debian/patches/931_libruby_suffix.diff

  • Committer: Bazaar Package Importer
  • Author(s): Lucas Nussbaum
  • Date: 2011-09-24 19:16:17 UTC
  • mfrom: (1.1.8 upstream) (13.1.7 experimental)
  • Revision ID: james.westby@ubuntu.com-20110924191617-o1qz4rcmqjot8zuy
Tags: 1.9.3~rc1-1
* New upstream release: 1.9.3 RC1.
  + Includes load.c fixes. Closes: #639959.
* Upload to unstable.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## 931_libruby_suffix.dpatch by akira yamada <akira@debian.org>
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: changes name of ruby runtime library to libRUBYNAME-1.9.1.so* from libRUBYNAME.so*
6
 
 
7
 
@DPATCH@
8
 
Index: b/configure.in
9
 
===================================================================
10
 
--- a/configure.in      2010-07-20 21:46:15.000000000 +0900
11
 
+++ b/configure.in      2010-07-20 21:46:15.000000000 +0900
12
 
@@ -1702,7 +1702,7 @@
13
 
     ;;
14
 
 esac
15
 
 
16
 
-RUBY_SO_NAME='$(RUBY_INSTALL_NAME)'
17
 
+RUBY_SO_NAME='ruby-1.9.1'
18
 
 LIBRUBY_LDSHARED=$LDSHARED
19
 
 LIBRUBY_DLDFLAGS=$DLDFLAGS
20
 
 LIBRUBY_SO='lib$(RUBY_SO_NAME).so.$(MAJOR).$(MINOR).$(TEENY)'
21
 
@@ -2019,13 +2019,13 @@
22
 
 AC_ARG_WITH(sitedir,
23
 
            [  --with-sitedir=DIR      site libraries in DIR [[LIBDIR/ruby/site_ruby]]],
24
 
             [sitedir=$withval],
25
 
-            [sitedir='${libdir}/${RUBY_INSTALL_NAME}/site_ruby'])
26
 
+            [sitedir='${libdir}/ruby/site_ruby'])
27
 
 SITE_DIR=`eval echo \\"${sitedir}\\"`
28
 
 
29
 
 AC_ARG_WITH(vendordir,
30
 
            [  --with-vendordir=DIR    vendor libraries in DIR [[LIBDIR/ruby/vendor_ruby]]],
31
 
             [vendordir=$withval],
32
 
-            [vendordir='${libdir}/${RUBY_INSTALL_NAME}/vendor_ruby'])
33
 
+            [vendordir='${libdir}/ruby/vendor_ruby'])
34
 
 VENDOR_DIR=`eval echo \\"${vendordir}\\"`
35
 
 
36
 
 case "$target_os" in
37
 
@@ -2094,7 +2094,7 @@
38
 
 AC_ARG_WITH(rubyhdrdir,
39
 
            AS_HELP_STRING([--with-rubyhdrdir=DIR], [core headers in DIR [[INCLUDEDIR/RUBY_BASE_NAME-RUBY_VERSION]]]),
40
 
            [rubyhdrdir=$withval],
41
 
-           [rubyhdrdir='${includedir}/${RUBY_INSTALL_NAME}-${ruby_version}'])
42
 
+           [rubyhdrdir='${includedir}/ruby-${ruby_version}'])
43
 
 
44
 
 AC_ARG_WITH(sitehdrdir,
45
 
            [  --with-site-hdrdir=DIR  core headers in DIR [INCLUDEDIR]],