~ubuntu-branches/ubuntu/quantal/ruby1.9.1/quantal

« back to all changes in this revision

Viewing changes to debian/patches/904_linux_target_os.diff

  • Committer: Bazaar Package Importer
  • Author(s): Lucas Nussbaum
  • Date: 2011-09-24 19:16:17 UTC
  • mfrom: (1.1.8 upstream) (13.1.7 experimental)
  • Revision ID: james.westby@ubuntu.com-20110924191617-o1qz4rcmqjot8zuy
Tags: 1.9.3~rc1-1
* New upstream release: 1.9.3 RC1.
  + Includes load.c fixes. Closes: #639959.
* Upload to unstable.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## 904_linux_target_os.dpatch.dpatch by Matthias Klose <doko@ubuntu.com>
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: Robustify check for target_os
6
 
 
7
 
@DPATCH@
8
 
Index: b/configure.in
9
 
===================================================================
10
 
--- a/configure.in      2010-07-20 21:46:14.000000000 +0900
11
 
+++ b/configure.in      2010-07-20 21:46:15.000000000 +0900
12
 
@@ -104,7 +104,7 @@
13
 
 fi
14
 
 
15
 
 AC_CANONICAL_TARGET
16
 
-target_os=`echo $target_os | sed 's/linux-gnu$/linux/;s/linux-gnu/linux-/'`
17
 
+target_os=`echo $target_os | sed 's/linux-gnu$/linux/;s/linux-gnulp$/linux/;s/linux-gnu/linux-/'`
18
 
 ac_install_sh='' # unusable for extension libraries.
19
 
 
20
 
 ifelse(currently,disabled, [