~ubuntu-branches/ubuntu/saucy/parole/saucy-proposed

« back to all changes in this revision

Viewing changes to debian/patches/01_fix-implicit-dso-linking.patch

  • Committer: Bazaar Package Importer
  • Author(s): Yves-Alexis Perez, Lionel Le Folgoc, Yves-Alexis Perez
  • Date: 2011-04-24 16:09:19 UTC
  • mfrom: (1.1.1 upstream)
  • Revision ID: james.westby@ubuntu.com-20110424160919-rpjwaicrdb8f7un2
Tags: 0.2.0.6-1
[ Lionel Le Folgoc ]
* debian/control:
  - drop unneeded build-dep on xulrunner-dev.   closes: #594073
  - suggests a few useful gstreamer0.10 plugins.
  - build-depends on quilt.
* debian/patches:
  - 01_fix-implicit-dso-linking.patch: added, fixes FTBFS with binutils-gold.
  - series: added.                                            closes: #615760
* debian/rules: pass --with quilt to dh.

[ Yves-Alexis Perez ]
* New upstream release.
* Switch to 3.0 (quilt) source format.
* debian/control:
  - update standards version to 3.9.2.
  - drop browser-plugin-parole package.
  - drop quilt build-dep.
  - add build-dep on hardening-includes
  - bump xfce build-deps to 4.8.
* debian/parole.install updated.
* debian/rules:
  - use --fail-missing and manually remove spurious files.
  - drop quilt addon
  - pick build flags from dpkg-buildflags.
  - add -O1, -z,defs and --as-needed to LDFLAGS.
  - add hardening flags to build flags.
  - stop harcoding the shell to bash, it works fine now.      closes: #623830

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
diff --git a/common/Makefile.am b/common/Makefile.am
 
2
index bd51b3b..5139ca8 100644
 
3
--- a/common/Makefile.am
 
4
+++ b/common/Makefile.am
 
5
@@ -12,9 +12,12 @@ libparolecommon_la_CFLAGS =          \
 
6
        $(GTK_CFLAGS)                   \
 
7
        $(LIBXFCE4UTIL_CFLAGS)
 
8
 
 
9
+libparolecommon_la_LIBADD =            \
 
10
+       $(X11_LIBS)
 
11
+
 
12
 libparolescreensaver_la_SOURCES =      \
 
13
        parole-screensaver.c            \
 
14
        parole-screensaver.h
 
15
 
 
16
 libparolescreensaver_la_CFLAGS =       \
 
17
-       $(GTK_CFLAGS)
 
18
\ No newline at end of file
 
19
+       $(GTK_CFLAGS)
 
20
diff --git a/configure.ac b/configure.ac
 
21
index d1b65b0..d65568b 100644
 
22
--- a/configure.ac
 
23
+++ b/configure.ac
 
24
@@ -96,6 +96,8 @@ XDT_CHECK_PACKAGE([DBUS_GLIB], [dbus-glib-1], [dbus_glib_minimum_version])
 
25
 XDT_CHECK_PACKAGE([LIBXFCE4GUI], [libxfcegui4-1.0],[libxfcegui4_minimum_version])
 
26
 XDT_CHECK_PACKAGE([LIBXFCE4UTIL], [libxfce4util-1.0],[libxfce4util_minimum_version])
 
27
 
 
28
+XDT_CHECK_PACKAGE([X11], [x11])
 
29
+
 
30
 #=======================================================#
 
31
 #           Check for availability of libnotify         #
 
32
 #=======================================================#
 
33
diff --git a/plugins/properties/Makefile.am b/plugins/properties/Makefile.am
 
34
index f4169d0..cc26157 100644
 
35
--- a/plugins/properties/Makefile.am
 
36
+++ b/plugins/properties/Makefile.am
 
37
@@ -23,6 +23,10 @@ stream_properties_la_CFLAGS =                        \
 
38
        $(LIBXFCE4UTIL_CFLAGS)
 
39
 
 
40
 stream_properties_la_LIBADD =                  \
 
41
+       $(top_builddir)/parole/libparole.la     \
 
42
+       $(PLATFORM_LIBS)                        \
 
43
+       $(GTK_LIBS)                             \
 
44
+       $(LIBXFCE4UTIL_LIBS)    \
 
45
        $(TAGLIBC_LIBS)
 
46
 
 
47
 stream_properties_la_LDFLAGS =                 \
 
48
diff --git a/plugins/tray/Makefile.am b/plugins/tray/Makefile.am
 
49
index a240229..0c82253 100644
 
50
--- a/plugins/tray/Makefile.am
 
51
+++ b/plugins/tray/Makefile.am
 
52
@@ -30,6 +30,8 @@ tray_icon_la_LDFLAGS =                                \
 
53
        $(PLATFORM_LDFLAGS)
 
54
 
 
55
 tray_icon_la_LIBADD =                          \
 
56
+       $(top_builddir)/parole/libparole.la     \
 
57
+       $(LIBXFCE4UTIL_LIBS)    \
 
58
        $(LIBNOTIFY_LIBS)
 
59
 
 
60
 #
 
61
@@ -44,4 +46,4 @@ EXTRA_DIST =                  \
 
62
        $(desktop_in_files)
 
63
     
 
64
 DISTCLEANFILES =               \
 
65
-       $(desktop_DATA)
 
66
\ No newline at end of file
 
67
+       $(desktop_DATA)
 
68
diff --git a/src/Makefile.am b/src/Makefile.am
 
69
index b2928a8..8bbaa6a 100644
 
70
--- a/src/Makefile.am
 
71
+++ b/src/Makefile.am
 
72
@@ -85,7 +85,8 @@ parole_LDADD =                                        \
 
73
         $(LIBXFCE4GUI_LIBS)                     \
 
74
        $(GST_VIDEO_LIBS)                       \
 
75
        $(GST_INTERFACES_LIBS)                  \
 
76
-       $(TAGLIBC_LIBS)
 
77
+       $(TAGLIBC_LIBS) \
 
78
+       $(X11_LIBS)
 
79
        
 
80
 parole_glib_enum_headers =                     \
 
81
        parole-conf.h                           \