~ubuntu-branches/ubuntu/trusty/erlang/trusty

« back to all changes in this revision

Viewing changes to debian/patches/java.patch

  • Committer: Bazaar Package Importer
  • Author(s): Clint Byrum
  • Date: 2011-05-05 15:48:43 UTC
  • mfrom: (3.5.13 sid)
  • Revision ID: james.westby@ubuntu.com-20110505154843-0om6ekzg6m7ugj27
Tags: 1:14.b.2-dfsg-3ubuntu1
* Merge from debian unstable.  Remaining changes:
  - Drop libwxgtk2.8-dev build dependency. Wx isn't in main, and not
    supposed to.
  - Drop erlang-wx binary.
  - Drop erlang-wx dependency from -megaco, -common-test, and -reltool, they
    do not really need wx. Also drop it from -debugger; the GUI needs wx,
    but it apparently has CLI bits as well, and is also needed by -megaco,
    so let's keep the package for now.
  - debian/patches/series: Do what I meant, and enable build-options.patch
    instead.
* Additional changes:
  - Drop erlang-wx from -et
* Dropped Changes:
  - patches/pcre-crash.patch: CVE-2008-2371: outer level option with
    alternatives caused crash. (Applied Upstream)
  - fix for ssl certificate verification in newSSL: 
    ssl_cacertfile_fix.patch (Applied Upstream)
  - debian/patches/series: Enable native.patch again, to get stripped beam
    files and reduce the package size again. (build-options is what
    actually accomplished this)
  - Remove build-options.patch on advice from upstream and because it caused
    odd build failures.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Author: Sergei Golovan <sgolovan@debian.org>
 
2
Description: GCJ 4.4 passes the test for JDK 1.5 but doesn't implement
 
3
 String#String(int[], int, int) constructor, which breaks jinterface
 
4
 build. This patch adds a check for the definition of this constructor.
 
5
 It helps to build Erlang on architectures without openjdk-6 available.
 
6
Forwarded: yes
 
7
Last-updated: Sat, 13 Feb 2010 10:08:42 +0300
 
8
 
 
9
--- erlang-14.b.2-dfsg.orig/erts/configure.in
 
10
+++ erlang-14.b.2-dfsg/erts/configure.in
 
11
@@ -4106,7 +4106,8 @@
 
12
   dnl Make sure it's at least JDK 1.5
 
13
   AC_CACHE_CHECK(for JDK version 1.5, 
 
14
      ac_cv_prog_javac_ver_1_5,
 
15
-     [ERL_TRY_LINK_JAVA([], [for (String i : args);],
 
16
+     [ERL_TRY_LINK_JAVA([], [for (String i : args);
 
17
+        int[] values = {}; String s = new String(values, 0, values.length);],
 
18
         ac_cv_prog_javac_ver_1_5=yes, ac_cv_prog_javac_ver_1_5=no)])
 
19
   if test $ac_cv_prog_javac_ver_1_5 = no; then
 
20
     unset -v JAVAC
 
21
--- erlang-14.b.2-dfsg.orig/lib/test_server/src/configure.in
 
22
+++ erlang-14.b.2-dfsg/lib/test_server/src/configure.in
 
23
@@ -399,7 +399,8 @@
 
24
   dnl Make sure it's at least JDK 1.5
 
25
   AC_CACHE_CHECK(for JDK version 1.5, 
 
26
      ac_cv_prog_javac_ver_1_5,
 
27
-     [ERL_TRY_LINK_JAVA([], [for (String i : args);],
 
28
+     [ERL_TRY_LINK_JAVA([], [for (String i : args);
 
29
+        int[] values = {}; String s = new String(values, 0, values.length);],
 
30
         ac_cv_prog_javac_ver_1_5=yes, ac_cv_prog_javac_ver_1_5=no)])
 
31
   if test $ac_cv_prog_javac_ver_1_5 = no; then
 
32
     unset -v JAVAC