~ubuntu-branches/ubuntu/trusty/erlang/trusty

« back to all changes in this revision

Viewing changes to debian/patches/ssl.patch

  • Committer: Bazaar Package Importer
  • Author(s): Clint Byrum
  • Date: 2011-05-05 15:48:43 UTC
  • mfrom: (3.5.13 sid)
  • Revision ID: james.westby@ubuntu.com-20110505154843-0om6ekzg6m7ugj27
Tags: 1:14.b.2-dfsg-3ubuntu1
* Merge from debian unstable.  Remaining changes:
  - Drop libwxgtk2.8-dev build dependency. Wx isn't in main, and not
    supposed to.
  - Drop erlang-wx binary.
  - Drop erlang-wx dependency from -megaco, -common-test, and -reltool, they
    do not really need wx. Also drop it from -debugger; the GUI needs wx,
    but it apparently has CLI bits as well, and is also needed by -megaco,
    so let's keep the package for now.
  - debian/patches/series: Do what I meant, and enable build-options.patch
    instead.
* Additional changes:
  - Drop erlang-wx from -et
* Dropped Changes:
  - patches/pcre-crash.patch: CVE-2008-2371: outer level option with
    alternatives caused crash. (Applied Upstream)
  - fix for ssl certificate verification in newSSL: 
    ssl_cacertfile_fix.patch (Applied Upstream)
  - debian/patches/series: Enable native.patch again, to get stripped beam
    files and reduce the package size again. (build-options is what
    actually accomplished this)
  - Remove build-options.patch on advice from upstream and because it caused
    odd build failures.

Show diffs side-by-side

added added

removed removed

Lines of Context:
2
2
 
3
3
Patch adds support for IPv6 to the ssl application.
4
4
 
5
 
--- erlang-13.b.3-dfsg.orig/erts/configure.in
6
 
+++ erlang-13.b.3-dfsg/erts/configure.in
7
 
@@ -1577,6 +1577,8 @@
8
 
        fi
9
 
 fi
10
 
 AC_CHECK_FUNCS([getnameinfo getipnodebyname getipnodebyaddr gethostbyname2])
 
5
--- erlang-14.b.2-dfsg.orig/erts/configure.in
 
6
+++ erlang-14.b.2-dfsg/erts/configure.in
 
7
@@ -1790,6 +1790,8 @@
 
8
 
 
9
 
 
10
 AC_CHECK_FUNCS([getipnodebyname getipnodebyaddr gethostbyname2])
11
11
+AC_CHECK_FUNCS([inet_pton])
12
12
+AC_CHECK_TYPES([struct sockaddr_storage],,,[#include <netinet/in.h>])
13
13
 
14
14
 AC_CHECK_FUNCS([ieee_handler fpsetmask finite isnan isinf res_gethostbyname dlopen \
15
15
                pread pwrite writev memmove strerror strerror_r strncasecmp \
16
 
--- erlang-13.b.3-dfsg.orig/erts/config.h.in
17
 
+++ erlang-13.b.3-dfsg/erts/config.h.in
18
 
@@ -253,6 +253,9 @@
 
16
--- erlang-14.b.2-dfsg.orig/erts/config.h.in
 
17
+++ erlang-14.b.2-dfsg/erts/config.h.in
 
18
@@ -326,6 +326,9 @@
19
19
 /* Define if ipv6 is present */
20
20
 #undef HAVE_IN6
21
21
 
25
25
 /* Define to 1 if you have the <inttypes.h> header file. */
26
26
 #undef HAVE_INTTYPES_H
27
27
 
28
 
@@ -424,6 +427,9 @@
 
28
@@ -521,6 +524,9 @@
29
29
 /* Define to 1 if `ssf_data' is member of `struct sctp_send_failed'. */
30
30
 #undef HAVE_STRUCT_SCTP_SEND_FAILED_SSF_DATA
31
31
 
35
35
 /* Define to 1 if you have the <syslog.h> header file. */
36
36
 #undef HAVE_SYSLOG_H
37
37
 
38
 
--- erlang-13.b.3-dfsg.orig/lib/ssl/c_src/esock.c
39
 
+++ erlang-13.b.3-dfsg/lib/ssl/c_src/esock.c
 
38
--- erlang-14.b.2-dfsg.orig/lib/ssl/c_src/esock.c
 
39
+++ erlang-14.b.2-dfsg/lib/ssl/c_src/esock.c
40
40
@@ -132,6 +132,11 @@
41
41
 #define INADDR_NONE 0xffffffff  /* Should be in <netinet/in.h>.  */
42
42
 #endif
304
304
 static Connection *new_connection(int state, FD fd)
305
305
 {
306
306
     Connection *cp;
307
 
--- erlang-13.b.3-dfsg.orig/lib/ssl/src/ssl_broker.erl
308
 
+++ erlang-13.b.3-dfsg/lib/ssl/src/ssl_broker.erl
 
307
--- erlang-14.b.2-dfsg.orig/lib/ssl/src/ssl_broker.erl
 
308
+++ erlang-14.b.2-dfsg/lib/ssl/src/ssl_broker.erl
309
309
@@ -471,7 +471,7 @@
310
310
     debug(St, "peername: client = ~w~n", [Client]),
311
311
     Reply = case ssl_server:peername(St#st.fd) of
428
428
 get_tagged_opt(Tag, Opts, Default) ->
429
429
     case lists:keysearch(Tag, 1, Opts) of
430
430
        {value, {_, Value}} ->
431
 
--- erlang-13.b.3-dfsg.orig/lib/ssl/src/ssl_prim.erl
432
 
+++ erlang-13.b.3-dfsg/lib/ssl/src/ssl_prim.erl
 
431
--- erlang-14.b.2-dfsg.orig/lib/ssl/src/ssl_prim.erl
 
432
+++ erlang-14.b.2-dfsg/lib/ssl/src/ssl_prim.erl
433
433
@@ -118,7 +118,7 @@
434
434
 peername(#st{fd = Fd, status = open}) ->
435
435
     case ssl_server:peername_prim(ssl_server_prim, Fd) of
448
448
            {ok, {At, Port}};
449
449
        Error ->
450
450
            Error
451
 
--- erlang-13.b.3-dfsg.orig/lib/ssl/src/ssl_server.erl
452
 
+++ erlang-13.b.3-dfsg/lib/ssl/src/ssl_server.erl
 
451
--- erlang-14.b.2-dfsg.orig/lib/ssl/src/ssl_server.erl
 
452
+++ erlang-14.b.2-dfsg/lib/ssl/src/ssl_server.erl
453
453
@@ -1363,7 +1363,10 @@
454
454
 
455
455
 ip_to_string({A,B,C,D}) ->