~ubuntu-branches/ubuntu/trusty/totem/trusty-proposed

« back to all changes in this revision

Viewing changes to debian/patches/70_bbc_plugin.patch

  • Committer: Bazaar Package Importer
  • Author(s): Sjoerd Simons, Josselin Mouette, Sjoerd Simons, Emilio Pozuelo Monfort
  • Date: 2009-04-19 17:28:51 UTC
  • mfrom: (1.2.52 upstream) (5.1.1 squeeze)
  • Revision ID: james.westby@ubuntu.com-20090419172851-epoqimnq62akn294
Tags: 2.26.1-1
[ Josselin Mouette ]
* totem-plugins depends on python-gdbm. Closes: #523582.

[ Sjoerd Simons ]
* New upstream release (2.26.1)
* debian/patches/02_flv.patch: Dropped, fixed upstream
* debian/patches/04_tracker_build.patch: Dropped, fixed upstream
* debian/patches/01_fake_keypresses.patch: Updated and simplified
* debian/patches/70_bbc_plugin.patch: Updated
* debian/patches/90_autotools.patch: Updated

[ Emilio Pozuelo Monfort ]
* Recommend gnome-codec-install rather than gnome-app-install.
  Closes: #523052.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
1
diff --git a/bindings/python/totem.defs b/bindings/python/totem.defs
2
 
index 03681ec..7ccaaac 100644
 
2
index 059b400..33aaf49 100644
3
3
--- a/bindings/python/totem.defs
4
4
+++ b/bindings/python/totem.defs
5
 
@@ -204,6 +204,16 @@
 
5
@@ -206,6 +206,16 @@
6
6
   (return-type "none")
7
7
 )
8
8
 
20
20
   (of-object "TotemObject")
21
21
   (c-name "totem_action_stop")
22
22
diff --git a/configure.in b/configure.in
23
 
index 1bdd1a8..08d5f14 100644
 
23
index d6f24e5..b9d12d7 100644
24
24
--- a/configure.in
25
25
+++ b/configure.in
26
26
@@ -50,7 +50,7 @@ AC_SUBST(TOTEM_VERSION_MINOR)
27
27
 AC_SUBST(TOTEM_VERSION_MICRO)
28
28
 
29
29
 # The full list of plugins
30
 
-allowed_plugins="thumbnail screensaver ontop galago gromit lirc media-player-keys mythtv properties sidebar-test skipto sample-python sample-vala bemused youtube publish tracker pythonconsole"
31
 
+allowed_plugins="thumbnail screensaver ontop galago gromit lirc media-player-keys mythtv properties sidebar-test skipto sample-python sample-vala bbc bemused youtube publish tracker pythonconsole"
 
30
-allowed_plugins="thumbnail screensaver ontop galago gromit lirc media-player-keys mythtv properties sidebar-test skipto sample-python sample-vala bemused youtube publish tracker pythonconsole jamendo opensubtitles screenshot brasero-disc-recorder coherence_upnp"
 
31
+allowed_plugins="thumbnail screensaver ontop galago gromit lirc media-player-keys mythtv properties sidebar-test skipto sample-python sample-vala bbc bemused youtube publish tracker pythonconsole jamendo opensubtitles screenshot brasero-disc-recorder coherence_upnp"
32
32
 
33
33
 PLUGINDIR='${libdir}/totem/plugins'
34
34
 AC_SUBST(PLUGINDIR)
35
 
@@ -547,6 +547,36 @@ for plugin in ${used_plugins}; do
 
35
@@ -564,6 +564,36 @@ for plugin in ${used_plugins}; do
36
36
                                add_plugin="0"
37
37
                        fi
38
38
                ;;
69
69
                bemused)
70
70
                        PKG_CHECK_MODULES(BEMUSED, bluez, [HAVE_BLUEZ=yes], [HAVE_BLUEZ=no])
71
71
                        if test "${HAVE_BLUEZ}" != "yes" ; then
72
 
@@ -836,6 +866,7 @@ totem.spec
 
72
@@ -852,6 +882,7 @@ totem.spec
73
73
 lib/Makefile
74
74
 src/Makefile
75
75
 src/plugins/Makefile
76
76
+src/plugins/bbc/Makefile
77
77
 src/plugins/bemused/Makefile
 
78
 src/plugins/coherence_upnp/Makefile
78
79
 src/plugins/screensaver/Makefile
79
 
 src/plugins/ontop/Makefile
80
80
diff --git a/src/plugins/bbc/Makefile.am b/src/plugins/bbc/Makefile.am
81
81
new file mode 100644
82
82
index 0000000..f733dd2