~ubuntu-branches/debian/sid/scribus/sid

« back to all changes in this revision

Viewing changes to debian/patches/0001-qreal-double-fixes.patch

  • Committer: Package Import Robot
  • Author(s): Oleksandr Moskalenko
  • Date: 2012-02-09 21:50:56 UTC
  • mfrom: (1.1.6)
  • Revision ID: package-import@ubuntu.com-20120209215056-2wrx1ara0jbm7fi5
Tags: 1.4.0.dfsg+r17287-1
* New upstream stable release upload into Debian (Closes: #654703).
* Applied the Ubuntu armel patch.
* Removed non-free color swatches from resources.
* debian/control:
  - Moved icc-profiles from Recommends to Suggests (Closes: #655885).
  - Updated Standards-Version to 3.9.2.
  - Updated extended description per lintian warning.
* debian/rules:
  - Update mailcap (Closes: #630751). A request for mime.types update has
    been sent to the mime-support maintainer.
  - Added build-arch and build-indep targets per lintian warning.
* debian/patches:
  - top_cmakelists.patch - don't copy extra docs and changelogs.
  - scribus_cmakelists.patch - don't copy extra docs and changelogs.
  - scribus_cmakelists.patch - don't install the non-free "doc" dir.
  - profiles_cmakelists.patch - don't install non-free sRGB profile.
* debian/copyright: 
  - Converted to the DEP5 machine readable foramt.
  - Added licenses for free color swatches.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From: Jani Monoses <jani@ubuntu.com>
2
 
Bug: http://bugs.scribus.net/view.php?id=9850
3
 
Bug-Debian: http://bugs.debian.org/621401
4
 
Subject: ARM fixes
5
 
 
6
 
---
7
 
 fonts/scfontmetrics.cpp                   |    4 ++--
8
 
 pageitem.cpp                              |   12 ++++++------
9
 
 pageitem_textframe.cpp                    |    6 +++---
10
 
 pdflib_core.cpp                           |    8 ++++----
11
 
 plugins/svgexplugin/svgexplugin.cpp       |   16 ++++++++--------
12
 
 plugins/tools/pathstroker/pathstroker.cpp |    2 +-
13
 
 propertiespalette.cpp                     |    4 ++--
14
 
 pslib.cpp                                 |   24 ++++++++++++------------
15
 
 scpageoutput.cpp                          |    8 ++++----
16
 
 scpainter.cpp                             |    8 ++++----
17
 
 scribusview.cpp                           |   16 ++++++++--------
18
 
 selection.cpp                             |    8 ++++----
19
 
 smlinestyle.cpp                           |    2 +-
20
 
 ui/modetoolbar.cpp                        |    2 +-
21
 
 14 files changed, 60 insertions(+), 60 deletions(-)
22
 
 
23
 
--- a/scribus/fonts/scfontmetrics.cpp
24
 
+++ b/scribus/fonts/scfontmetrics.cpp
25
 
@@ -281,7 +281,7 @@ QPixmap FontSample(const ScFace& fnt, in
26
 
                        {
27
 
                                gly.translate(static_cast<qreal>(pen_x) / 6400.0, a);
28
 
                                gp = getMaxClipF(&gly);
29
 
-                               ymax = qMax(ymax, gp.y());
30
 
+                               ymax = qMax(double(ymax), gp.y());
31
 
                                p->setupPolygon(&gly);
32
 
                                p->fillPath();
33
 
                        }
34
 
@@ -302,7 +302,7 @@ QPixmap FontSample(const ScFace& fnt, in
35
 
                        {
36
 
                                gly.translate(static_cast<qreal>(pen_x) / 6400.0, a);
37
 
                                gp = getMaxClipF(&gly);
38
 
-                               ymax = qMax(ymax, gp.y());
39
 
+                               ymax = qMax(double(ymax), gp.y());
40
 
                                p->setupPolygon(&gly);
41
 
                                p->fillPath();
42
 
                        }
43
 
--- a/scribus/pageitem.cpp
44
 
+++ b/scribus/pageitem.cpp
45
 
@@ -1991,12 +1991,12 @@ void PageItem::drawGlyphs(ScPainter *p,
46
 
                                if (style.underlineWidth() != -1)
47
 
                                        lw = (style.underlineWidth() / 1000.0) * (style.fontSize() / 10.0);
48
 
                                else
49
 
-                                       lw = qMax(style.font().strokeWidth(style.fontSize() / 10.0), 1.0);
50
 
+                                       lw = qMax(style.font().strokeWidth(style.fontSize() / 10.0), qreal(1.0));
51
 
                        }
52
 
                        else
53
 
                        {
54
 
                                st = style.font().underlinePos(style.fontSize() / 10.0);
55
 
-                               lw = qMax(style.font().strokeWidth(style.fontSize() / 10.0), 1.0);
56
 
+                               lw = qMax(style.font().strokeWidth(style.fontSize() / 10.0), qreal(1.0));
57
 
                        }
58
 
                        if (style.baselineOffset() != 0)
59
 
                                st += (style.fontSize() / 10.0) * glyphs.scaleV * (style.baselineOffset() / 1000.0);
60
 
@@ -2109,12 +2109,12 @@ void PageItem::drawGlyphs(ScPainter *p,
61
 
                                if (style.strikethruWidth() != -1)
62
 
                                        lw = (style.strikethruWidth() / 1000.0) * (style.fontSize() / 10.0);
63
 
                                else
64
 
-                                       lw = qMax(style.font().strokeWidth(style.fontSize() / 10.0), 1.0);
65
 
+                                       lw = qMax(style.font().strokeWidth(style.fontSize() / 10.0), qreal(1.0));
66
 
                        }
67
 
                        else
68
 
                        {
69
 
                                st = style.font().strikeoutPos(style.fontSize() / 10.0);
70
 
-                               lw = qMax(style.font().strokeWidth(style.fontSize() / 10.0), 1.0);
71
 
+                               lw = qMax(style.font().strokeWidth(style.fontSize() / 10.0), qreal(1.0));
72
 
                        }
73
 
                        if (style.baselineOffset() != 0)
74
 
                                st += (style.fontSize() / 10.0) * glyphs.scaleV * (style.baselineOffset() / 1000.0);
75
 
@@ -4798,7 +4798,7 @@ void PageItem::getBoundingRect(double *x
76
 
                FPoint maxAr = getMaxClipF(&arrow);
77
 
                totalRect = totalRect.united(QRectF(QPointF(minAr.x(), minAr.y()), QPointF(maxAr.x(), maxAr.y())));
78
 
        }
79
 
-       totalRect.getCoords(x1, y1, x2, y2);
80
 
+       totalRect.getCoords((qreal*)x1, (qreal*)y1, (qreal*)x2, (qreal*)y2);
81
 
 }
82
 
 
83
 
 void PageItem::getVisualBoundingRect(double * x1, double * y1, double * x2, double * y2) const
84
 
@@ -4953,7 +4953,7 @@ void PageItem::getVisualBoundingRect(dou
85
 
                FPoint maxAr = getMaxClipF(&arrow);
86
 
                totalRect = totalRect.united(QRectF(QPointF(minAr.x(), minAr.y()), QPointF(maxAr.x(), maxAr.y())));
87
 
        }
88
 
-       totalRect.getCoords(x1, y1, x2, y2);
89
 
+       totalRect.getCoords((qreal*)x1, (qreal*)y1, (qreal*)x2, (qreal*)y2);
90
 
 }
91
 
 
92
 
 double PageItem::visualXPos() const
93
 
--- a/scribus/pageitem_textframe.cpp
94
 
+++ b/scribus/pageitem_textframe.cpp
95
 
@@ -522,7 +522,7 @@ struct LineControl {
96
 
                double maxX = colRight - morespace;
97
 
                if (legacy) maxX -= (lineCorr + insets.Right);
98
 
 
99
 
-               double StartX = floor(qMax(line.x, qMin(colRight,breakXPos) - 1));
100
 
+               double StartX = floor(qMax((double)line.x, qMin(colRight,breakXPos) - 1));
101
 
                int xPos  = static_cast<int>(ceil(maxX + insets.Right));
102
 
                int yDesc = static_cast<int>(yPos+line.descent);
103
 
                int yAsc  = static_cast<int>(ceil(yPos-line.ascent));
104
 
@@ -687,8 +687,8 @@ struct LineControl {
105
 
                                desc = cStyle.font().realCharDescent(ch, cStyle.fontSize() / 10.0);
106
 
                        }
107
 
                        //      qDebug() << QString("checking char 'x%2' with ascender %1 > %3").arg(asce).arg(ch.unicode()).arg(result);
108
 
-                       line.ascent  = qMax(line.ascent, asce);
109
 
-                       line.descent = qMax(line.descent, desc);
110
 
+                       line.ascent  = qMax((double)line.ascent, asce);
111
 
+                       line.descent = qMax((double)line.descent, desc);
112
 
                }
113
 
        }
114
 
        
115
 
--- a/scribus/pdflib_core.cpp
116
 
+++ b/scribus/pdflib_core.cpp
117
 
@@ -4433,12 +4433,12 @@ bool PDFLibCore::setTextCh(PageItem *ite
118
 
                                if (style.underlineWidth() != -1)
119
 
                                        Uwid = (style.underlineWidth() / 1000.0) * (style.fontSize() / 10.0);
120
 
                                else
121
 
-                                       Uwid = qMax(style.font().strokeWidth(style.fontSize() / 10.0), 1.0);
122
 
+                                       Uwid = qMax(style.font().strokeWidth(style.fontSize() / 10.0), (qreal)1.0);
123
 
                        }
124
 
                        else
125
 
                        {
126
 
                                Upos = style.font().underlinePos(style.fontSize() / 10.0);
127
 
-                               Uwid = qMax(style.font().strokeWidth(style.fontSize() / 10.0), 1.0);
128
 
+                               Uwid = qMax(style.font().strokeWidth(style.fontSize() / 10.0), (qreal)1.0);
129
 
                        }
130
 
                        if (style.baselineOffset() != 0)
131
 
                                Upos += (style.fontSize() / 10.0) * hl->glyph.scaleV * (style.baselineOffset() / 1000.0);
132
 
@@ -4713,12 +4713,12 @@ bool PDFLibCore::setTextCh(PageItem *ite
133
 
                                if (style.strikethruWidth() != -1)
134
 
                                        Uwid = (style.strikethruWidth() / 1000.0) * (style.fontSize() / 10.0);
135
 
                                else
136
 
-                                       Uwid = qMax(style.font().strokeWidth(style.fontSize() / 10.0), 1.0);
137
 
+                                       Uwid = qMax(style.font().strokeWidth(style.fontSize() / 10.0), (qreal)1.0);
138
 
                        }
139
 
                        else
140
 
                        {
141
 
                                Upos = style.font().strikeoutPos(style.fontSize() / 10.0);
142
 
-                               Uwid = qMax(style.font().strokeWidth(style.fontSize() / 10.0), 1.0);
143
 
+                               Uwid = qMax(style.font().strokeWidth(style.fontSize() / 10.0), (qreal)1.0);
144
 
                        }
145
 
                        if (style.baselineOffset() != 0)
146
 
                                Upos += (style.fontSize() / 10.0) * hl->glyph.scaleV * (style.baselineOffset() / 1000.0);
147
 
--- a/scribus/plugins/svgexplugin/svgexplugin.cpp
148
 
+++ b/scribus/plugins/svgexplugin/svgexplugin.cpp
149
 
@@ -723,12 +723,12 @@ QDomElement SVGExPlug::processTextItem(P
150
 
                                                if (charStyle.underlineWidth() != -1)
151
 
                                                        lw = (charStyle.underlineWidth() / 1000.0) * (charStyle.fontSize() / 10.0);
152
 
                                                else
153
 
-                                                       lw = qMax(charStyle.font().strokeWidth(charStyle.fontSize() / 10.0), 1.0);
154
 
+                                                       lw = qMax(charStyle.font().strokeWidth(charStyle.fontSize() / 10.0), qreal(1.0));
155
 
                                        }
156
 
                                        else
157
 
                                        {
158
 
                                                Upos = charStyle.font().underlinePos(charStyle.fontSize() / 10.0);
159
 
-                                               lw = qMax(charStyle.font().strokeWidth(charStyle.fontSize() / 10.0), 1.0);
160
 
+                                               lw = qMax(charStyle.font().strokeWidth(charStyle.fontSize() / 10.0), qreal(1.0));
161
 
                                        }
162
 
                                        if (charStyle.baselineOffset() != 0)
163
 
                                                Upos += (charStyle.fontSize() / 10.0) * (charStyle.baselineOffset() / 1000.0);
164
 
@@ -780,12 +780,12 @@ QDomElement SVGExPlug::processTextItem(P
165
 
                                                if (charStyle.strikethruWidth() != -1)
166
 
                                                        lw = (charStyle.strikethruWidth() / 1000.0) * (charStyle.fontSize() / 10.0);
167
 
                                                else
168
 
-                                                       lw = qMax(charStyle.font().strokeWidth(charStyle.fontSize() / 10.0), 1.0);
169
 
+                                                       lw = qMax(charStyle.font().strokeWidth(charStyle.fontSize() / 10.0), qreal(1.0));
170
 
                                        }
171
 
                                        else
172
 
                                        {
173
 
                                                Upos = charStyle.font().strikeoutPos(charStyle.fontSize() / 10.0);
174
 
-                                               lw = qMax(charStyle.font().strokeWidth(charStyle.fontSize() / 10.0), 1.0);
175
 
+                                               lw = qMax(charStyle.font().strokeWidth(charStyle.fontSize() / 10.0), qreal(1.0));
176
 
                                        }
177
 
                                        if (charStyle.baselineOffset() != 0)
178
 
                                                Upos += (charStyle.fontSize() / 10.0) * hl->glyph.scaleV * (charStyle.baselineOffset() / 1000.0);
179
 
@@ -970,12 +970,12 @@ QDomElement SVGExPlug::processPathTextIt
180
 
                                        if (charStyle.underlineWidth() != -1)
181
 
                                                Uwid = (charStyle.underlineWidth() / 1000.0) * (charStyle.fontSize() / 10.0);
182
 
                                        else
183
 
-                                               Uwid = qMax(charStyle.font().strokeWidth(charStyle.fontSize() / 10.0), 1.0);
184
 
+                                               Uwid = qMax(charStyle.font().strokeWidth(charStyle.fontSize() / 10.0), qreal(1.0));
185
 
                                }
186
 
                                else
187
 
                                {
188
 
                                        Upos = charStyle.font().underlinePos(charStyle.fontSize() / 10.0);
189
 
-                                       Uwid = qMax(charStyle.font().strokeWidth(charStyle.fontSize() / 10.0), 1.0);
190
 
+                                       Uwid = qMax(charStyle.font().strokeWidth(charStyle.fontSize() / 10.0), qreal(1.0));
191
 
                                }
192
 
                                if (charStyle.baselineOffset() != 0)
193
 
                                        Upos += (charStyle.fontSize() / 10.0) * (charStyle.baselineOffset() / 1000.0);
194
 
@@ -1046,12 +1046,12 @@ QDomElement SVGExPlug::processPathTextIt
195
 
                                        if (charStyle.strikethruWidth() != -1)
196
 
                                                Uwid = (charStyle.strikethruWidth() / 1000.0) * (charStyle.fontSize() / 10.0);
197
 
                                        else
198
 
-                                               Uwid = qMax(charStyle.font().strokeWidth(charStyle.fontSize() / 10.0), 1.0);
199
 
+                                               Uwid = qMax(charStyle.font().strokeWidth(charStyle.fontSize() / 10.0), qreal(1.0));
200
 
                                }
201
 
                                else
202
 
                                {
203
 
                                        Upos = charStyle.font().strikeoutPos(charStyle.fontSize() / 10.0);
204
 
-                                       Uwid = qMax(charStyle.font().strokeWidth(charStyle.fontSize() / 10.0), 1.0);
205
 
+                                       Uwid = qMax(charStyle.font().strokeWidth(charStyle.fontSize() / 10.0), qreal(1.0));
206
 
                                }
207
 
                                if (charStyle.baselineOffset() != 0)
208
 
                                        Upos += (charStyle.fontSize() / 10.0) * (charStyle.baselineOffset() / 1000.0);
209
 
--- a/scribus/plugins/tools/pathstroker/pathstroker.cpp
210
 
+++ b/scribus/plugins/tools/pathstroker/pathstroker.cpp
211
 
@@ -115,7 +115,7 @@ bool PathStrokerPlugin::run(ScribusDoc*
212
 
                currDoc = ScCore->primaryMainWindow()->doc;
213
 
        if (currDoc->m_Selection->count() > 0)
214
 
        {
215
 
-               QVector<double> m_array;
216
 
+               QVector<qreal> m_array;
217
 
                PageItem *currItem = currDoc->m_Selection->itemAt(0);
218
 
                FPointArray path = currItem->PoLine;
219
 
                QPainterPath pp;
220
 
--- a/scribus/propertiespalette.cpp
221
 
+++ b/scribus/propertiespalette.cpp
222
 
@@ -107,7 +107,7 @@ void LineFormatItemDelegate::redraw(cons
223
 
                const ScColor& col = item.m_doc->PageColors[item.m_Line[its].Color];
224
 
                tmpf = ScColorEngine::getDisplayColor(col, item.m_doc, item.m_Line[its].Shade);
225
 
                QPen pen;
226
 
-               QVector<double> m_array;
227
 
+               QVector<qreal> m_array;
228
 
                if (item.m_Line[its].Dash == 1)
229
 
                        pen.setStyle(Qt::SolidLine);
230
 
                else
231
 
@@ -4639,7 +4639,7 @@ void PropertiesPalette::MakeIrre(int f,
232
 
                        doc->setRedrawBounding(CurItem);
233
 
                        break;
234
 
                default:
235
 
-                       CurItem->SetFrameShape(c, vals);
236
 
+                       CurItem->SetFrameShape(c, (double*)vals);
237
 
                        doc->setRedrawBounding(CurItem);
238
 
                        CurItem->FrameType = f+2;
239
 
                        break;
240
 
--- a/scribus/pslib.cpp
241
 
+++ b/scribus/pslib.cpp
242
 
@@ -2839,12 +2839,12 @@ bool PSLib::ProcessItem(ScribusDoc* Doc,
243
 
                                                                        if (style.underlineWidth() != -1)
244
 
                                                                                Uwid = (style.underlineWidth() / 1000.0) * (style.fontSize() / 10.0);
245
 
                                                                        else
246
 
-                                                                               Uwid = qMax(style.font().strokeWidth(style.fontSize() / 10.0), 1.0);
247
 
+                                                                               Uwid = qMax(style.font().strokeWidth(style.fontSize() / 10.0), qreal(1.0));
248
 
                                                                }
249
 
                                                                else
250
 
                                                                {
251
 
                                                                        Upos = style.font().underlinePos(style.fontSize() / 10.0);
252
 
-                                                                       Uwid = qMax(style.font().strokeWidth(style.fontSize() / 10.0), 1.0);
253
 
+                                                                       Uwid = qMax(style.font().strokeWidth(style.fontSize() / 10.0), qreal(1.0));
254
 
                                                                }
255
 
                                                                if (style.baselineOffset() != 0)
256
 
                                                                        Upos += (style.fontSize() / 10.0) * hl->glyph.scaleV * (style.baselineOffset() / 1000.0);
257
 
@@ -2910,12 +2910,12 @@ bool PSLib::ProcessItem(ScribusDoc* Doc,
258
 
                                                                        if (style.strikethruWidth() != -1)
259
 
                                                                                Uwid = (style.strikethruWidth() / 1000.0) * (style.fontSize() / 10.0);
260
 
                                                                        else
261
 
-                                                                               Uwid = qMax(style.font().strokeWidth(style.fontSize() / 10.0), 1.0);
262
 
+                                                                               Uwid = qMax(style.font().strokeWidth(style.fontSize() / 10.0), qreal(1.0));
263
 
                                                                }
264
 
                                                                else
265
 
                                                                {
266
 
                                                                        Upos = style.font().strikeoutPos(style.fontSize() / 10.0);
267
 
-                                                                       Uwid = qMax(style.font().strokeWidth(style.fontSize() / 10.0), 1.0);
268
 
+                                                                       Uwid = qMax(style.font().strokeWidth(style.fontSize() / 10.0), qreal(1.0));
269
 
                                                                }
270
 
                                                                if (style.baselineOffset() != 0)
271
 
                                                                        Upos += (style.fontSize() / 10.0) * hl->glyph.scaleV * (style.baselineOffset() / 1000.0);
272
 
@@ -2987,12 +2987,12 @@ bool PSLib::ProcessItem(ScribusDoc* Doc,
273
 
                                                        if (style.underlineWidth() != -1)
274
 
                                                                Uwid = (style.underlineWidth() / 1000.0) * (style.fontSize() / 10.0);
275
 
                                                        else
276
 
-                                                               Uwid = qMax(style.font().strokeWidth(style.fontSize() / 10.0), 1.0);
277
 
+                                                               Uwid = qMax(style.font().strokeWidth(style.fontSize() / 10.0), qreal(1.0));
278
 
                                                }
279
 
                                                else
280
 
                                                {
281
 
                                                        Upos = style.font().underlinePos(style.fontSize() / 10.0);
282
 
-                                                       Uwid = qMax(style.font().strokeWidth(style.fontSize() / 10.0), 1.0);
283
 
+                                                       Uwid = qMax(style.font().strokeWidth(style.fontSize() / 10.0), qreal(1.0));
284
 
                                                }
285
 
                                                if (style.baselineOffset() != 0)
286
 
                                                        Upos += (style.fontSize() / 10.0) * hl->glyph.scaleV * (style.baselineOffset() / 1000.0);
287
 
@@ -3064,12 +3064,12 @@ bool PSLib::ProcessItem(ScribusDoc* Doc,
288
 
                                                        if (style.strikethruWidth() != -1)
289
 
                                                                Uwid = (style.strikethruWidth() / 1000.0) * (style.fontSize() / 10.0);
290
 
                                                        else
291
 
-                                                               Uwid = qMax(style.font().strokeWidth(style.fontSize() / 10.0), 1.0);
292
 
+                                                               Uwid = qMax(style.font().strokeWidth(style.fontSize() / 10.0), qreal(1.0));
293
 
                                                }
294
 
                                                else
295
 
                                                {
296
 
                                                        Upos = style.font().strikeoutPos(style.fontSize() / 10.0);
297
 
-                                                       Uwid = qMax(style.font().strokeWidth(style.fontSize() / 10.0), 1.0);
298
 
+                                                       Uwid = qMax(style.font().strokeWidth(style.fontSize() / 10.0), qreal(1.0));
299
 
                                                }
300
 
                                                if (style.baselineOffset() != 0)
301
 
                                                        Upos += (style.fontSize() / 10.0) * hl->glyph.scaleV * (style.baselineOffset() / 1000.0);
302
 
@@ -3791,12 +3791,12 @@ void PSLib::setTextCh(ScribusDoc* Doc, P
303
 
                                if (cstyle.underlineWidth() != -1)
304
 
                                        lw = (cstyle.underlineWidth() / 1000.0) * (cstyle.fontSize() / 10.0);
305
 
                                else
306
 
-                                       lw = qMax(cstyle.font().strokeWidth(cstyle.fontSize() / 10.0), 1.0);
307
 
+                                       lw = qMax(cstyle.font().strokeWidth(cstyle.fontSize() / 10.0), qreal(1.0));
308
 
                        }
309
 
                        else
310
 
                        {
311
 
                                Upos = cstyle.font().underlinePos(cstyle.fontSize() / 10.0);
312
 
-                               lw = qMax(cstyle.font().strokeWidth(cstyle.fontSize() / 10.0), 1.0);
313
 
+                               lw = qMax(cstyle.font().strokeWidth(cstyle.fontSize() / 10.0), qreal(1.0));
314
 
                        }
315
 
                        if (cstyle.baselineOffset() != 0)
316
 
                                Upos += (cstyle.fontSize() / 10.0) * glyphs.scaleV * (cstyle.baselineOffset() / 1000.0);
317
 
@@ -3924,12 +3924,12 @@ void PSLib::setTextCh(ScribusDoc* Doc, P
318
 
                                if (cstyle.strikethruWidth() != -1)
319
 
                                        lw = (cstyle.strikethruWidth() / 1000.0) * (cstyle.fontSize() / 10.0);
320
 
                                else
321
 
-                                       lw = qMax(cstyle.font().strokeWidth(cstyle.fontSize() / 10.0), 1.0);
322
 
+                                       lw = qMax(cstyle.font().strokeWidth(cstyle.fontSize() / 10.0), qreal(1.0));
323
 
                        }
324
 
                        else
325
 
                        {
326
 
                                Upos = cstyle.font().strikeoutPos(cstyle.fontSize() / 10.0);
327
 
-                               lw = qMax(cstyle.font().strokeWidth(cstyle.fontSize() / 10.0), 1.0);
328
 
+                               lw = qMax(cstyle.font().strokeWidth(cstyle.fontSize() / 10.0), qreal(1.0));
329
 
                        }
330
 
                        if (cstyle.baselineOffset() != 0)
331
 
                                Upos += (cstyle.fontSize() / 10.0) * glyphs.scaleV * (cstyle.baselineOffset() / 1000.0);
332
 
--- a/scribus/scpageoutput.cpp
333
 
+++ b/scribus/scpageoutput.cpp
334
 
@@ -551,12 +551,12 @@ void ScPageOutput::drawGlyphs(PageItem*
335
 
                                if (style.underlineWidth() != -1)
336
 
                                        lw = (style.underlineWidth() / 1000.0) * (style.fontSize() / 10.0);
337
 
                                else
338
 
-                                       lw = qMax(style.font().strokeWidth(style.fontSize() / 10.0), 1.0);
339
 
+                                       lw = qMax(style.font().strokeWidth(style.fontSize() / 10.0), qreal(1.0));
340
 
                        }
341
 
                        else
342
 
                        {
343
 
                                st = style.font().underlinePos(style.fontSize() / 10.0);
344
 
-                               lw = qMax(style.font().strokeWidth(style.fontSize() / 10.0), 1.0);
345
 
+                               lw = qMax(style.font().strokeWidth(style.fontSize() / 10.0), qreal(1.0));
346
 
                        }
347
 
                        if (style.baselineOffset() != 0)
348
 
                                st += (style.fontSize() / 10.0) * glyphs.scaleV * (style.baselineOffset() / 1000.0);
349
 
@@ -638,12 +638,12 @@ void ScPageOutput::drawGlyphs(PageItem*
350
 
                                if (style.strikethruWidth() != -1)
351
 
                                        lw = (style.strikethruWidth() / 1000.0) * (style.fontSize() / 10.0);
352
 
                                else
353
 
-                                       lw = qMax(style.font().strokeWidth(style.fontSize() / 10.0), 1.0);
354
 
+                                       lw = qMax(style.font().strokeWidth(style.fontSize() / 10.0), qreal(1.0));
355
 
                        }
356
 
                        else
357
 
                        {
358
 
                                st = style.font().strikeoutPos(style.fontSize() / 10.0);
359
 
-                               lw = qMax(style.font().strokeWidth(style.fontSize() / 10.0), 1.0);
360
 
+                               lw = qMax(style.font().strokeWidth(style.fontSize() / 10.0), qreal(1.0));
361
 
                        }
362
 
                        if (style.baselineOffset() != 0)
363
 
                                st += (style.fontSize() / 10.0) * glyphs.scaleV * (style.baselineOffset() / 1000.0);
364
 
--- a/scribus/scpainter.cpp
365
 
+++ b/scribus/scpainter.cpp
366
 
@@ -941,7 +941,7 @@ void ScPainter::drawVPath( int mode )
367
 
                        cairo_set_fill_rule (m_cr, CAIRO_FILL_RULE_WINDING);
368
 
                if (fillMode == 1)
369
 
                {
370
 
-                       double r, g, b;
371
 
+                       qreal r, g, b;
372
 
                        m_fill.getRgbF(&r, &g, &b);
373
 
                        cairo_set_source_rgba( m_cr, r, g, b, fill_trans );
374
 
 //                     if (fill_trans != 1.0)
375
 
@@ -979,7 +979,7 @@ void ScPainter::drawVPath( int mode )
376
 
                                vneu = 255 - ((255 - v) * shad / 100);
377
 
                                qStopColor.setHsv(h, sneu, vneu);
378
 
                                double a = colorStops[offset]->opacity;
379
 
-                               double r, g, b;
380
 
+                               qreal r, g, b;
381
 
                                qStopColor.getRgbF(&r, &g, &b);
382
 
                                cairo_pattern_add_color_stop_rgba (pat, rampPoint, r, g, b, a);
383
 
                                lastPoint = rampPoint;
384
 
@@ -1024,7 +1024,7 @@ void ScPainter::drawVPath( int mode )
385
 
                        cairo_set_dash( m_cr, m_array.data(), m_array.count(), m_offset);
386
 
                else
387
 
                        cairo_set_dash( m_cr, NULL, 0, 0 );
388
 
-               double r, g, b;
389
 
+               qreal r, g, b;
390
 
                m_stroke.getRgbF(&r, &g, &b);
391
 
                cairo_set_source_rgba( m_cr, r, g, b, stroke_trans );
392
 
 //             if (stroke_trans != 1.0)
393
 
@@ -1348,7 +1348,7 @@ void ScPainter::drawText(QRectF area, QS
394
 
        double y;
395
 
        double ww = 0;
396
 
        double hh = 0;
397
 
-       double r, g, b;
398
 
+       qreal r, g, b;
399
 
        cairo_select_font_face(m_cr, m_font.family().toLatin1(), CAIRO_FONT_SLANT_NORMAL, CAIRO_FONT_WEIGHT_BOLD);
400
 
        cairo_set_font_size(m_cr, m_font.pointSizeF());
401
 
        cairo_font_extents (m_cr, &extentsF);
402
 
--- a/scribus/scribusview.cpp
403
 
+++ b/scribus/scribusview.cpp
404
 
@@ -4109,12 +4109,12 @@ void ScribusView::TextToPath()
405
 
                                                        if (charStyle.underlineWidth() != -1)
406
 
                                                                Uwid = (charStyle.underlineWidth() / 1000.0) * (charStyle.fontSize() / 10.0);
407
 
                                                        else
408
 
-                                                               Uwid = qMax(charStyle.font().strokeWidth(charStyle.fontSize() / 10.0), 1.0);
409
 
+                                                               Uwid = qMax(charStyle.font().strokeWidth(charStyle.fontSize() / 10.0), (qreal)1.0);
410
 
                                                }
411
 
                                                else
412
 
                                                {
413
 
                                                        Upos = charStyle.font().underlinePos(charStyle.fontSize() / 10.0);
414
 
-                                                       Uwid = qMax(charStyle.font().strokeWidth(charStyle.fontSize() / 10.0), 1.0);
415
 
+                                                       Uwid = qMax(charStyle.font().strokeWidth(charStyle.fontSize() / 10.0), (qreal)1.0);
416
 
                                                }
417
 
                                                if (charStyle.baselineOffset() != 0)
418
 
                                                        Upos += (charStyle.fontSize() / 10.0) * (charStyle.baselineOffset() / 1000.0);
419
 
@@ -4249,12 +4249,12 @@ void ScribusView::TextToPath()
420
 
                                                        if (charStyle.strikethruWidth() != -1)
421
 
                                                                Uwid = (charStyle.strikethruWidth() / 1000.0) * (charStyle.fontSize() / 10.0);
422
 
                                                        else
423
 
-                                                               Uwid = qMax(charStyle.font().strokeWidth(charStyle.fontSize() / 10.0), 1.0);
424
 
+                                                               Uwid = qMax(charStyle.font().strokeWidth(charStyle.fontSize() / 10.0), (qreal)1.0);
425
 
                                                }
426
 
                                                else
427
 
                                                {
428
 
                                                        Upos = charStyle.font().strikeoutPos(charStyle.fontSize() / 10.0);
429
 
-                                                       Uwid = qMax(charStyle.font().strokeWidth(charStyle.fontSize() / 10.0), 1.0);
430
 
+                                                       Uwid = qMax(charStyle.font().strokeWidth(charStyle.fontSize() / 10.0), (qreal)1.0);
431
 
                                                }
432
 
                                                if (charStyle.baselineOffset() != 0)
433
 
                                                        Upos += (charStyle.fontSize() / 10.0) * (charStyle.baselineOffset() / 1000.0);
434
 
@@ -4339,12 +4339,12 @@ void ScribusView::TextToPath()
435
 
                                                                if (charStyle.underlineWidth() != -1)
436
 
                                                                        lw = (charStyle.underlineWidth() / 1000.0) * (charStyle.fontSize() / 10.0);
437
 
                                                                else
438
 
-                                                                       lw = qMax(charStyle.font().strokeWidth(charStyle.fontSize() / 10.0), 1.0);
439
 
+                                                                       lw = qMax(charStyle.font().strokeWidth(charStyle.fontSize() / 10.0), (qreal)1.0);
440
 
                                                        }
441
 
                                                        else
442
 
                                                        {
443
 
                                                                st = charStyle.font().underlinePos(charStyle.fontSize() / 10.0);
444
 
-                                                               lw = qMax(charStyle.font().strokeWidth(charStyle.fontSize() / 10.0), 1.0);
445
 
+                                                               lw = qMax(charStyle.font().strokeWidth(charStyle.fontSize() / 10.0), (qreal)1.0);
446
 
                                                        }
447
 
                                                        if (charStyle.baselineOffset() != 0)
448
 
                                                                st += (charStyle.fontSize() / 10.0) * hl->glyph.scaleV * (charStyle.baselineOffset() / 1000.0);
449
 
@@ -4523,12 +4523,12 @@ void ScribusView::TextToPath()
450
 
                                                                if (charStyle.strikethruWidth() != -1)
451
 
                                                                        lw = (charStyle.strikethruWidth() / 1000.0) * (charStyle.fontSize() / 10.0);
452
 
                                                                else
453
 
-                                                                       lw = qMax(charStyle.font().strokeWidth(charStyle.fontSize() / 10.0), 1.0);
454
 
+                                                                       lw = qMax(charStyle.font().strokeWidth(charStyle.fontSize() / 10.0), (qreal)1.0);
455
 
                                                        }
456
 
                                                        else
457
 
                                                        {
458
 
                                                                st = charStyle.font().strikeoutPos(charStyle.fontSize() / 10.0);
459
 
-                                                               lw = qMax(charStyle.font().strokeWidth(charStyle.fontSize() / 10.0), 1.0);
460
 
+                                                               lw = qMax(charStyle.font().strokeWidth(charStyle.fontSize() / 10.0), (qreal)1.0);
461
 
                                                        }
462
 
                                                        if (charStyle.baselineOffset() != 0)
463
 
                                                                st += (charStyle.fontSize() / 10.0) * hl->glyph.scaleV * (charStyle.baselineOffset() / 1000.0);
464
 
--- a/scribus/selection.cpp
465
 
+++ b/scribus/selection.cpp
466
 
@@ -447,10 +447,10 @@ void Selection::setGroupRect()
467
 
                        QRectF itRect(currItem->getVisualBoundingRect());
468
 
 //                     for (uint pc = 0; pc < 4; ++pc)
469
 
                        {
470
 
-                               vminx = qMin(vminx, itRect.x());
471
 
-                               vminy = qMin(vminy, itRect.y());
472
 
-                               vmaxx = qMax(vmaxx, itRect.right());
473
 
-                               vmaxy = qMax(vmaxy, itRect.bottom());
474
 
+                               vminx = qMin(vminx, (double)itRect.x());
475
 
+                               vminy = qMin(vminy, (double)itRect.y());
476
 
+                               vmaxx = qMax(vmaxx, (double)itRect.right());
477
 
+                               vmaxy = qMax(vmaxy, (double)itRect.bottom());
478
 
                        }
479
 
                }
480
 
                else
481
 
--- a/scribus/smlinestyle.cpp
482
 
+++ b/scribus/smlinestyle.cpp
483
 
@@ -729,7 +729,7 @@ void SMLineStyle::updatePreview()
484
 
        for (int it = (*tmpLine).size()-1; it > -1; it--)
485
 
        {
486
 
                QPen pen;
487
 
-               QVector<double> m_array;
488
 
+               QVector<qreal> m_array;
489
 
                if ((*tmpLine)[it].Dash == 1)
490
 
                        pen.setStyle(Qt::SolidLine);
491
 
                else
492
 
--- a/scribus/ui/modetoolbar.cpp
493
 
+++ b/scribus/ui/modetoolbar.cpp
494
 
@@ -101,7 +101,7 @@ void ModeToolBar::SelShape(int s, int c,
495
 
 //     insertShapeButtonMenu->hide();
496
 
        SubMode = s;
497
 
        ValCount = c;
498
 
-       ShapeVals = vals;
499
 
+       ShapeVals = (double*)vals;
500
 
        m_ScMW->scrActions["toolsInsertShape"]->setChecked(false);
501
 
        m_ScMW->scrActions["toolsInsertShape"]->setChecked(true);
502
 
 }