~ubuntu-branches/ubuntu/maverick/xchat/maverick

« back to all changes in this revision

Viewing changes to debian/patches/01_serverlist.patch

  • Committer: Bazaar Package Importer
  • Author(s): Lorenzo De Liso
  • Date: 2010-06-21 22:47:10 UTC
  • mfrom: (2.1.7 sid)
  • Revision ID: james.westby@ubuntu.com-20100621224710-9t1iyiglri330pss
Tags: 2.8.8-1ubuntu1
* Merge from debian unstable (LP: #597042), remaining changes:
  - debian/patches:
    + series: Refreshed.
    + 01_serverlist.patch: Numerous changes to default serverlist.
    + 02_ubuntu_default_server.patch: select "Ubuntu servers" by default.
    + 37_lpi.patch: Add launchpad integration.
    + 38_autoconf.patch: Autoconf modifications for launchpad integration.
    + 45_brand_ctcp_version.patch: Add Ubuntu brand to CTCP version response.
    + 70_notification_strings_shorten.patch: Shorten notification strings.
  - debian/control:
    + Build-depend on libgtk2.0-dev (>= 2.10.0).
    + Build-depend on liblaunchpad-integration-dev.
    + Remove conflict/replaces on xchat-gnome.
    + Updated Maintainer field to match Ubuntu Developers.
  - debian/rules:
    + Make build independent of the python version.
  - debian/patches/45_ctcp_version_less_information.dpatch: 
    + Renamed to debian/patches/45_brand_ctcp_version.patch
    + Added short description.
* Converted all patches to quilt, as in debian quilt has been
  adopted, all old dpatch patches have been renamed with the 
  *.patch extension.
* Dropped changes:
  - 71_notification_icon_change.patch: can't be applied

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
## 01_serverlist.dpatch by evo, edited by bartm, edited by asisak, edited by
 
2
## warp10, ember
 
3
##
 
4
## DP: Add debian and chillfactory irc servers.
 
5
## DP: Make Debian servers default.
 
6
## DP: Remove Aitvaras IPV6 servers
 
7
## DP: Connect irc.ubuntu.com and irc.freelists.org to port 8001.
 
8
## DP: Fix oz.org referred as "OzNet" and conncting to wrong servers.
 
9
## DP: Refresh patch for 2.8.6
 
10
 
 
11
diff -urNad xchat-2.8.6~/src/common/servlist.c xchat-2.8.6/src/common/servlist.c
 
12
--- xchat-2.8.6~/src/common/servlist.c  2008-04-01 09:22:34.000000000 +0100
 
13
+++ xchat-2.8.6/src/common/servlist.c   2008-06-22 13:27:45.000000000 +0100
 
14
@@ -46,6 +46,12 @@
 
15
 
 
16
 static const struct defaultserver def[] =
 
17
 {
 
18
+       {"Debian Servers", 0, "#debian"},
 
19
+       {0,                     "irc.debian.org"},
 
20
+
 
21
+       {"Ubuntu Servers", 0, "#ubuntu"},
 
22
+       {0,                     "irc.ubuntu.com/8001"},
 
23
+
 
24
        {"2600net",     0},
 
25
        {0,                     "irc.2600.net"},
 
26
 
 
27
@@ -59,12 +65,12 @@
 
28
        {0,                     "eu.afternet.org"},
 
29
 
 
30
        {"Aitvaras",    0},
 
31
-#ifdef USE_IPV6
 
32
+/*#ifdef USE_IPV6
 
33
 #ifdef USE_OPENSSL
 
34
        {0,                     "irc6.ktu.lt/+7668"},
 
35
 #endif
 
36
        {0,                     "irc6.ktu.lt/7666"},
 
37
-#endif
 
38
+#endif*/
 
39
 #ifdef USE_OPENSSL
 
40
        {0,                     "irc.data.lt/+6668"},
 
41
        {0,                     "irc-ssl.omnitel.net/+6668"},
 
42
@@ -137,6 +143,9 @@
 
43
        {"ChatSpike", 0},
 
44
        {0,                     "irc.chatspike.net"},
 
45
 
 
46
+       {"ChillFactory", 0},
 
47
+       {0,                     "irc.chillfactory.net"},
 
48
+
 
49
        {"CoolChat",    0},
 
50
        {0,                     "irc.coolchat.net"},
 
51
 /*     {0,                     "unix.coolchat.net"},
 
52
@@ -207,7 +216,7 @@
 
53
        {0,                     "irc.vendetta.com"},
 
54
 
 
55
        {"FreeNode",    0},
 
56
-       {0,                             "irc.freenode.net"},
 
57
+       {0,                             "irc.freenode.net/8001"},
 
58
 
 
59
 /*     {"Freeworld",   0},
 
60
        {0,                     "kabel.freeworld.nu"},
 
61
@@ -339,7 +348,14 @@
 
62
 
 
63
        {"OzNet",       0},
 
64
        {0,                     "irc.oz.org"},
 
65
-
 
66
+       {0,                     "germany.oz.org"},
 
67
+       {0,                     "sandiego.oz.org"},
 
68
+       {0,                     "us.oz.org"},
 
69
+       {0,                     "au.oz.org"},
 
70
+       {0,                     "rockhampton.oz.org"},
 
71
+       {0,                     "wollongong.oz.org"},
 
72
+       {0,                     "waix.oz.org"}, 
 
73
+       
 
74
        {"PTlink",      0},
 
75
        {0,                     "irc.PTlink.net"},
 
76
        {0,                     "aaia.PTlink.net"},
 
77
@@ -900,7 +916,7 @@
 
78
                                free (net->encoding);
 
79
                                net->encoding = strdup (def[i].charset);
 
80
                        }
 
81
-                       if (g_str_hash (def[i].network) == 0x8e1b96f7)
 
82
+                       if (g_str_hash (def[i].network) == 0x37473b25)
 
83
                                prefs.slist_select = j;
 
84
                        j++;
 
85
                } else