~ubuntu-branches/ubuntu/maverick/xchat/maverick

« back to all changes in this revision

Viewing changes to debian/patches/70_notification_strings_shorten.patch

  • Committer: Bazaar Package Importer
  • Author(s): Lorenzo De Liso
  • Date: 2010-06-21 22:47:10 UTC
  • mfrom: (2.1.7 sid)
  • Revision ID: james.westby@ubuntu.com-20100621224710-9t1iyiglri330pss
Tags: 2.8.8-1ubuntu1
* Merge from debian unstable (LP: #597042), remaining changes:
  - debian/patches:
    + series: Refreshed.
    + 01_serverlist.patch: Numerous changes to default serverlist.
    + 02_ubuntu_default_server.patch: select "Ubuntu servers" by default.
    + 37_lpi.patch: Add launchpad integration.
    + 38_autoconf.patch: Autoconf modifications for launchpad integration.
    + 45_brand_ctcp_version.patch: Add Ubuntu brand to CTCP version response.
    + 70_notification_strings_shorten.patch: Shorten notification strings.
  - debian/control:
    + Build-depend on libgtk2.0-dev (>= 2.10.0).
    + Build-depend on liblaunchpad-integration-dev.
    + Remove conflict/replaces on xchat-gnome.
    + Updated Maintainer field to match Ubuntu Developers.
  - debian/rules:
    + Make build independent of the python version.
  - debian/patches/45_ctcp_version_less_information.dpatch: 
    + Renamed to debian/patches/45_brand_ctcp_version.patch
    + Added short description.
* Converted all patches to quilt, as in debian quilt has been
  adopted, all old dpatch patches have been renamed with the 
  *.patch extension.
* Dropped changes:
  - 71_notification_icon_change.patch: can't be applied

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
 
 
2
=== modified file 'src/fe-gtk/plugin-tray.c'
 
3
--- old/src/fe-gtk/plugin-tray.c        2008-10-31 17:46:48 +0000
 
4
+++ new/src/fe-gtk/plugin-tray.c        2009-03-13 12:06:32 +0000
 
5
@@ -653,7 +653,7 @@
 
6
        }
 
7
 
 
8
        if (prefs.input_balloon_hilight)
 
9
-               tray_set_balloonf (word[2], _("XChat: Highlighted message from: %s (%s)"),
 
10
+               tray_set_balloonf (word[2], _("%s (%s)"),
 
11
                                                                 word[1], xchat_get_info (ph, "channel"));
 
12
 
 
13
        return XCHAT_EAT_NONE;
 
14
@@ -678,8 +678,8 @@
 
15
        }
 
16
 
 
17
        if (prefs.input_balloon_chans)
 
18
-               tray_set_balloonf (word[2], _("XChat: New public message from: %s (%s)"),
 
19
-                                                                word[1], xchat_get_info (ph, "channel"));
 
20
+               tray_set_balloonf (word[2], _("%s (%s)"),
 
21
+                                                                word[1], xchat_get_info(ph, "channel"));
 
22
 
 
23
        return XCHAT_EAT_NONE;
 
24
 }
 
25
@@ -707,8 +707,8 @@
 
26
                                                        tray_priv_count, from, network);
 
27
 
 
28
        if (prefs.input_balloon_priv)
 
29
-               tray_set_balloonf (text, _("XChat: Private message from: %s (%s)"),
 
30
-                                                                from, network);
 
31
+               tray_set_balloonf (text, "%s",
 
32
+                                                                from);
 
33
 }
 
34
 
 
35
 static int
 
36
@@ -761,8 +761,8 @@
 
37
        }
 
38
 
 
39
        if (prefs.input_balloon_priv)
 
40
-               tray_set_balloonf ("", _("XChat: File offer from: %s (%s)"),
 
41
-                                                               word[1], network);
 
42
+               tray_set_balloonf (_("is offering you a file."), "%s",
 
43
+                                                               word[1]);
 
44
 
 
45
        return XCHAT_EAT_NONE;
 
46
 }
 
47