~ubuntu-branches/ubuntu/oneiric/awstats/oneiric

« back to all changes in this revision

Viewing changes to debian/patches/1003_redirect_to_STDERR.patch

  • Committer: Bazaar Package Importer
  • Author(s): Jonas Smedegaard, Sergey B Kirpichev, Jonas Smedegaard
  • Date: 2009-03-03 18:19:24 UTC
  • mfrom: (1.2.6 upstream)
  • Revision ID: james.westby@ubuntu.com-20090303181924-szfwaw0qmfdg7m6b
Tags: 6.9~dfsg-1
[ Sergey B Kirpichev ]
* New upstream release (Closes: #494676).
* Add myself to Uploaders field. 
* Drop patches 0001 and 1005 (applied upstream).
* Unfuzz patches 1002-1004.
* Add new patch 1007 updating Russian translation. Thanks to Sergey
  Kirpichev at upstream tracker #2540486.
* Add new patch 1008 enhancing the ExtraSection headings to include
  the words (Top XXX) for consistency with all other section headings.
* Add new patch 1009 fixing URL to Hurd (Closes: #408086).
* Add new patch 1010 fixing dirdata permissions (Closes: #299148).
* Add new patch 1011 fixing Geo::IPfree warnings (Closes: #512373).
* Add new patch 2001 hiding charts in days of month statistics.
* Use debian defaults for geoip data files.

[ Jonas Smedegaard ]
* Repackage upstream tarball.
* Packaging moved to Git (from Subversion). Update debian/control and
  git-buildpackage configfile, enabling pristine-tar support.
* Use new local CDBS snippet package-relations.mk to resolve, cleanup
  and apply CDBS-declared (build-)dependencies.
* Add DEB_MAINTAINER_MODE in debian/rules (thanks to Romain Beauxis).
* Update local CDBS snippets:
  + upstream-tarball.mk: internal restructuring
  + buildinfo.mk: fix copyright years
  + copyright-check.mk: major rewrite, now generating hint file more
    readily usable as template for new proposed copyright format
  + Update README.cdbs-tweaks to also cover newly added package-
    relations.mk.
* Rewrite debian/copyright using new proposed syntax (v440). Update
  copyright-hints.
* Unfuzz patch 1006.
* Depend on misc:depends (thanks to lintian) and cdbs:depends
  (currently unused, and drop superfluous dependencies (fulfilled by
  perl even in oldstable).

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Index: awstats-6.6/tools/awstats_buildstaticpages.pl
 
1
Index: awstats-6.9/tools/awstats_buildstaticpages.pl
2
2
===================================================================
3
 
--- awstats-6.6.orig/tools/awstats_buildstaticpages.pl  2006-02-08 17:26:14.000000000 -0500
4
 
+++ awstats-6.6/tools/awstats_buildstaticpages.pl       2007-01-13 12:39:43.000000000 -0500
5
 
@@ -75,7 +75,7 @@
 
3
--- awstats-6.9.orig/tools/awstats_buildstaticpages.pl  2008-09-25 21:08:26.000000000 +0400
 
4
+++ awstats-6.9/tools/awstats_buildstaticpages.pl       2009-01-26 16:45:39.000000000 +0300
 
5
@@ -79,7 +79,7 @@
6
6
 # Return:              None
7
7
 #------------------------------------------------------------------------------
8
8
 sub error {
11
11
     exit 1;
12
12
 }
13
13
 
14
 
@@ -95,7 +95,7 @@
 
14
@@ -99,7 +99,7 @@
15
15
 #              print "$messagestring<br />\n";
16
16
 #      }
17
17
 #      else {
20
20
 #      }
21
21
 #      }
22
22
 }
23
 
Index: awstats-6.6/tools/awstats_configure.pl
 
23
Index: awstats-6.9/tools/awstats_configure.pl
24
24
===================================================================
25
 
--- awstats-6.6.orig/tools/awstats_configure.pl 2006-02-08 17:26:14.000000000 -0500
26
 
+++ awstats-6.6/tools/awstats_configure.pl      2007-01-13 12:39:43.000000000 -0500
27
 
@@ -87,7 +87,7 @@
 
25
--- awstats-6.9.orig/tools/awstats_configure.pl 2008-04-06 17:45:24.000000000 +0400
 
26
+++ awstats-6.9/tools/awstats_configure.pl      2009-01-26 16:45:39.000000000 +0300
 
27
@@ -88,7 +88,7 @@
28
28
 # error
29
29
 #-------------------------------------------------------
30
30
 sub error {
33
33
     exit 1;
34
34
 }
35
35
 
36
 
Index: awstats-6.6/tools/awstats_exportlib.pl
 
36
Index: awstats-6.9/tools/awstats_exportlib.pl
37
37
===================================================================
38
 
--- awstats-6.6.orig/tools/awstats_exportlib.pl 2003-12-05 18:53:38.000000000 -0500
39
 
+++ awstats-6.6/tools/awstats_exportlib.pl      2007-01-13 12:39:43.000000000 -0500
 
38
--- awstats-6.9.orig/tools/awstats_exportlib.pl 2008-04-27 20:47:20.000000000 +0400
 
39
+++ awstats-6.9/tools/awstats_exportlib.pl      2009-01-26 16:47:29.000000000 +0300
40
40
@@ -93,8 +93,8 @@
41
 
        my $thirdmessage=shift||"";
42
 
        my $donotshowsetupinfo=shift||0;
43
 
        if ($Debug) { debug("$message $secondmessage $thirdmessage",1); }
44
 
-       print "$message";
45
 
-       print "\n";
46
 
+       print STDERR "$message";
47
 
+       print STDERR "\n";
48
 
        exit 1;
49
 
 }
50
 
 
51
 
Index: awstats-6.6/tools/awstats_updateall.pl
 
41
        my $thirdmessage=shift||"";
 
42
        my $donotshowsetupinfo=shift||0;
 
43
        if ($Debug) { debug("$message $secondmessage $thirdmessage",1); }
 
44
-       print "$message";
 
45
-       print "\n";
 
46
+       print STDERR "$message";
 
47
+       print STDERR "\n";
 
48
        exit 1;
 
49
 }
 
50
 
 
51
Index: awstats-6.9/tools/awstats_updateall.pl
52
52
===================================================================
53
 
--- awstats-6.6.orig/tools/awstats_updateall.pl 2006-07-23 19:57:48.000000000 -0400
54
 
+++ awstats-6.6/tools/awstats_updateall.pl      2007-01-13 12:39:43.000000000 -0500
 
53
--- awstats-6.9.orig/tools/awstats_updateall.pl 2006-07-24 02:57:48.000000000 +0400
 
54
+++ awstats-6.9/tools/awstats_updateall.pl      2009-01-26 16:45:39.000000000 +0300
55
55
@@ -37,7 +37,7 @@
56
56
 # Return:              None
57
57
 #------------------------------------------------------------------------------
61
61
     exit 1;
62
62
 }
63
63
 
64
 
Index: awstats-6.6/tools/logresolvemerge.pl
 
64
Index: awstats-6.9/tools/logresolvemerge.pl
65
65
===================================================================
66
 
--- awstats-6.6.orig/tools/logresolvemerge.pl   2006-10-26 15:53:34.000000000 -0400
67
 
+++ awstats-6.6/tools/logresolvemerge.pl        2007-01-13 12:40:34.000000000 -0500
68
 
@@ -106,7 +106,7 @@
 
66
--- awstats-6.9.orig/tools/logresolvemerge.pl   2008-11-15 17:58:02.000000000 +0300
 
67
+++ awstats-6.9/tools/logresolvemerge.pl        2009-01-26 16:45:39.000000000 +0300
 
68
@@ -107,7 +107,7 @@
69
69
 # Return:              None
70
70
 #------------------------------------------------------------------------------
71
71
 sub error {
74
74
     exit 1;
75
75
 }
76
76
 
77
 
@@ -135,7 +135,7 @@
 
77
@@ -136,7 +136,7 @@
78
78
 sub warning {
79
79
        my $messagestring=shift;
80
80
        if ($Debug) { debug("$messagestring",1); }
83
83
 }
84
84
 
85
85
 #-----------------------------------------------------------------------------
86
 
Index: awstats-6.6/tools/maillogconvert.pl
 
86
Index: awstats-6.9/tools/maillogconvert.pl
87
87
===================================================================
88
 
--- awstats-6.6.orig/tools/maillogconvert.pl    2006-11-28 16:00:42.000000000 -0500
89
 
+++ awstats-6.6/tools/maillogconvert.pl 2007-01-13 12:39:43.000000000 -0500
 
88
--- awstats-6.9.orig/tools/maillogconvert.pl    2008-09-05 02:29:24.000000000 +0400
 
89
+++ awstats-6.9/tools/maillogconvert.pl 2009-01-26 16:45:39.000000000 +0300
90
90
@@ -56,7 +56,7 @@
91
91
 #-------------------------------------------------------
92
92