~ubuntu-branches/ubuntu/oneiric/isc-dhcp/oneiric-security

« back to all changes in this revision

Viewing changes to debian/patches/dhclient-script-exit-status.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Andrew Pollock
  • Date: 2009-09-02 22:34:25 UTC
  • Revision ID: james.westby@ubuntu.com-20090902223425-e060dofnj2yf8zzf
Tags: 4.1.0-1
* The "throw everything out and start over" release
* New upstream release
* debian/control: drop 3 from the binary package names, adjust dependencies,
  maintainer scripts, accordingly
* use debhelper more extensively, de-cruft debian/rules
* remove dhcp-server preinst
* add debug packages
* add transitional packages
* add debian/README.source
* debian/control: bumped Standards-Version
* debian/isc-dhcp-server.postinst: transfer existing config and lease files
  when upgrading from dhcp3-server
* debian/isc-dhcp-client.postinst: transfer existing config file when
  upgrading from dhcp3-client
* debian/changelog: added marker for legacy malformed changelog entry to
  placate Lintian
* add a patch to correct groff warnings in man pages
* add a patch to ignore checksums on the loopback interface
* debian/control: make isc-dhcp-client depend on ifupdown that invokes
  /sbin/dhclient correctly

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## dhclient-script-exit-status.dpatch by  <apollock@debian.org>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: Use exit status 2, rather than 1, to indicate that binding failed,
 
6
## DP: so that unrelated errors do not result in DHCPDECLINE
 
7
 
 
8
@DPATCH@
 
9
diff -urNad dhcp3-3.0.2/client/dhclient.c /tmp/dpep.DiNW3N/dhcp3-3.0.2/client/dhclient.c
 
10
--- dhcp3-3.0.2/client/dhclient.c       2004-11-25 04:39:14.000000000 +1100
 
11
+++ /tmp/dpep.DiNW3N/dhcp3-3.0.2/client/dhclient.c      2005-06-15 12:51:38.952349445 +1000
 
12
@@ -869,7 +869,7 @@
 
13
        /* If the BOUND/RENEW code detects another machine using the
 
14
           offered address, it exits nonzero.  We need to send a
 
15
           DHCPDECLINE and toss the lease. */
 
16
-       if (script_go (client)) {
 
17
+       if (script_go (client) == 2) {
 
18
                make_decline (client, client -> new);
 
19
                send_decline (client);
 
20
                destroy_client_lease (client -> new);