~ubuntu-branches/ubuntu/saucy/gnome-control-center/saucy-proposed

« back to all changes in this revision

Viewing changes to debian/patches/00git_online_accounts_gtkgrid.patch

  • Committer: Package Import Robot
  • Author(s): Sebastien Bacher, Sebastien Bacher, Robert Ancell, Iain Lane, Edward Donovan, Rico Tzschichholz, Jeremy Bicha, David Henningsson
  • Date: 2012-11-21 19:32:45 UTC
  • mfrom: (1.1.63)
  • Revision ID: package-import@ubuntu.com-20121121193245-mj61nzz1z4fk3z25
Tags: 1:3.6.3-0ubuntu1
[ Sebastien Bacher ]
* New upstream version
* debian/control.in: recommends libcanberra-pulse (lp: #1004973)
* debian/patches/58_ubuntu_icon_views_redesign.patch:
  - drop most of the changes, keep the different grid size though
    to fit on screen with our extra icons
* debian/patches/91_dont_show_in_unity.patch:
  - dropped, show the upstream printer panel and the layout tab
* debian/patches/revert_git_keyboard_gsettings.patch,
  debian/patches/revert_git_stop_using_gconf.patch:
  - dropped the gconf->gsettings reverts

[ Robert Ancell ]
* New upstream release (LP: #1010317)
* debian/control:
  - Bump build-depends on libgnome-desktop-3-dev, libwacom-dev
  - Add build-depends on libclutter-1.0-dev, libclutter-gtk-1.0-dev,
    libpwquality-dev
  - Drop build-depends on libgnomekbd-dev
* debian/patches/60_ubuntu_nav_bar.patch:
  - Disabled for now, doesn't apply
* debian/patches/revert_ua_gsettings.patch:
  - We can use GSettings for universal access now
* debian/patches/00git_online_accounts_gtkgrid.patch:
* debian/patches/00git_online_accounts_layout.part:
* debian/patches/git_wacom_translations.patch:
  - Applied upstream

[ Iain Lane ]
* Add Build-Depends on libxkbfile-dev
* New upstream release.
* Refresh all patches to apply cleanly.

[ Edward Donovan ]
* debian/source_gnome-control-center.py: Fix for Python 3. (LP: #1013171)

[ Rico Tzschichholz ]
* debian/control.in:
  - Build-depend on gtk-doc-tools instead of docbook directly
  - Bump minimum glib-2.0, gnome-desktop3, gnome-settings-daemon
     and gsettings-desktop-schemas

[ Jeremy Bicha ]
* Dropped more patches applied in new version:
  - git_unmute_sound_event.patch
  - git_fix_big_editable_labels.patch
  - 96_sound_nua_panel.patch
* debian/patches/04_new_appearance_settings.patch:
  - Dropped, this is now packaged separately as gnome-control-center-unity
* debian/patches/10_keyboard_layout_on_unity.patch:
  - Don't change the keyboard panel name when not running Unity
* debian/patches/52_ubuntu_language_list_mods.patch:
  - Don't disable adding current language to the list. While this
    fix shows the current language twice, at least it avoids the
    "Ubuntu suddenly in Chinese" bug (LP: #1035219)
* debian/patches/53_use_ubuntu_help.patch:
  - Only show Ubuntu help when running Unity
* debian/patches/58_hide_gdm_notifications.patch:
  - Hide "Show notifications when locked" settings when running Unity
    since it's a GNOME Shell-specific feature
* debian/patches/63_normal_scrollbar_in_a11y.patch:
  - Drop, overlay-scrollbars should handle this instead
* debian/patches/91_dont_show_in_unity.patch:
  - Hide Printers & Region panels in Unity until we're ready to switch
    to them.
* debian/patches/fix-crash-on-user-panel.patch:
  - Dropped, GNOME says it's obsolete
* debian/rules:
  - Build with -z,defs again
  - Explicitly disable ibus support since ibus 1.4 isn't supported in
    this version
* debian/control.in:
  - Drop ubuntu-docs and gnome-user-guide from recommends to suggests
  - Don't recommend indicators; let's leave that to Unity

[ David Henningsson ]
* sound_nua_panel.patch: Rebase to gnome 3.6 

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From 3ae795ea6ec09c8a1d49533510904dec9425f617 Mon Sep 17 00:00:00 2001
2
 
From: Debarshi Ray <debarshir@gnome.org>
3
 
Date: Sat, 14 Apr 2012 21:10:37 +0000
4
 
Subject: online-accounts: goa_provider_show_account now expects GtkGrids, not GtkTable
5
 
 
6
 
Fixes: https://bugzilla.gnome.org/669625
7
 
---
8
 
diff --git a/panels/online-accounts/cc-online-accounts-panel.c b/panels/online-accounts/cc-online-accounts-panel.c
9
 
index 7891203..94d1bea 100644
10
 
--- a/panels/online-accounts/cc-online-accounts-panel.c
11
 
+++ b/panels/online-accounts/cc-online-accounts-panel.c
12
 
@@ -323,8 +323,9 @@ show_page_account (GoaPanel  *panel,
13
 
 {
14
 
   GList *children;
15
 
   GList *l;
16
 
-  GtkWidget *alignment;
17
 
-  GtkWidget *table;
18
 
+  GtkWidget *grid;
19
 
+  GtkWidget *left_grid;
20
 
+  GtkWidget *right_grid;
21
 
   GtkWidget *bar;
22
 
   GtkWidget *label;
23
 
   GoaProvider *provider;
24
 
@@ -357,9 +358,16 @@ show_page_account (GoaPanel  *panel,
25
 
       g_signal_connect (bar, "response", G_CALLBACK (on_info_bar_response), panel);
26
 
     }
27
 
 
28
 
-  table = gtk_table_new (3, 2, FALSE);
29
 
-  gtk_table_set_row_spacings (GTK_TABLE (table), 0);
30
 
-  gtk_table_set_col_spacings (GTK_TABLE (table), 12);
31
 
+  left_grid = gtk_grid_new ();
32
 
+  gtk_widget_set_halign (left_grid, GTK_ALIGN_END);
33
 
+  gtk_widget_set_hexpand (left_grid, TRUE);
34
 
+  gtk_orientable_set_orientation (GTK_ORIENTABLE (left_grid), GTK_ORIENTATION_VERTICAL);
35
 
+  gtk_grid_set_row_spacing (GTK_GRID (left_grid), 0);
36
 
+
37
 
+  right_grid = gtk_grid_new ();
38
 
+  gtk_widget_set_hexpand (right_grid, TRUE);
39
 
+  gtk_orientable_set_orientation (GTK_ORIENTABLE (right_grid), GTK_ORIENTATION_VERTICAL);
40
 
+  gtk_grid_set_row_spacing (GTK_GRID (right_grid), 0);
41
 
 
42
 
   if (provider != NULL)
43
 
     {
44
 
@@ -367,12 +375,16 @@ show_page_account (GoaPanel  *panel,
45
 
                                  panel->client,
46
 
                                  object,
47
 
                                  GTK_BOX (panel->accounts_vbox),
48
 
-                                 GTK_TABLE (table));
49
 
+                                 GTK_GRID (left_grid),
50
 
+                                 GTK_GRID (right_grid));
51
 
     }
52
 
 
53
 
-  alignment = gtk_alignment_new (0.5, 0.0, 0.0, 0.0);
54
 
-  gtk_container_add (GTK_CONTAINER (alignment), table);
55
 
-  gtk_box_pack_start (GTK_BOX (panel->accounts_vbox), alignment, FALSE, TRUE, 0);
56
 
+  grid = gtk_grid_new ();
57
 
+  gtk_orientable_set_orientation (GTK_ORIENTABLE (grid), GTK_ORIENTATION_HORIZONTAL);
58
 
+  gtk_grid_set_column_spacing (GTK_GRID (grid), 12);
59
 
+  gtk_container_add (GTK_CONTAINER (grid), left_grid);
60
 
+  gtk_container_add (GTK_CONTAINER (grid), right_grid);
61
 
+  gtk_box_pack_start (GTK_BOX (panel->accounts_vbox), grid, FALSE, TRUE, 0);
62
 
 
63
 
   gtk_widget_show_all (panel->accounts_vbox);
64
 
 
65
 
--
66
 
cgit v0.9.0.2