~ubuntu-branches/ubuntu/saucy/sane-backends/saucy

« back to all changes in this revision

Viewing changes to debian/patches/allow_dll.d_symlinks.patch

  • Committer: Bazaar Package Importer
  • Author(s): Robert Ancell
  • Date: 2011-02-14 14:28:56 UTC
  • mfrom: (1.2.2 upstream)
  • Revision ID: james.westby@ubuntu.com-20110214142856-6gxjetg88q9zctid
Tags: 1.0.22-0ubuntu1
* New upstream release
* debian/control:
  - Use standards version 3.9.1
* debian/patches/allow_dll.d_symlinks.patch:
* debian/patches/fix_epson2_cancel.patch:
* debian/patches/fix_epson2_commands.patch:
* debian/patches/fix_xerox_mfp_color_mode.patch:
* debian/patches/genesys_disable_raw_data_log.patch:
* debian/patches/no_translations.patch:
* debian/patches/saned_exit_avahi_process.patch:
* debian/patches/scsi_perfection_2450.patch:
* debian/patches/scsi_scanjet_4c.patch:
* debian/patches/xerox_mfp_new_ids.patch:
  - Applied upstream
* debian/watch:
  - Dropped, the URL is not consistent between releases

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Description: Allow symlinks under /etc/sane.d/dll.d
2
 
 Symlinks were not allowed due to the use of lstat(), switch to using stat()
3
 
 instead.
4
 
Author: Julien BLACHE <jblache@debian.org>
5
 
 
6
 
Index: sane-backends-1.0.21/backend/dll.c
7
 
===================================================================
8
 
--- sane-backends-1.0.21.orig/backend/dll.c     2010-07-09 18:17:45.464558452 +0200
9
 
+++ sane-backends-1.0.21/backend/dll.c  2010-07-09 18:18:27.567557502 +0200
10
 
@@ -779,7 +779,7 @@
11
 
   DBG (5, "sane_init/read_dlld: processing %s ...\n",
12
 
        STRINGIFY(PATH_SANE_CONFIG_DIR) "/dll.d");
13
 
 
14
 
-  /* Debian specific: read files under $sysconfdir/sane.d/dll.d */
15
 
+  /* Read files under $sysconfdir/sane.d/dll.d */
16
 
   dlld = opendir (STRINGIFY(PATH_SANE_CONFIG_DIR) "/dll.d");
17
 
 
18
 
   if (dlld == NULL)
19
 
@@ -809,7 +809,7 @@
20
 
 
21
 
       DBG (5, "sane_init/read_dlld: considering %s\n", conffile);
22
 
 
23
 
-      if (lstat (conffile, &st) != 0)
24
 
+      if (stat (conffile, &st) != 0)
25
 
         continue;
26
 
 
27
 
       if (!S_ISREG (st.st_mode))