~ubuntu-branches/ubuntu/saucy/sane-backends/saucy

« back to all changes in this revision

Viewing changes to debian/patches/fix_epson2_cancel.patch

  • Committer: Bazaar Package Importer
  • Author(s): Robert Ancell
  • Date: 2011-02-14 14:28:56 UTC
  • mfrom: (1.2.2 upstream)
  • Revision ID: james.westby@ubuntu.com-20110214142856-6gxjetg88q9zctid
Tags: 1.0.22-0ubuntu1
* New upstream release
* debian/control:
  - Use standards version 3.9.1
* debian/patches/allow_dll.d_symlinks.patch:
* debian/patches/fix_epson2_cancel.patch:
* debian/patches/fix_epson2_commands.patch:
* debian/patches/fix_xerox_mfp_color_mode.patch:
* debian/patches/genesys_disable_raw_data_log.patch:
* debian/patches/no_translations.patch:
* debian/patches/saned_exit_avahi_process.patch:
* debian/patches/scsi_perfection_2450.patch:
* debian/patches/scsi_scanjet_4c.patch:
* debian/patches/xerox_mfp_new_ids.patch:
  - Applied upstream
* debian/watch:
  - Dropped, the URL is not consistent between releases

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
commit 9a89932ab4624925794532ab5e5610e3b0190d53
2
 
Author: Olaf Meeuwissen <olaf.meeuwissen@avasys.jp>
3
 
Date:   Sun Dec 12 16:25:17 2010 +0100
4
 
 
5
 
        epson2: fixed issue when a scan is cancelled
6
 
 
7
 
Index: sane-backends-1.0.21/backend/epson2-ops.c
8
 
===================================================================
9
 
--- sane-backends-1.0.21.orig/backend/epson2-ops.c      2010-11-29 18:12:09.682154520 +0100
10
 
+++ sane-backends-1.0.21/backend/epson2-ops.c   2010-12-12 16:34:42.911151001 +0100
11
 
@@ -1721,6 +1721,7 @@
12
 
 
13
 
                if (s->buf[buf_len] & FSG_STATUS_CANCEL_REQ) {
14
 
                        DBG(0, "%s: cancel request received\n", __func__);
15
 
+                       e2_cancel(s);
16
 
                        return SANE_STATUS_CANCELLED;
17
 
                }
18