~ubuntu-branches/ubuntu/trusty/ginkgocadx/trusty

« back to all changes in this revision

Viewing changes to debian/patches/fix-wx.patch

  • Committer: Package Import Robot
  • Author(s): Dmitry Smirnov
  • Date: 2013-07-21 11:58:53 UTC
  • mfrom: (7.2.1 sid)
  • Revision ID: package-import@ubuntu.com-20130721115853-44e7n1xujqglu78e
Tags: 3.4.0.928.29+dfsg-1
* New upstream release [July 2013]
  + new B-D: "libjsoncpp-dev".
  + new patch "unbundle-libjsoncpp.patch" to avoid building bundled
    "libjsoncpp-dev".
  + new patch "fix-wx.patch" to avoid FTBFS due to missing
    "-lwx_gtk2u_html-2.8".
* Removed unnecessary versioned Build-Depends.
* Removed obsolete lintian override.
* Reference get-orig-source implementation for orig.tar clean-up and
  DFSG-repackaging.
* Upload to unstable.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Last-Update: 2013-07-21
 
2
Forwarded: no
 
3
Author: Dmitry Smirnov <onlyjob@member.fsf.org>
 
4
Description: fix FTBFS due to missing "-lwx_gtk2u_html-2.8"
 
5
    /usr/bin/ld: ../cadxcore/libCADxCore.a(aboutdialogbase.cpp.o): undefined reference to symbol 'wxEVT_COMMAND_HTML_LINK_CLICKED@@WXU_2.8'
 
6
    /usr/lib/x86_64-linux-gnu/libwx_gtk2u_html-2.8.so.0: error adding symbols: DSO missing from command line
 
7
 
 
8
--- a/src/CMakeLists.txt
 
9
+++ b/src/CMakeLists.txt
 
10
@@ -52,9 +52,9 @@
 
11
 ENDIF()
 
12
 
 
13
 IF(NOT USE_CUSTOM_WX)
 
14
 MESSAGE("Using system wxWidgets")
 
15
-FIND_PACKAGE(wxWidgets 2.8.11 COMPONENTS core base gl net xml aui adv richtext xrc REQUIRED)
 
16
+FIND_PACKAGE(wxWidgets 2.8.11 COMPONENTS core base html gl net xml aui adv richtext xrc REQUIRED)
 
17
 ELSE()
 
18
 MESSAGE("Using custom wxWidgets")
 
19
 SET_CUSTOM_wxWidgets_PACKAGE()
 
20
 ENDIF()