~ubuntu-branches/ubuntu/utopic/geany/utopic

« back to all changes in this revision

Viewing changes to debian/patches/20_debian_control_tags.patch

  • Committer: Package Import Robot
  • Author(s): Chow Loong Jin
  • Date: 2011-12-10 07:43:26 UTC
  • mfrom: (3.3.7 sid)
  • Revision ID: package-import@ubuntu.com-20111210074326-s8yqbew5i20h33tf
Tags: 0.21-1ubuntu1
* Merge from Debian Unstable, remaining changes:
  - debian/patches/20_use_evince_viewer.patch:
     + use evince as viewer for pdf and dvi files
  - debian/patches/20_use_x_terminal_emulator.patch:
     + use x-terminal-emulator as terminal
  - debian/control
     + Add breaks on geany-plugins-common << 0.20
* Also fixes bugs:
  - Filter for MATLAB/Octave files filters everythign (LP: 885505)

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Author: Damián Viano <des@debian.org>
 
2
Description: Add support for having 'Source:' and 'Package:' as tags in a 
 
3
RFC2822 file as debian/control
 
4
--- geany.orig/tagmanager/conf.c
 
5
+++ geany/tagmanager/conf.c
 
6
@@ -14,6 +14,7 @@
 
7
 #include "general.h"   /* must always come first */
 
8
 
 
9
 #include <ctype.h>
 
10
+#include <string.h>
 
11
 
 
12
 #include "parse.h"
 
13
 #include "read.h"
 
14
@@ -73,6 +74,20 @@
 
15
                        vStringClear (name);
 
16
                        continue;
 
17
                }
 
18
+
 
19
+               /* look for a stanza */
 
20
+               if (*cp != '\0' && (strncmp((const char*) cp, "Source:", 7) == 0 ||
 
21
+                       strncmp((const char*) cp, "Package:", 8) == 0))
 
22
+               {
 
23
+                       cp = (const unsigned char*) strchr((const char*) cp, ':') + 1;
 
24
+                       while (isspace ((int) *cp))
 
25
+                               ++cp;
 
26
+                       vStringCopyS (name, (const char*) cp);
 
27
+                       vStringTerminate (name);
 
28
+                       makeSimpleTag (name, ConfKinds, K_SECTION);
 
29
+                       vStringClear (name);
 
30
+                       continue;
 
31
+               }
 
32
 
 
33
                while (*cp != '\0')
 
34
                {