~ubuntu-branches/ubuntu/utopic/gnome-settings-daemon/utopic

« back to all changes in this revision

Viewing changes to debian/patches/git_new_cups_build.patch

  • Committer: Package Import Robot
  • Author(s): Sebastien Bacher, Sebastien Bacher, Robert Ancell, Rico Tzschichholz, Iain Lane
  • Date: 2012-11-21 17:16:23 UTC
  • mfrom: (1.1.62)
  • Revision ID: package-import@ubuntu.com-20121121171623-k7iufrs14qoiozeq
Tags: 3.6.3-0ubuntu1
[ Sebastien Bacher ]
* New upstream version (lp: #1008840)
* debian/patches/git*,
  debian/patches/power-ignore-bad-dbus-requests.patch,
  debian/patches/power-ignore-bad-dbus-requests.patch,
  debian/patches/10_smaller_syndaemon_timeout.patch: 
  - dropped, those fixes are in the new version
* debian/control.in:
  - restore build-depends on libgnomekbd-dev, libxklavier-dev,
    drop the build-depends on libxkbfile-dev
* debian/patches/20_migrate_background_uri.patch:
  - dropped, it was only needed until the LTS
* debian/patches/40_xres_lcddefault.patch:
  - dropped, that was a workaround for libreoffice that shouldn't be
    needed and we should better fix libreoffice
* debian/patches/61_unity_use_application_indicator.patch:
  - drop the keyboard indicator code, that will need to be turned 
    into a proper indicator refactored to handle the new ibus config
* debian/patches/90_set_gmenus_xsettings.patch:
  - refreshed for the new version
* debian/patches/revert_new_ibus_use.patch:
  - revert keyboard code to our 3.4 version
* debian/patches/sync_keyboard_layout_to_accountsservice.patch:
  - dropped, the changes are included in the previous patch

[ Robert Ancell ]
* New upstream release
* debian/control:
  - Bump build-depends on libgnome-desktop-3-dev, libwacom-dev
  - Drop build-depends on libgnomekbd-dev, libxklavier-dev
  - Add build-depends on libxkbfile-dev

[ Rico Tzschichholz ]
* debian/control.in:
  - Build-depend on gtk-doc-tools

[ Iain Lane ]
* New upstream release
* Refresh patches and remove those applied upstream.
* Remove gstreamer BDs which are now obsolete. 

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From 644b7e358f992f35f370015c392ef4c9bcfb9ed8 Mon Sep 17 00:00:00 2001
2
 
From: Jiri Popelka <jpopelka@redhat.com>
3
 
Date: Wed, 11 Jul 2012 16:17:12 +0000
4
 
Subject: Use CUPS-1.6 IPP API getter/setter functions.
5
 
 
6
 
CUPS 1.6 makes various structures private and
7
 
introduces these ippGet and ippSet functions
8
 
for all of the fields in these structures.
9
 
http://www.cups.org/str.php?L3928
10
 
 
11
 
We define our own accessors when
12
 
building against CUPS < 1.6.
13
 
---
14
 
Index: gnome-settings-daemon-3.4.2/plugins/print-notifications/gsd-print-notifications-manager.c
15
 
===================================================================
16
 
--- gnome-settings-daemon-3.4.2.orig/plugins/print-notifications/gsd-print-notifications-manager.c      2012-08-08 15:36:25.000000000 +0200
17
 
+++ gnome-settings-daemon-3.4.2/plugins/print-notifications/gsd-print-notifications-manager.c   2012-08-08 15:38:48.820909196 +0200
18
 
@@ -52,6 +52,16 @@
19
 
 #define CONNECTING_TIMEOUT    60
20
 
 #define REASON_TIMEOUT        15000
21
 
 
22
 
+#if (CUPS_VERSION_MAJOR > 1) || (CUPS_VERSION_MINOR > 5)
23
 
+#define HAVE_CUPS_1_6 1
24
 
+#endif
25
 
+
26
 
+#ifndef HAVE_CUPS_1_6
27
 
+#define ippGetStatusCode(ipp) ipp->request.status.status_code
28
 
+#define ippGetInteger(attr, element) attr->values[element].integer
29
 
+#define ippGetString(attr, element, language) attr->values[element].string.text
30
 
+#endif
31
 
+
32
 
 struct GsdPrintNotificationsManagerPrivate
33
 
 {
34
 
         GDBusProxy                   *cups_proxy;
35
 
@@ -396,10 +406,10 @@
36
 
                         response = cupsDoRequest (http, request, "/");
37
 
 
38
 
                         if (response) {
39
 
-                                if (response->request.status.status_code <= IPP_OK_CONFLICT &&
40
 
+                                if (ippGetStatusCode (response) <= IPP_OK_CONFLICT &&
41
 
                                     (attr = ippFindAttribute(response, "job-originating-user-name",
42
 
                                                              IPP_TAG_NAME))) {
43
 
-                                        if (g_strcmp0 (attr->values[0].string.text, cupsUser ()) == 0)
44
 
+                                        if (g_strcmp0 (ippGetString (attr, 0, NULL), cupsUser ()) == 0)
45
 
                                                 my_job = TRUE;
46
 
                                 }
47
 
                                 ippDelete(response);
48
 
@@ -889,12 +899,12 @@
49
 
                                        "notify-lease-duration", SUBSCRIPTION_DURATION);
50
 
                         response = cupsDoRequest (http, request, "/");
51
 
 
52
 
-                        if (response != NULL && response->request.status.status_code <= IPP_OK_CONFLICT) {
53
 
+                        if (response != NULL && ippGetStatusCode (response) <= IPP_OK_CONFLICT) {
54
 
                                 if ((attr = ippFindAttribute (response, "notify-subscription-id",
55
 
                                                               IPP_TAG_INTEGER)) == NULL)
56
 
                                         g_debug ("No notify-subscription-id in response!\n");
57
 
                                 else
58
 
-                                        manager->priv->subscription_id = attr->values[0].integer;
59
 
+                                        manager->priv->subscription_id = ippGetInteger (attr, 0);
60
 
                         }
61
 
 
62
 
                         if (response)
63
 
Index: gnome-settings-daemon-3.4.2/plugins/print-notifications/gsd-printer.c
64
 
===================================================================
65
 
--- gnome-settings-daemon-3.4.2.orig/plugins/print-notifications/gsd-printer.c  2012-04-16 14:34:43.000000000 +0200
66
 
+++ gnome-settings-daemon-3.4.2/plugins/print-notifications/gsd-printer.c       2012-08-08 15:38:48.824909196 +0200
67
 
@@ -63,6 +63,14 @@
68
 
 #define GNOME_SESSION_PRESENCE_DBUS_PATH  "/org/gnome/SessionManager/Presence"
69
 
 #define GNOME_SESSION_PRESENCE_DBUS_IFACE "org.gnome.SessionManager.Presence"
70
 
 
71
 
+#if (CUPS_VERSION_MAJOR > 1) || (CUPS_VERSION_MINOR > 5)
72
 
+#define HAVE_CUPS_1_6 1
73
 
+#endif
74
 
+
75
 
+#ifndef HAVE_CUPS_1_6
76
 
+#define ippGetState(ipp) ipp->state
77
 
+#endif
78
 
+
79
 
 enum {
80
 
   PRESENCE_STATUS_AVAILABLE = 0,
81
 
   PRESENCE_STATUS_INVISIBLE,
82
 
@@ -725,7 +733,7 @@
83
 
                                                         "AutoConfigure",
84
 
                                                         ("Automatic configuration"));
85
 
                 if (response) {
86
 
-                        if (response->state == IPP_ERROR)
87
 
+                        if (ippGetState (response) == IPP_ERROR)
88
 
                                 g_warning ("An error has occured during automatic configuration of new printer.");
89
 
                         ippDelete (response);
90
 
                 }