~ubuntu-branches/ubuntu/utopic/gnome-settings-daemon/utopic

« back to all changes in this revision

Viewing changes to debian/patches/power-ignore-bad-dbus-requests.patch

  • Committer: Package Import Robot
  • Author(s): Sebastien Bacher, Sebastien Bacher, Robert Ancell, Rico Tzschichholz, Iain Lane
  • Date: 2012-11-21 17:16:23 UTC
  • mfrom: (1.1.62)
  • Revision ID: package-import@ubuntu.com-20121121171623-k7iufrs14qoiozeq
Tags: 3.6.3-0ubuntu1
[ Sebastien Bacher ]
* New upstream version (lp: #1008840)
* debian/patches/git*,
  debian/patches/power-ignore-bad-dbus-requests.patch,
  debian/patches/power-ignore-bad-dbus-requests.patch,
  debian/patches/10_smaller_syndaemon_timeout.patch: 
  - dropped, those fixes are in the new version
* debian/control.in:
  - restore build-depends on libgnomekbd-dev, libxklavier-dev,
    drop the build-depends on libxkbfile-dev
* debian/patches/20_migrate_background_uri.patch:
  - dropped, it was only needed until the LTS
* debian/patches/40_xres_lcddefault.patch:
  - dropped, that was a workaround for libreoffice that shouldn't be
    needed and we should better fix libreoffice
* debian/patches/61_unity_use_application_indicator.patch:
  - drop the keyboard indicator code, that will need to be turned 
    into a proper indicator refactored to handle the new ibus config
* debian/patches/90_set_gmenus_xsettings.patch:
  - refreshed for the new version
* debian/patches/revert_new_ibus_use.patch:
  - revert keyboard code to our 3.4 version
* debian/patches/sync_keyboard_layout_to_accountsservice.patch:
  - dropped, the changes are included in the previous patch

[ Robert Ancell ]
* New upstream release
* debian/control:
  - Bump build-depends on libgnome-desktop-3-dev, libwacom-dev
  - Drop build-depends on libgnomekbd-dev, libxklavier-dev
  - Add build-depends on libxkbfile-dev

[ Rico Tzschichholz ]
* debian/control.in:
  - Build-depend on gtk-doc-tools

[ Iain Lane ]
* New upstream release
* Refresh patches and remove those applied upstream.
* Remove gstreamer BDs which are now obsolete. 

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Index: gnome-settings-daemon-3.4.1/plugins/power/gsd-power-manager.c
2
 
===================================================================
3
 
--- gnome-settings-daemon-3.4.1.orig/plugins/power/gsd-power-manager.c  2012-04-25 16:53:47.385612908 -0400
4
 
+++ gnome-settings-daemon-3.4.1/plugins/power/gsd-power-manager.c       2012-04-25 17:04:19.765619601 -0400
5
 
@@ -4149,6 +4149,12 @@
6
 
 {
7
 
         GsdPowerManager *manager = GSD_POWER_MANAGER (user_data);
8
 
 
9
 
+        /* Check session pointer as a proxy for whether the manager is in the
10
 
+           start or stop state */
11
 
+        if (manager->priv->session == NULL) {
12
 
+                return;
13
 
+        }
14
 
+
15
 
         g_debug ("Calling method '%s.%s' for Power",
16
 
                  interface_name, method_name);
17
 
 
18
 
@@ -4183,6 +4189,12 @@
19
 
         GsdPowerManager *manager = GSD_POWER_MANAGER (user_data);
20
 
         GVariant *retval = NULL;
21
 
 
22
 
+        /* Check session pointer as a proxy for whether the manager is in the
23
 
+           start or stop state */
24
 
+        if (manager->priv->session == NULL) {
25
 
+                return NULL;
26
 
+        }
27
 
+
28
 
         if (g_strcmp0 (property_name, "Icon") == 0) {
29
 
                 retval = engine_get_icon_property_variant (manager);
30
 
         } else if (g_strcmp0 (property_name, "Tooltip") == 0) {