~ubuntu-branches/ubuntu/vivid/hamster-applet/vivid

« back to all changes in this revision

Viewing changes to debian/patches/01_startup-fix.patch

  • Committer: Bazaar Package Importer
  • Author(s): Andrew Starr-Bochicchio, Robert Ancell, Andrew Starr-Bochicchio
  • Date: 2009-12-22 17:52:52 UTC
  • mfrom: (1.1.13 upstream) (5.1.4 squeeze)
  • Revision ID: james.westby@ubuntu.com-20091222175252-2r447ri9x56hi4kl
Tags: 2.29.4-0ubuntu1
[ Robert Ancell ]
* debian/control.in:
  - Remove old debian VCS links

[ Andrew Starr-Bochicchio ]
* New upstream release. (LP: #488783)
 - Fixed problems with hamster interfering with 
   screensaver hibernation code. (LP: #448438)
 - Fixes to the dropdown in compiz (not spanning
   over virtual desktops anymore). (LP: #303572)

* Merge with Debian testing, remaining Ubuntu changes:
 - Adapt debian/watch to take unstable version.
 - Point Vcs field at lp:~ubuntu-desktop/hamster-applet/ubuntu

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Remove path checks, they prevent applet from starting
 
2
 
 
3
diff -Nur -x '*.orig' -x '*~' hamster-applet-2.28.0/hamster/configuration.py hamster-applet-2.28.0.new/hamster/configuration.py
 
4
--- hamster-applet-2.28.0/hamster/configuration.py      2009-09-01 11:32:49.000000000 +0200
 
5
+++ hamster-applet-2.28.0.new/hamster/configuration.py  2009-10-01 22:47:50.000000000 +0200
 
6
@@ -44,10 +44,8 @@
 
7
         gettext.install("hamster-applet", unicode = True)
 
8
 
 
9
         # Typically shared data dir is /usr/share/hamster-applet
 
10
-        if os.path.realpath(__file__).startswith(defs.PYTHONDIR):
 
11
-            data_dir = os.path.join(defs.DATA_DIR, "hamster-applet")
 
12
-        else:
 
13
-            data_dir = os.path.realpath(os.path.join(os.path.dirname(__file__), '..', 'data'))
 
14
+        data_dir = os.path.join(defs.DATA_DIR, "hamster-applet")
 
15
+
 
16
         self.data_dir = data_dir
 
17
         self.dispatcher = Dispatcher()
 
18
         self.storage = Storage(self.dispatcher)