~ubuntu-branches/ubuntu/wily/mate-settings-daemon/wily

« back to all changes in this revision

Viewing changes to debian/patches/0002_fix-a11y-keyboard-dialog-segfaults.patch

  • Committer: Package Import Robot
  • Author(s): John Paul Adrian Glaubitz, Martin Wimpress, John Paul Adrian Glaubitz
  • Date: 2015-08-16 16:35:32 UTC
  • mfrom: (10.1.4 experimental)
  • Revision ID: package-import@ubuntu.com-20150816163532-34zcev57w1c1bbv6
Tags: 1.10.1-1
[ Martin Wimpress ]
* debian/rules:
  + Remove obsolete build options.

[ John Paul Adrian Glaubitz ]
* Fix minor typo in debian/control (missing hyphen).
* Upload to unstable.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From 025d64d20cd513c81dc88d369491f1fa555f352e Mon Sep 17 00:00:00 2001
2
 
From: Monsta <monsta@inbox.ru>
3
 
Date: Fri, 2 Jan 2015 18:18:27 +0300
4
 
Subject: [PATCH] a11y-keyboard: fix crash
5
 
 
6
 
fixes https://github.com/mate-desktop/mate-settings-daemon/issues/70
7
 
---
8
 
 plugins/a11y-keyboard/msd-a11y-preferences-dialog.c | 18 +++++++++---------
9
 
 1 file changed, 9 insertions(+), 9 deletions(-)
10
 
 
11
 
diff --git a/plugins/a11y-keyboard/msd-a11y-preferences-dialog.c b/plugins/a11y-keyboard/msd-a11y-preferences-dialog.c
12
 
index 72d42ff..675b993 100644
13
 
--- a/plugins/a11y-keyboard/msd-a11y-preferences-dialog.c
14
 
+++ b/plugins/a11y-keyboard/msd-a11y-preferences-dialog.c
15
 
@@ -458,7 +458,7 @@ on_sticky_keys_checkbutton_toggled (GtkToggleButton          *button,
16
 
 
17
 
 static void
18
 
 on_bounce_keys_checkbutton_toggled (GtkToggleButton          *button,
19
 
-                                 MsdA11yPreferencesDialog *dialog)
20
 
+                                    MsdA11yPreferencesDialog *dialog)
21
 
 {
22
 
         config_set_bounce_keys (dialog, gtk_toggle_button_get_active (button));
23
 
 }
24
 
@@ -649,7 +649,7 @@ setup_dialog (MsdA11yPreferencesDialog *dialog,
25
 
         g_signal_connect (widget,
26
 
                           "toggled",
27
 
                           G_CALLBACK (on_sticky_keys_checkbutton_toggled),
28
 
-                          NULL);
29
 
+                          dialog);
30
 
         enabled = config_get_sticky_keys (dialog, &is_writable);
31
 
         ui_set_sticky_keys (dialog, enabled);
32
 
         if (! is_writable) {
33
 
@@ -662,7 +662,7 @@ setup_dialog (MsdA11yPreferencesDialog *dialog,
34
 
         g_signal_connect (widget,
35
 
                           "toggled",
36
 
                           G_CALLBACK (on_bounce_keys_checkbutton_toggled),
37
 
-                          NULL);
38
 
+                          dialog);
39
 
         enabled = config_get_bounce_keys (dialog, &is_writable);
40
 
         ui_set_bounce_keys (dialog, enabled);
41
 
         if (! is_writable) {
42
 
@@ -675,7 +675,7 @@ setup_dialog (MsdA11yPreferencesDialog *dialog,
43
 
         g_signal_connect (widget,
44
 
                           "toggled",
45
 
                           G_CALLBACK (on_slow_keys_checkbutton_toggled),
46
 
-                          NULL);
47
 
+                          dialog);
48
 
         enabled = config_get_slow_keys (dialog, &is_writable);
49
 
         ui_set_slow_keys (dialog, enabled);
50
 
         if (! is_writable) {
51
 
@@ -688,7 +688,7 @@ setup_dialog (MsdA11yPreferencesDialog *dialog,
52
 
         g_signal_connect (widget,
53
 
                           "toggled",
54
 
                           G_CALLBACK (on_high_contrast_checkbutton_toggled),
55
 
-                          NULL);
56
 
+                          dialog);
57
 
         enabled = config_get_high_contrast (dialog, &is_writable);
58
 
         ui_set_high_contrast (dialog, enabled);
59
 
         if (! is_writable) {
60
 
@@ -701,7 +701,7 @@ setup_dialog (MsdA11yPreferencesDialog *dialog,
61
 
         g_signal_connect (widget,
62
 
                           "toggled",
63
 
                           G_CALLBACK (on_at_screen_keyboard_checkbutton_toggled),
64
 
-                          NULL);
65
 
+                          dialog);
66
 
         enabled = config_get_at_screen_keyboard (dialog, &is_writable);
67
 
         ui_set_at_screen_keyboard (dialog, enabled);
68
 
         if (! is_writable) {
69
 
@@ -720,7 +720,7 @@ setup_dialog (MsdA11yPreferencesDialog *dialog,
70
 
         g_signal_connect (widget,
71
 
                           "toggled",
72
 
                           G_CALLBACK (on_at_screen_reader_checkbutton_toggled),
73
 
-                          NULL);
74
 
+                          dialog);
75
 
         enabled = config_get_at_screen_reader (dialog, &is_writable);
76
 
         ui_set_at_screen_reader (dialog, enabled);
77
 
         if (! is_writable) {
78
 
@@ -739,7 +739,7 @@ setup_dialog (MsdA11yPreferencesDialog *dialog,
79
 
         g_signal_connect (widget,
80
 
                           "toggled",
81
 
                           G_CALLBACK (on_at_screen_magnifier_checkbutton_toggled),
82
 
-                          NULL);
83
 
+                          dialog);
84
 
         enabled = config_get_at_screen_magnifier (dialog, &is_writable);
85
 
         ui_set_at_screen_magnifier (dialog, enabled);
86
 
         if (! is_writable) {
87
 
@@ -758,7 +758,7 @@ setup_dialog (MsdA11yPreferencesDialog *dialog,
88
 
         g_signal_connect (widget,
89
 
                           "toggled",
90
 
                           G_CALLBACK (on_large_print_checkbutton_toggled),
91
 
-                          NULL);
92
 
+                          dialog);
93
 
         enabled = config_get_large_print (&is_writable);
94
 
         ui_set_large_print (dialog, enabled);
95
 
         if (! is_writable) {
96