~ubuntu-branches/debian/lenny/mailman/lenny

« back to all changes in this revision

Viewing changes to debian/patches/12_savannah_wrapper.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Lionel Elie Mamane
  • Date: 2007-02-28 21:59:36 UTC
  • mfrom: (1.1.2 upstream)
  • Revision ID: james.westby@ubuntu.com-20070228215936-xoay8ru29qndpa9u
Tags: 1:2.1.9-7
Upgrade subject and author indexes of _all_ archiving volumes to
Unicode strings. (completely closes: #412142)

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh -e
2
 
## 12_savannah_wrapper.dpatch by Tollef Fog Heen <tfheen@debian.org>
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: Compile a wrapper for the savannah contrib plugin
6
 
 
7
 
[ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts
8
 
patch_opts="${patch_opts:--f --no-backup-if-mismatch ${2:+-d $2}}"
9
 
 
10
 
if [ $# -lt 1 ]; then
11
 
    echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
12
 
    exit 1
13
 
fi
14
 
case "$1" in
15
 
    -patch) patch $patch_opts -p1 < $0;;
16
 
    -unpatch) patch $patch_opts -p1 -R < $0;;
17
 
    *)
18
 
        echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
19
 
        exit 1;;
20
 
esac
21
 
 
22
 
exit 0
23
 
@DPATCH@
24
 
 
25
 
--- mailman-2.1.4.orig/src/Makefile.in
26
 
+++ mailman-2.1.4/src/Makefile.in
27
 
@@ -71,7 +71,7 @@
28
 
 # Fixed definitions
29
 
 
30
 
 CGI_PROGS= admindb admin confirm create edithtml listinfo options \
31
 
-       private rmlist roster subscribe
32
 
+       private rmlist roster subscribe savannah
33
 
 
34
 
 COMMONOBJS= common.o vsnprintf.o
35