~ubuntu-branches/ubuntu/oneiric/gnome-settings-daemon/oneiric

« back to all changes in this revision

Viewing changes to debian/patches/00git_disconnect_callbacks.patch

  • Committer: Package Import Robot
  • Author(s): Rodrigo Moya
  • Date: 2011-09-19 17:05:48 UTC
  • mfrom: (1.1.51 upstream)
  • Revision ID: package-import@ubuntu.com-20110919170548-gegm8ewt6qf7v7lp
Tags: 3.1.92-0ubuntu1
* New upstream release
* debian/control:
  - Bump libcolord-dev build dependency
* debian/patches/00git_guard_against_division_by_0.patch:
* debian/patches/00git_dont_crash_if_session_not_ready.patch:
* debian/patches/00git_numlock_status.patch:
* debian/patches/00git_disconnect_callbacks.patch:
  - Remove upstream patches
* debian/patches/06_use_application_indicator.patch:
* debian/patches/16_use_synchronous_notifications.patch:
  - Rebased

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From 28146a6b453eef450acfbdda7172246f9b8b0036 Mon Sep 17 00:00:00 2001
2
 
From: Rodrigo Moya <rodrigo@gnome-db.org>
3
 
Date: Tue, 13 Sep 2011 10:57:17 +0200
4
 
Subject: [PATCH] gconf: Disconnect callbacks when cleaning up
5
 
 
6
 
---
7
 
 plugins/gconf/conf-watcher.c |    8 +++++++-
8
 
 1 files changed, 7 insertions(+), 1 deletions(-)
9
 
 
10
 
diff --git a/plugins/gconf/conf-watcher.c b/plugins/gconf/conf-watcher.c
11
 
index 99a148d..e569818 100644
12
 
--- a/plugins/gconf/conf-watcher.c
13
 
+++ b/plugins/gconf/conf-watcher.c
14
 
@@ -23,13 +23,19 @@
15
 
 
16
 
 G_DEFINE_TYPE(ConfWatcher, conf_watcher, G_TYPE_OBJECT)
17
 
 
18
 
+static void settings_changed_cb (GSettings *settings,
19
 
+                                 const gchar *key,
20
 
+                                 ConfWatcher *watcher);
21
 
+
22
 
 static void
23
 
 conf_watcher_finalize (GObject *object)
24
 
 {
25
 
        ConfWatcher *watcher = CONF_WATCHER (object);
26
 
 
27
 
-       if (watcher->settings != NULL)
28
 
+       if (watcher->settings != NULL) {
29
 
+                g_signal_handlers_disconnect_by_func (watcher->settings, settings_changed_cb, watcher);
30
 
                g_object_unref (watcher->settings);
31
 
+        }
32
 
 
33
 
        if (watcher->conf_client != NULL)
34
 
                g_object_unref (watcher->conf_client);
35
 
1.7.5.4
36