~ubuntu-branches/ubuntu/oneiric/gnome-settings-daemon/oneiric

« back to all changes in this revision

Viewing changes to debian/patches/16_use_synchronous_notifications.patch

  • Committer: Package Import Robot
  • Author(s): Rodrigo Moya
  • Date: 2011-09-19 17:05:48 UTC
  • mfrom: (1.1.51 upstream)
  • Revision ID: package-import@ubuntu.com-20110919170548-gegm8ewt6qf7v7lp
Tags: 3.1.92-0ubuntu1
* New upstream release
* debian/control:
  - Bump libcolord-dev build dependency
* debian/patches/00git_guard_against_division_by_0.patch:
* debian/patches/00git_dont_crash_if_session_not_ready.patch:
* debian/patches/00git_numlock_status.patch:
* debian/patches/00git_disconnect_callbacks.patch:
  - Remove upstream patches
* debian/patches/06_use_application_indicator.patch:
* debian/patches/16_use_synchronous_notifications.patch:
  - Rebased

Show diffs side-by-side

added added

removed removed

Lines of Context:
195
195
 }
196
196
 
197
197
 static void
198
 
@@ -622,7 +759,9 @@ update_dialog (GsdMediaKeysManager *mana
199
 
                gboolean sound_changed,
200
 
                gboolean quiet)
201
 
 {
202
 
-        vol = (int) (100 * (double) vol / PA_VOLUME_NORM);
 
198
@@ -677,6 +796,8 @@ update_dialog (GsdMediaKeysManager *mana
 
199
         } else {
 
200
                 vol = 0.0;
 
201
         }
203
202
+        if (ubuntu_osd_notification_show_volume (manager, vol, muted))
204
203
+                goto done;
205
 
+
206
 
         vol = CLAMP (vol, 0, 100);
207
204
 
208
205
         dialog_init (manager);
 
206
         gsd_media_keys_window_set_volume_muted (GSD_MEDIA_KEYS_WINDOW (manager->priv->dialog),
209
207
@@ -633,12 +772,26 @@ update_dialog (GsdMediaKeysManager *mana
210
208
                                           GSD_MEDIA_KEYS_WINDOW_ACTION_VOLUME);
211
209
         dialog_show (manager);
408
406
 }
409
407
 
410
408
@@ -1484,23 +1702,23 @@ do_action (GsdMediaKeysManager *manager,
411
 
                 execute (manager, "gcalctool", FALSE, FALSE);
 
409
                 do_execute_desktop (manager, "gcalctool.desktop", timestamp);
412
410
                 break;
413
411
         case PLAY_KEY:
414
412
-                return do_multimedia_player_action (manager, "Play");