~ubuntu-branches/ubuntu/quantal/virtualbox/quantal

« back to all changes in this revision

Viewing changes to debian/patches/12-make-module.patch

  • Committer: Package Import Robot
  • Author(s): Felix Geyer
  • Date: 2012-04-05 12:41:55 UTC
  • mfrom: (3.1.12 sid)
  • Revision ID: package-import@ubuntu.com-20120405124155-i7b39tv5ddwhubbe
Tags: 4.1.12-dfsg-2
* Upstream has replaced the 4.1.12 tarball with a new one that fixes a
  crash when creating host only interfaces. (Closes: #667460)
  - Add 36-tarball-respin.patch which contains the diff between the old
    and the new tarball.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
1
Description: Fix ARCH setting in modules Makefiles.
2
2
Author: Michael Meskes <meskes@debian.org>
3
3
 
4
 
diff -urNad virtualbox-ose-3.0.8-dfsg~/src/VBox/Installer/linux/Makefile.include.header virtualbox-ose-3.0.8-dfsg/src/VBox/Installer/linux/Makefile.include.header
5
 
--- virtualbox-ose-3.0.8-dfsg~/src/VBox/Installer/linux/Makefile.include.header 2009-10-07 11:27:13.000000000 +0200
6
 
+++ virtualbox-ose-3.0.8-dfsg/src/VBox/Installer/linux/Makefile.include.header  2009-10-07 13:43:30.705472033 +0200
7
 
@@ -33,9 +33,21 @@
 
4
diff --git a/src/VBox/HostDrivers/Support/linux/Makefile b/src/VBox/HostDrivers/Support/linux/Makefile
 
5
--- a/src/VBox/HostDrivers/Support/linux/Makefile
 
6
+++ b/src/VBox/HostDrivers/Support/linux/Makefile
 
7
@@ -44,9 +44,21 @@ ifeq ($(BUILD_TARGET_ARCH),)
 
8
   BUILD_TARGET_ARCH := amd64
 
9
  else
 
10
   ifeq ($(ARCH),i386)
 
11
-   BUILD_TARGET_ARCH := x86
 
12
+   ifeq ($(CONFIG_X86_32),y)
 
13
+     BUILD_TARGET_ARCH := x86
 
14
+   else
 
15
+     BUILD_TARGET_ARCH := amd64
 
16
+   endif
 
17
   else
 
18
-   BUILD_TARGET_ARCH := $(BUILD_TARGET_ARCH_DEF)
 
19
+   ifeq ($(ARCH),x86)
 
20
+     ifeq ($(CONFIG_X86_32),y)
 
21
+       BUILD_TARGET_ARCH := x86
 
22
+     else
 
23
+       BUILD_TARGET_ARCH := amd64
 
24
+     endif
 
25
+   else
 
26
+     BUILD_TARGET_ARCH := $(BUILD_TARGET_ARCH_DEF)
 
27
+   endif
 
28
   endif
 
29
  endif
 
30
 else
 
31
diff --git a/src/VBox/HostDrivers/VBoxNetAdp/linux/Makefile b/src/VBox/HostDrivers/VBoxNetAdp/linux/Makefile
 
32
--- a/src/VBox/HostDrivers/VBoxNetAdp/linux/Makefile
 
33
+++ b/src/VBox/HostDrivers/VBoxNetAdp/linux/Makefile
 
34
@@ -35,9 +35,21 @@ ifeq ($(BUILD_TARGET_ARCH),)
 
35
   BUILD_TARGET_ARCH := amd64
 
36
  else
 
37
   ifeq ($(ARCH),i386)
 
38
-   BUILD_TARGET_ARCH := x86
 
39
+   ifeq ($(CONFIG_X86_32),y)
 
40
+     BUILD_TARGET_ARCH := x86
 
41
+   else
 
42
+     BUILD_TARGET_ARCH := amd64
 
43
+   endif
 
44
   else
 
45
-   BUILD_TARGET_ARCH := $(BUILD_TARGET_ARCH_DEF)
 
46
+   ifeq ($(ARCH),x86)
 
47
+     ifeq ($(CONFIG_X86_32),y)
 
48
+       BUILD_TARGET_ARCH := x86
 
49
+     else
 
50
+       BUILD_TARGET_ARCH := amd64
 
51
+     endif
 
52
+   else
 
53
+     BUILD_TARGET_ARCH := $(BUILD_TARGET_ARCH_DEF)
 
54
+   endif
 
55
   endif
 
56
  endif
 
57
 else
 
58
diff --git a/src/VBox/HostDrivers/VBoxNetFlt/linux/Makefile b/src/VBox/HostDrivers/VBoxNetFlt/linux/Makefile
 
59
--- a/src/VBox/HostDrivers/VBoxNetFlt/linux/Makefile
 
60
+++ b/src/VBox/HostDrivers/VBoxNetFlt/linux/Makefile
 
61
@@ -35,9 +35,21 @@ ifeq ($(BUILD_TARGET_ARCH),)
 
62
   BUILD_TARGET_ARCH := amd64
 
63
  else
 
64
   ifeq ($(ARCH),i386)
 
65
-   BUILD_TARGET_ARCH := x86
 
66
+   ifeq ($(CONFIG_X86_32),y)
 
67
+     BUILD_TARGET_ARCH := x86
 
68
+   else
 
69
+     BUILD_TARGET_ARCH := amd64
 
70
+   endif
 
71
   else
 
72
-   BUILD_TARGET_ARCH := $(BUILD_TARGET_ARCH_DEF)
 
73
+   ifeq ($(ARCH),x86)
 
74
+     ifeq ($(CONFIG_X86_32),y)
 
75
+       BUILD_TARGET_ARCH := x86
 
76
+     else
 
77
+       BUILD_TARGET_ARCH := amd64
 
78
+     endif
 
79
+   else
 
80
+     BUILD_TARGET_ARCH := $(BUILD_TARGET_ARCH_DEF)
 
81
+   endif
 
82
   endif
 
83
  endif
 
84
 else
 
85
diff --git a/src/VBox/HostDrivers/VBoxPci/linux/Makefile b/src/VBox/HostDrivers/VBoxPci/linux/Makefile
 
86
--- a/src/VBox/HostDrivers/VBoxPci/linux/Makefile
 
87
+++ b/src/VBox/HostDrivers/VBoxPci/linux/Makefile
 
88
@@ -35,9 +35,21 @@ ifeq ($(BUILD_TARGET_ARCH),)
 
89
   BUILD_TARGET_ARCH := amd64
 
90
  else
 
91
   ifeq ($(ARCH),i386)
 
92
-   BUILD_TARGET_ARCH := x86
 
93
+   ifeq ($(CONFIG_X86_32),y)
 
94
+     BUILD_TARGET_ARCH := x86
 
95
+   else
 
96
+     BUILD_TARGET_ARCH := amd64
 
97
+   endif
 
98
   else
 
99
-   BUILD_TARGET_ARCH := $(BUILD_TARGET_ARCH_DEF)
 
100
+   ifeq ($(ARCH),x86)
 
101
+     ifeq ($(CONFIG_X86_32),y)
 
102
+       BUILD_TARGET_ARCH := x86
 
103
+     else
 
104
+       BUILD_TARGET_ARCH := amd64
 
105
+     endif
 
106
+   else
 
107
+     BUILD_TARGET_ARCH := $(BUILD_TARGET_ARCH_DEF)
 
108
+   endif
 
109
   endif
 
110
  endif
 
111
 else
 
112
diff --git a/src/VBox/Installer/linux/Makefile.include.header b/src/VBox/Installer/linux/Makefile.include.header
 
113
--- a/src/VBox/Installer/linux/Makefile.include.header
 
114
+++ b/src/VBox/Installer/linux/Makefile.include.header
 
115
@@ -54,9 +54,21 @@ ifeq ($(BUILD_TARGET_ARCH),)
8
116
   BUILD_TARGET_ARCH := amd64
9
117
  else
10
118
   ifeq ($(ARCH),i386)
28
136
   endif
29
137
  endif
30
138
 else
31
 
diff -urNad virtualbox-ose-3.0.8-dfsg~/src/VBox/HostDrivers/Support/linux/Makefile virtualbox-ose-3.0.8-dfsg/src/VBox/HostDrivers/Support/linux/Makefile
32
 
--- virtualbox-ose-3.0.8-dfsg~/src/VBox/HostDrivers/Support/linux/Makefile      2009-10-07 11:27:14.000000000 +0200
33
 
+++ virtualbox-ose-3.0.8-dfsg/src/VBox/HostDrivers/Support/linux/Makefile       2009-10-07 13:43:30.705472033 +0200
34
 
@@ -44,9 +44,21 @@
35
 
   BUILD_TARGET_ARCH := amd64
36
 
  else
37
 
   ifeq ($(ARCH),i386)
38
 
-   BUILD_TARGET_ARCH := x86
39
 
+   ifeq ($(CONFIG_X86_32),y)
40
 
+     BUILD_TARGET_ARCH := x86
41
 
+   else
42
 
+     BUILD_TARGET_ARCH := amd64
43
 
+   endif
44
 
   else
45
 
-   BUILD_TARGET_ARCH := $(BUILD_TARGET_ARCH_DEF)
46
 
+   ifeq ($(ARCH),x86)
47
 
+     ifeq ($(CONFIG_X86_32),y)
48
 
+       BUILD_TARGET_ARCH := x86
49
 
+     else
50
 
+       BUILD_TARGET_ARCH := amd64
51
 
+     endif
52
 
+   else
53
 
+     BUILD_TARGET_ARCH := $(BUILD_TARGET_ARCH_DEF)
54
 
+   endif
55
 
   endif
56
 
  endif
57
 
 else
58
 
diff -urNad virtualbox-ose-3.0.8-dfsg~/src/VBox/HostDrivers/VBoxNetAdp/linux/Makefile virtualbox-ose-3.0.8-dfsg/src/VBox/HostDrivers/VBoxNetAdp/linux/Makefile
59
 
--- virtualbox-ose-3.0.8-dfsg~/src/VBox/HostDrivers/VBoxNetAdp/linux/Makefile   2009-10-07 11:27:14.000000000 +0200
60
 
+++ virtualbox-ose-3.0.8-dfsg/src/VBox/HostDrivers/VBoxNetAdp/linux/Makefile    2009-10-07 13:43:30.705472033 +0200
61
 
@@ -35,9 +35,21 @@
62
 
   BUILD_TARGET_ARCH := amd64
63
 
  else
64
 
   ifeq ($(ARCH),i386)
65
 
-   BUILD_TARGET_ARCH := x86
66
 
+   ifeq ($(CONFIG_X86_32),y)
67
 
+     BUILD_TARGET_ARCH := x86
68
 
+   else
69
 
+     BUILD_TARGET_ARCH := amd64
70
 
+   endif
71
 
   else
72
 
-   BUILD_TARGET_ARCH := $(BUILD_TARGET_ARCH_DEF)
73
 
+   ifeq ($(ARCH),x86)
74
 
+     ifeq ($(CONFIG_X86_32),y)
75
 
+       BUILD_TARGET_ARCH := x86
76
 
+     else
77
 
+       BUILD_TARGET_ARCH := amd64
78
 
+     endif
79
 
+   else
80
 
+     BUILD_TARGET_ARCH := $(BUILD_TARGET_ARCH_DEF)
81
 
+   endif
82
 
   endif
83
 
  endif
84
 
 else
85
 
diff -urNad virtualbox-ose-3.0.8-dfsg~/src/VBox/HostDrivers/VBoxNetFlt/linux/Makefile virtualbox-ose-3.0.8-dfsg/src/VBox/HostDrivers/VBoxNetFlt/linux/Makefile
86
 
--- virtualbox-ose-3.0.8-dfsg~/src/VBox/HostDrivers/VBoxNetFlt/linux/Makefile   2009-10-07 11:27:14.000000000 +0200
87
 
+++ virtualbox-ose-3.0.8-dfsg/src/VBox/HostDrivers/VBoxNetFlt/linux/Makefile    2009-10-07 13:43:30.705472033 +0200
88
 
@@ -35,9 +35,21 @@
89
 
   BUILD_TARGET_ARCH := amd64
90
 
  else
91
 
   ifeq ($(ARCH),i386)
92
 
-   BUILD_TARGET_ARCH := x86
93
 
+   ifeq ($(CONFIG_X86_32),y)
94
 
+     BUILD_TARGET_ARCH := x86
95
 
+   else
96
 
+     BUILD_TARGET_ARCH := amd64
97
 
+   endif
98
 
   else
99
 
-   BUILD_TARGET_ARCH := $(BUILD_TARGET_ARCH_DEF)
100
 
+   ifeq ($(ARCH),x86)
101
 
+     ifeq ($(CONFIG_X86_32),y)
102
 
+       BUILD_TARGET_ARCH := x86
103
 
+     else
104
 
+       BUILD_TARGET_ARCH := amd64
105
 
+     endif
106
 
+   else
107
 
+     BUILD_TARGET_ARCH := $(BUILD_TARGET_ARCH_DEF)
108
 
+   endif
109
 
   endif
110
 
  endif
111
 
 else