~ubuntu-branches/ubuntu/saucy/qemu/saucy-proposed

« back to all changes in this revision

Viewing changes to debian/patches/linaro-patches-1.5.0/0053-hw-nseries.c-Drop-QEMU_VERSION-from-atags.patch

  • Committer: Package Import Robot
  • Author(s): Serge Hallyn
  • Date: 2013-05-28 08:18:30 UTC
  • mfrom: (1.8.2) (10.1.37 sid)
  • Revision ID: package-import@ubuntu.com-20130528081830-87xl2z9fq516a814
Tags: 1.5.0+dfsg-2ubuntu1
* Merge 1.5.0+dfs-2 from debian unstable.  Remaining changes:
  - debian/control
    * update maintainer
    * remove libiscsi, usb-redir, vde, vnc-jpeg, and libssh2-1-dev
      from build-deps
    * enable rbd
    * add qemu-system and qemu-common B/R to qemu-keymaps
    * add D:udev, R:qemu, R:qemu-common and B:qemu-common to
      qemu-system-common
    * qemu-system-arm, qemu-system-ppc, qemu-system-sparc:
      - add qemu-kvm to Provides
      - add qemu-common, qemu-kvm, kvm to B/R
      - remove openbios-sparc from qemu-system-sparc D
    * qemu-system-x86:
      - add qemu-common to Breaks/Replaces.
      - add cpu-checker to Recommends.
    * qemu-user: add B/R:qemu-kvm
    * qemu-kvm:
      - add armhf armel powerpc sparc to Architecture
      - C/R/P: qemu-kvm-spice
    * add qemu-common package
    * drop qemu-slof which is not packaged in ubuntu
  - add qemu-system-common.links for tap ifup/down scripts and OVMF link.
  - qemu-system-x86.links:
    * remove pxe rom links which are in kvm-ipxe
    * add symlink for kvm.1 manpage
  - debian/rules
    * add kvm-spice symlink to qemu-kvm
    * call dh_installmodules for qemu-system-x86
    * update dh_installinit to install upstart script
    * run dh_installman (Closes: #709241) (cherrypicked from 1.5.0+dfsg-2)
  - Add qemu-utils.links for kvm-* symlinks.
  - Add qemu-system-x86.qemu-kvm.upstart and .default
  - Add qemu-system-x86.modprobe to set nesting=1
  - Add qemu-system-common.preinst to add kvm group
  - qemu-system-common.postinst: remove bad group acl if there, then have
    udev relabel /dev/kvm.
  - Dropped patches:
    * 0001-fix-wrong-output-with-info-chardev-for-tcp-socket.patch
  - Kept patches:
    * expose_vms_qemu64cpu.patch - updated
    * gridcentric patch - updated
    * linaro arm patches from qemu-linaro rebasing branch

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From 80d37cd70440d6460b226fce8ee5b514d44da2f4 Mon Sep 17 00:00:00 2001
 
2
From: Peter Maydell <peter.maydell@linaro.org>
 
3
Date: Mon, 18 Feb 2013 16:58:32 +0000
 
4
Subject: [PATCH 53/69] hw/nseries.c: Drop QEMU_VERSION from atags
 
5
 
 
6
(Why?)
 
7
---
 
8
 hw/arm/nseries.c | 3 +--
 
9
 1 file changed, 1 insertion(+), 2 deletions(-)
 
10
 
 
11
diff --git a/hw/arm/nseries.c b/hw/arm/nseries.c
 
12
index d47bdb0..88fab81 100644
 
13
--- a/hw/arm/nseries.c
 
14
+++ b/hw/arm/nseries.c
 
15
@@ -1403,8 +1403,7 @@ static int n8x0_atag_setup(void *p, int model)
 
16
     stw_raw(w ++, 24);                         /* u16 len */
 
17
     strcpy((void *) w, "hw-build");            /* char component[12] */
 
18
     w += 6;
 
19
-    strcpy((void *) w, "QEMU ");
 
20
-    pstrcat((void *) w, 12, qemu_get_version()); /* char version[12] */
 
21
+    strcpy((void *) w, "QEMU");                /* char version[12] */
 
22
     w += 6;
 
23
 
 
24
     tag = (model == 810) ? "1.1.10-qemu" : "1.1.6-qemu";
 
25
-- 
 
26
1.8.1.2
 
27