~ubuntu-branches/ubuntu/saucy/qemu/saucy-proposed

« back to all changes in this revision

Viewing changes to debian/patches/patches-arm-1.4.0/0011-omap_gptimer-Add-omap_gp_timer_change_clk.patch

  • Committer: Package Import Robot
  • Author(s): Serge Hallyn
  • Date: 2013-05-28 08:18:30 UTC
  • mfrom: (1.8.2) (10.1.37 sid)
  • Revision ID: package-import@ubuntu.com-20130528081830-87xl2z9fq516a814
Tags: 1.5.0+dfsg-2ubuntu1
* Merge 1.5.0+dfs-2 from debian unstable.  Remaining changes:
  - debian/control
    * update maintainer
    * remove libiscsi, usb-redir, vde, vnc-jpeg, and libssh2-1-dev
      from build-deps
    * enable rbd
    * add qemu-system and qemu-common B/R to qemu-keymaps
    * add D:udev, R:qemu, R:qemu-common and B:qemu-common to
      qemu-system-common
    * qemu-system-arm, qemu-system-ppc, qemu-system-sparc:
      - add qemu-kvm to Provides
      - add qemu-common, qemu-kvm, kvm to B/R
      - remove openbios-sparc from qemu-system-sparc D
    * qemu-system-x86:
      - add qemu-common to Breaks/Replaces.
      - add cpu-checker to Recommends.
    * qemu-user: add B/R:qemu-kvm
    * qemu-kvm:
      - add armhf armel powerpc sparc to Architecture
      - C/R/P: qemu-kvm-spice
    * add qemu-common package
    * drop qemu-slof which is not packaged in ubuntu
  - add qemu-system-common.links for tap ifup/down scripts and OVMF link.
  - qemu-system-x86.links:
    * remove pxe rom links which are in kvm-ipxe
    * add symlink for kvm.1 manpage
  - debian/rules
    * add kvm-spice symlink to qemu-kvm
    * call dh_installmodules for qemu-system-x86
    * update dh_installinit to install upstart script
    * run dh_installman (Closes: #709241) (cherrypicked from 1.5.0+dfsg-2)
  - Add qemu-utils.links for kvm-* symlinks.
  - Add qemu-system-x86.qemu-kvm.upstart and .default
  - Add qemu-system-x86.modprobe to set nesting=1
  - Add qemu-system-common.preinst to add kvm group
  - qemu-system-common.postinst: remove bad group acl if there, then have
    udev relabel /dev/kvm.
  - Dropped patches:
    * 0001-fix-wrong-output-with-info-chardev-for-tcp-socket.patch
  - Kept patches:
    * expose_vms_qemu64cpu.patch - updated
    * gridcentric patch - updated
    * linaro arm patches from qemu-linaro rebasing branch

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From 035fa7975e7b02bfae963e90a5c149f1f3cd2e0d Mon Sep 17 00:00:00 2001
2
 
From: Peter Maydell <peter.maydell@linaro.org>
3
 
Date: Mon, 18 Feb 2013 16:58:24 +0000
4
 
Subject: [PATCH 11/77] omap_gptimer: Add omap_gp_timer_change_clk()
5
 
 
6
 
Add omap_gp_timer_change_clk() functions to inform the gptimer code when
7
 
the clock source for a timer has been changed.
8
 
 
9
 
TODO: is this the best way to do this??
10
 
---
11
 
 hw/omap.h         | 1 +
12
 
 hw/omap_gptimer.c | 6 ++++++
13
 
 2 files changed, 7 insertions(+)
14
 
 
15
 
diff --git a/hw/omap.h b/hw/omap.h
16
 
index 086692f..5e9d41d 100644
17
 
--- a/hw/omap.h
18
 
+++ b/hw/omap.h
19
 
@@ -844,6 +844,7 @@ struct omap_gp_timer_s;
20
 
 struct omap_gp_timer_s *omap_gp_timer_init(struct omap_target_agent_s *ta,
21
 
                 qemu_irq irq, omap_clk fclk, omap_clk iclk);
22
 
 void omap_gp_timer_reset(struct omap_gp_timer_s *s);
23
 
+void omap_gp_timer_change_clk(struct omap_gp_timer_s *timer);
24
 
 
25
 
 /* OMAP2 sysctimer */
26
 
 struct omap_synctimer_s;
27
 
diff --git a/hw/omap_gptimer.c b/hw/omap_gptimer.c
28
 
index e500884..b019295 100644
29
 
--- a/hw/omap_gptimer.c
30
 
+++ b/hw/omap_gptimer.c
31
 
@@ -75,6 +75,12 @@ struct omap_gp_timer_s {
32
 
 #define GPT_OVF_IT     (1 << 1)
33
 
 #define GPT_MAT_IT     (1 << 0)
34
 
 
35
 
+/*if the clock source of gptimer changes, rate must be regenerated*/
36
 
+void omap_gp_timer_change_clk(struct omap_gp_timer_s *timer)
37
 
+{
38
 
+    timer->rate = omap_clk_getrate(timer->clk);
39
 
+}
40
 
+
41
 
 static inline void omap_gp_timer_intr(struct omap_gp_timer_s *timer, int it)
42
 
 {
43
 
     if (timer->it_ena & it) {
44
 
1.8.1.2
45