~ubuntu-branches/ubuntu/trusty/isdnutils/trusty

« back to all changes in this revision

Viewing changes to debian/patches/isdnbill-manpage.dpatch

  • Committer: Package Import Robot
  • Author(s): Steve Langasek
  • Date: 2013-11-15 00:02:58 UTC
  • mfrom: (1.1.8) (31.1.1 trusty-proposed)
  • Revision ID: package-import@ubuntu.com-20131115000258-tt9v3gasgrdml07k
Tags: 1:3.25+dfsg1-3.3ubuntu1
* Merge from Debian unstable:
  - resolves licensing issues with package contents.  LP: #511988.
  - includes proper upstream fix for ipppd on ARM.  LP: #453159.
  - resolves isdnutils-base removal failures.  LP: #813771.
  - fixes capiutils init script to not try to mount obsolete capifs.
    LP: #1064347.
* Remaining changes:
  - Switch libreadline5-dev to libreadline-gplv2-dev since this package
    appears to be GPLv2
  - debian/patches/no-imake.patch: Don't build xisdnload/xmonisdn using
    xmkmf/imake.  This patch was dropped in Debian without explanation;
    it still applies and seems to still be a good idea for eventual
    upstreaming, since imake is quite obsolete.
  - capi.conf: Fix typo for fcdsl2 firmware. LP: #189132.
  - Remove dependencies on /etc/inittab.
    - Disable the installation code to modify /etc/inittab.
    - isdnutils-base: Add ttyI0 example script, which needs to be installed
      in /etc/event.d/ttyI0.
    - isdnvboxserver: Add ttyI1 example script, which needs to be installed
      in /etc/event.d/ttyI1.
    - The two upstart scripts need to be edited.
    - Further improvements and documentation welcome.
* Changes included in Debian:
  - replace calls to ./MAKEDEV with /sbin/MAKEDEV
  - Build-depend on ppp-dev.
  - Switch to newer tcl -dev.
  - update to newer automake
  - debian/rules: use autoreconf to update the autotools in the capi20
    directory
  - debian/{compat,rules,*.files,.dirs}: Convert to Multi-arch.
  - debian/libcapi20-dev.install: Remove .la files (no builds use them).
* Changes included upstream:
  - fix for ARM FTBFS.
  - fix bashisms in vboxplay.
  - debian/patches/{config_libdir,toplevel-make}.patch: add CONFIG_LIBDIR
    override to upstream build system to support Multi-arch.
* Dropped changes:
  - kick dpatch to the curb.
* Handle migrating the blacklist file from
  /etc/modprobe.d/blacklist-capiutils.conf to the path used in Debian,
  /etc/modprobe.d/capiutils.conf.
* Handle rename of /etc/ppp/ip-down.d/99-ipppd and /etc/ppp/ip-up.d/00-ipppd
  to /etc/ppp/ip-down.d/ipppd and /etc/ppp/ip-up.d/ipppd
* Handle rename of /etc/init.d/isdnutils to /etc/init.d/isdnutils-base
* Restore standard.tcl to /usr/share/isdnvboxserver/default; maintainer
  scripts must not depend on contents of /usr/share/doc.
* Apply patches that were preserved in the 3.0 (quilt) migration, but
  were inadvertently not applied:
  - debian/patches/capifax.additional_error_codes.patch
  - debian/patches/capifax.3_1kHz_audio.patch
* Drop debian/isdnutils-base.cron.d, which isn't a cronjob example at all
  but an inittab example gone astray.
* debian/dotconfig*: don't use embedded quotes for paths; this confuses
  vbox's Makefiles something fierce, and causes files to be missed from
  debian/tmp'/usr/share/man/' at install time.
* Fix isdnlog and ipppd to not ship files used in the postinst under
  /usr/share/doc.
* Modernize the upstart examples.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh -e
2
 
 
3
 
# DP: add manpage for isdnbill(1)
4
 
 
5
 
dir=
6
 
if [ $# -eq 3 -a "$2" = '-d' ]; then
7
 
    pdir="-d $3"
8
 
    dir="$3/"
9
 
elif [ $# -ne 1 ]; then
10
 
    echo >&2 "usage: `basename $0`: -patch|-unpatch [-d <srcdir>]"
11
 
    exit 1
12
 
fi
13
 
case "$1" in
14
 
    -patch)
15
 
        patch $pdir -f --no-backup-if-mismatch -p1 < $0
16
 
        ;;
17
 
    -unpatch)
18
 
        patch $pdir -f --no-backup-if-mismatch -R -p1 < $0
19
 
        ;;
20
 
    *)
21
 
        echo >&2 "usage: `basename $0`: -patch|-unpatch [-d <srcdir>]"
22
 
        exit 1
23
 
esac
24
 
exit 0
25
 
 
26
 
--- isdnutils-3.3.orig/isdnlog/isdnrep/isdnbill.man
27
 
+++ isdnutils-3.3/isdnlog/isdnrep/isdnbill.man
28
 
@@ -0,0 +1,90 @@
29
 
+.\" $Id: $
30
 
+.\" CHECKIN $Date: $
31
 
+.\" .TH isdnbill 1 "@MANDATE_ISDNBILL@" "ISDN 4 Linux @I4LVERSION@" "Linux System Commands"
32
 
+.TH isdnbill 1 "2003-10-14" "ISDN 4 Linux @I4LVERSION@" "Linux System Commands"
33
 
+
34
 
+.PD 0
35
 
+.SH NAME
36
 
+isdnbill \- report isdn costs
37
 
+
38
 
+.SH DESCRIPTION
39
 
+isdnbill is a simple and imperfect utility to show the bill for ISDN calls.
40
 
+Note that it is only for indicative purposes! It works best in Germany,
41
 
+and even then there are no guarantees.
42
 
+Consider its use for educational purposes only...
43
 
+
44
 
+For better results, use isdnrep.
45
 
+
46
 
+.SH OPTIONS
47
 
+.TP
48
 
+.B \-V
49
 
+show version
50
 
+
51
 
+.TP
52
 
+.B \-a
53
 
+show all connections
54
 
+
55
 
+.TP
56
 
+.B \-e
57
 
+show incomplete calls
58
 
+
59
 
+.TP
60
 
+.B \-f
61
 
+recalculate costs _always_
62
 
+
63
 
+.TP
64
 
+.B \-i
65
 
+show incoming calls
66
 
+
67
 
+.TP
68
 
+.B \-m
69
 
+prices without VAT
70
 
+
71
 
+.TP
72
 
+.B \-n
73
 
+do _not_ replace numbers with aliases
74
 
+
75
 
+.TP
76
 
+.B \-o
77
 
+show outgoing calls
78
 
+
79
 
+.TP
80
 
+.B \-t
81
 
+show only current connections
82
 
+
83
 
+.TP
84
 
+.B \-vn
85
 
+verbose level n
86
 
+
87
 
+.TP
88
 
+.B \-Nnnn
89
 
+show only calls with the specified number
90
 
+
91
 
+.TP
92
 
+.B \-I
93
 
+show only calls on the internal S0 bus
94
 
+
95
 
+.TP
96
 
+.B \-E
97
 
+show only calls on the external S0 bus
98
 
+
99
 
+
100
 
+.SH "FILES"
101
 
+.TP
102
 
+\fB@LOGFILE@\fR or \fB/var/lib/isdn/calls\fR
103
 
+isdnlog log file with information about all calls.
104
 
+
105
 
+.TP
106
 
+\fB@I4LCONFDIR@/@CONFFILE@\fR
107
 
+general configuration
108
 
+
109
 
+.TP
110
 
+\fB@I4LCONFDIR@/@CALLERIDFILE@\fR
111
 
+aliases for telephone numbers
112
 
+
113
 
+.SH SEE ALSO
114
 
+.B isdnlog(5) isdnlog(8) isdnrep(1)
115
 
+
116
 
+.SH AUTHOR
117
 
+This manual page was written by
118
 
+Paul Slootman <paul@debian.org>, for Debian GNU/Linux.