~ubuntu-branches/ubuntu/trusty/xiphos/trusty

« back to all changes in this revision

Viewing changes to debian/patches/xul-2.0.patch

  • Committer: Bazaar Package Importer
  • Author(s): Dmitrijs Ledkovs, Jonathan Marsden, Dmitrijs Ledkovs
  • Date: 2010-11-25 21:26:48 UTC
  • mfrom: (2.1.1 experimental)
  • Revision ID: james.westby@ubuntu.com-20101125212648-mc64wvs0nw3xp7bx
Tags: 3.1.4-1
[ Jonathan Marsden ]
* New upstream release 3.1.4
* Removed debian/patch/* since the one patch was included upstream.
* Bumped Standards-Version to 3.9.1 (no changes required).
* debian/README.Debian: Corrected spelling and reworded for clarity.
* debian/control: Add Jonathan Marsden back into Uploaders.

[ Dmitrijs Ledkovs ]
* Added local options dpkg-source to unapply patches and fail on
  upstream source changes (ignoring false positives).
* Added bzr-builddeb hook to generate source-format before build. If you
  are not using bzr-builddeb, you must run "./debian/rules clean" before
  building.
* patches/xul-2.0.patch: bump UPPER_RANGE to allow running against xul20.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
=== modified file 'src/gecko/gecko-utils.cpp'
 
2
--- a/src/gecko/gecko-utils.cpp 2010-03-29 16:50:00 +0000
 
3
+++ b/src/gecko/gecko-utils.cpp 2010-11-26 12:29:42 +0000
 
4
@@ -233,11 +233,9 @@
 
5
        //I have really no clue what this ranges mean but if xulrunner is
 
6
        //outside of this range we get coredumps =( so here is a bold assumption
 
7
        //that we will be able to work with any future xulrunner.
 
8
-#define UPPER_RANGE "1.9.99"
 
9
-#define LOWER_RANGE "1.9.0"
 
10
        static const GREVersionRange greVersion = {
 
11
-               LOWER_RANGE, PR_TRUE,
 
12
-               UPPER_RANGE, PR_TRUE
 
13
+               GECKO_MIN, PR_TRUE,
 
14
+               GECKO_MAX, PR_TRUE
 
15
        };
 
16
        char xpcomLocation[PATH_MAX];
 
17
        rv = GRE_GetGREPathWithProperties(&greVersion, 1, nsnull, 0, xpcomLocation, sizeof (xpcomLocation));
 
18
 
 
19
=== modified file 'wscript'
 
20
--- a/wscript   2010-11-08 13:20:13 +0000
 
21
+++ b/wscript   2010-11-27 11:10:13 +0000
 
22
@@ -311,7 +311,7 @@
 
23
 
 
24
 
 
25
     if conf.check_cfg(modversion='gtkhtml-editor-3.14',
 
26
-                      msg='Is post GNOME3 gtkhtml-editor available?',
 
27
+                      msg='Checking for GNOME3 gtkhtml-editor',
 
28
                       okmsg='Deffinatly',
 
29
                       errmsg='Probably, not'
 
30
                       ):
 
31
@@ -377,6 +377,20 @@
 
32
                                                      args='--variable=sdkdir',
 
33
                                                      okmsg=waffles.misc.myokmsg,
 
34
                                                      msg="Checking for libxul sdkdir").strip())
 
35
+            conf.define('GECKO_VER', conf.check_cfg(package='libxul-embedding',
 
36
+                                                    args='--modversion',
 
37
+                                                     okmsg=waffles.misc.myokmsg,
 
38
+                                                    msg="Checking for Gecko GREVersion").strip())
 
39
+            if not env['GECKO_VER'][3].isalpha():
 
40
+                    conf.define('GECKO_MIN', env['GECKO_VER'][0:5]+'.0')
 
41
+                    conf.define('GECKO_MAX', env['GECKO_VER'][0:5]+'.99')
 
42
+            else:
 
43
+                    conf.define('GECKO_MIN', env['GECKO_VER'][0:4]+'0')
 
44
+                    conf.define('GECKO_MAX', env['GECKO_VER'][0:3]+'.0.99')
 
45
+
 
46
+            conf.check_message("Gecko", "GREVersionMin", 1, env['GECKO_MIN'])
 
47
+            conf.check_message("Gecko", "GREVersionMax", 1, env['GECKO_MAX'])
 
48
+
 
49
         else:
 
50
                     d = env['MOZILLA_DISTDIR']
 
51
                     conf.define['CPPPATH_GECKO'] = ['%s/sdk/include' % d,
 
52
@@ -389,6 +403,10 @@
 
53
                                                 '%s/include/gfx' % d]
 
54
                     conf.define['LIBPATH_GECKO'] = ['%s/sdk/lib' % d]
 
55
                     conf.define['LIB_GECKO'] = ['xpcomglue_s', 'xpcom', 'xul', 'nspr4']
 
56
+                    # FIXME: how to detect Gecko-ver on Win similar to pkg-config on unix?
 
57
+                    conf.define('GECKO_MIN', '1.9.0.0')
 
58
+                    conf.define('GECKO_MAX', '2.0.0.*')
 
59
+
 
60
 
 
61
         env.append_value('ALL_LIBS', 'NSPR')
 
62
         env.append_value('ALL_LIBS', 'GECKO')
 
63