~ubuntu-branches/ubuntu/utopic/eglibc/utopic

« back to all changes in this revision

Viewing changes to debian/patches/any/local-rtld.diff

  • Committer: Package Import Robot
  • Author(s): Adam Conrad
  • Date: 2012-10-26 05:14:58 UTC
  • mfrom: (1.5.1) (4.4.22 experimental)
  • Revision ID: package-import@ubuntu.com-20121026051458-oryotr4i03ob5pab
Tags: 2.16-0ubuntu1
* Merge with unreleased 2.16 in Debian experimental, remaining changes:
  - Drop the Breaks line from libc6, which refers to a Debian transition
  - Remove the libc6 recommends on libc6-i686, which we don't build
  - Enable libc6{,-dev}-armel on armhf and libc6{-dev}-armhf on armel
  - Ship update-locale and validlocale in /usr/sbin in libc-bin
  - Don't build locales or locales-all in Ubuntu, we rely on langpacks
  - Heavily mangle the way we do service restarting on major upgrades
  - Use different MIN_KERNEL_SUPPORTED versions than Debian, due to
    buildd needs.  This should be universally bumped to 3.2.0 once all
    our buildds (including the PPA guests) are running precise kernels
  - Build i386 variants as -march=i686, build amd64 with -O3, and build
    ppc64 variants (both 64-bit and 32-bit) with -O3 -fno-tree-vectorize
  - Re-enable unsubmitted-ldconfig-cache-abi.diff and rebuild the cache
    on upgrades from previous versions that used a different constant
  - debian/patches/any/local-CVE-2012-3406.diff: switch to malloc when
    array grows too large to handle via alloca extension (CVE-2012-3406)
  - Build generic i386/i686 flavour with -mno-tls-direct-seg-refs
* Changes added/dropped with this merge while reducing our delta:
  - Stop building glibc docs from the eglibc source, and instead make
    the glibc-docs stub have a hard dependency on glibc-doc-reference
  - Remove outdated conflicts against ancient versions of ia32-libs
  - Drop the tzdata dependency from libc6, it's in required and minimal
  - Use gcc-4.7/g++-4.7 by default on all our supported architectures
  - Save our historical changelog as changelog.ubuntu in the source
  - Drop nscd's libaudit build-dep for now, as libaudit is in universe
  - Drop the unnecessary Breaks from libc6 to locales and locales-all
  - Ship xen's ld.so.conf.d snippet as /etc/ld.so.conf.d/libc6-xen.conf
* Disable hard failures on the test suite for the first upload to raring

Show diffs side-by-side

added added

removed removed

Lines of Context:
12
12
 
13
13
---
14
14
 Makeconfig   |    7 ++++++-
15
 
 elf/Makefile |    2 +-
16
 
 2 files changed, 7 insertions(+), 2 deletions(-)
 
15
 elf/Makefile |    4 ++--
 
16
 2 files changed, 8 insertions(+), 3 deletions(-)
17
17
 
18
18
--- a/Makeconfig
19
19
+++ b/Makeconfig
20
 
@@ -212,6 +212,11 @@
 
20
@@ -196,6 +196,11 @@
21
21
 endif
22
22
 inst_slibdir = $(install_root)$(slibdir)
23
23
 
29
29
 # Prefix to put on files installed in $(libdir).  For libraries `libNAME.a',
30
30
 # the prefix is spliced between `lib' and the name, so the linker switch
31
31
 # `-l$(libprefix)NAME' finds the library; for other files the prefix is
32
 
@@ -496,7 +501,7 @@
 
32
@@ -472,7 +477,7 @@
33
33
 endif
34
34
 ifndef config-LDFLAGS
35
 
 ifeq (yesyes,$(build-shared)$(elf))
 
35
 ifeq (yes,$(build-shared))
36
36
-config-LDFLAGS = -Wl,-dynamic-linker=$(slibdir)/$(rtld-installed-name)
37
37
+config-LDFLAGS = -Wl,-dynamic-linker=$(rtlddir)/$(rtld-installed-name)
38
38
 endif
40
40
 ifndef link-libc
41
41
--- a/elf/Makefile
42
42
+++ b/elf/Makefile
43
 
@@ -397,7 +397,7 @@
 
43
@@ -345,7 +345,7 @@
44
44
          | $(AWK) '($$7 ~ /^UND(|EF)$$/ && $$1 != "0:" && $$4 != "REGISTER") { print; p=1 } END { exit p != 0 }'
45
45
 
46
46
 # interp.c exists just to get this string into the libraries.
49
49
                  -DNOT_IN_libc=1
50
50
 $(objpfx)interp.os: $(common-objpfx)config.make
51
51
 
52
 
@@ -423,7 +423,7 @@
 
52
@@ -388,7 +388,7 @@
53
53
 endif
54
54
 
55
55