~ubuntu-branches/ubuntu/utopic/eglibc/utopic

« back to all changes in this revision

Viewing changes to debian/patches/hurd-i386/submitted-net.diff

  • Committer: Package Import Robot
  • Author(s): Adam Conrad
  • Date: 2012-10-26 05:14:58 UTC
  • mfrom: (1.5.1) (4.4.22 experimental)
  • Revision ID: package-import@ubuntu.com-20121026051458-oryotr4i03ob5pab
Tags: 2.16-0ubuntu1
* Merge with unreleased 2.16 in Debian experimental, remaining changes:
  - Drop the Breaks line from libc6, which refers to a Debian transition
  - Remove the libc6 recommends on libc6-i686, which we don't build
  - Enable libc6{,-dev}-armel on armhf and libc6{-dev}-armhf on armel
  - Ship update-locale and validlocale in /usr/sbin in libc-bin
  - Don't build locales or locales-all in Ubuntu, we rely on langpacks
  - Heavily mangle the way we do service restarting on major upgrades
  - Use different MIN_KERNEL_SUPPORTED versions than Debian, due to
    buildd needs.  This should be universally bumped to 3.2.0 once all
    our buildds (including the PPA guests) are running precise kernels
  - Build i386 variants as -march=i686, build amd64 with -O3, and build
    ppc64 variants (both 64-bit and 32-bit) with -O3 -fno-tree-vectorize
  - Re-enable unsubmitted-ldconfig-cache-abi.diff and rebuild the cache
    on upgrades from previous versions that used a different constant
  - debian/patches/any/local-CVE-2012-3406.diff: switch to malloc when
    array grows too large to handle via alloca extension (CVE-2012-3406)
  - Build generic i386/i686 flavour with -mno-tls-direct-seg-refs
* Changes added/dropped with this merge while reducing our delta:
  - Stop building glibc docs from the eglibc source, and instead make
    the glibc-docs stub have a hard dependency on glibc-doc-reference
  - Remove outdated conflicts against ancient versions of ia32-libs
  - Drop the tzdata dependency from libc6, it's in required and minimal
  - Use gcc-4.7/g++-4.7 by default on all our supported architectures
  - Save our historical changelog as changelog.ubuntu in the source
  - Drop nscd's libaudit build-dep for now, as libaudit is in universe
  - Drop the unnecessary Breaks from libc6 to locales and locales-all
  - Ship xen's ld.so.conf.d snippet as /etc/ld.so.conf.d/libc6-xen.conf
* Disable hard failures on the test suite for the first upload to raring

Show diffs side-by-side

added added

removed removed

Lines of Context:
78
78
 sysdeps/unix/sysv/linux/netinet/if_ether.h |  105 ----------------
79
79
 20 files changed, 815 insertions(+), 1310 deletions(-)
80
80
 
81
 
--- a/sysdeps/gnu/Makefile
82
 
+++ b/sysdeps/gnu/Makefile
83
 
@@ -91,3 +91,8 @@
 
81
Index: eglibc-2.16/sysdeps/gnu/Makefile
 
82
===================================================================
 
83
--- eglibc-2.16.orig/sysdeps/gnu/Makefile       2012-07-22 23:38:01.000000000 +0200
 
84
+++ eglibc-2.16/sysdeps/gnu/Makefile    2012-07-23 00:21:13.000000000 +0200
 
85
@@ -87,3 +87,8 @@
84
86
 librt-shared-only-routines += rt-unwind-resume
85
87
 CFLAGS-rt-unwind-resume.c += -fexceptions -fasynchronous-unwind-tables
86
88
 endif
89
91
+sysdep_headers += net/ethernet.h net/if_arp.h net/if_ether.h net/if_ppp.h \
90
92
+                 net/route.h
91
93
+endif
92
 
--- /dev/null
93
 
+++ b/sysdeps/gnu/net/ethernet.h
94
 
@@ -0,0 +1,84 @@
 
94
Index: eglibc-2.16/sysdeps/gnu/net/ethernet.h
 
95
===================================================================
 
96
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
 
97
+++ eglibc-2.16/sysdeps/gnu/net/ethernet.h      2012-07-23 00:21:13.000000000 +0200
 
98
@@ -0,0 +1,83 @@
95
99
+/* Copyright (C) 1997, 1999, 2001, 2008, 2010 Free Software Foundation, Inc.
96
100
+   This file is part of the GNU C Library.
97
101
+
106
110
+   Lesser General Public License for more details.
107
111
+
108
112
+   You should have received a copy of the GNU Lesser General Public
109
 
+   License along with the GNU C Library; if not, write to the Free
110
 
+   Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
111
 
+   02111-1307 USA.  */
 
113
+   License along with the GNU C Library; if not, see
 
114
+   <http://www.gnu.org/licenses/>.  */
112
115
+
113
116
+/* Based on the FreeBSD version of this file. Curiously, that file
114
117
+   lacks a copyright in the header. */
176
179
+__END_DECLS
177
180
+
178
181
+#endif /* net/ethernet.h */
179
 
--- /dev/null
180
 
+++ b/sysdeps/gnu/net/if_arp.h
181
 
@@ -0,0 +1,184 @@
 
182
Index: eglibc-2.16/sysdeps/gnu/net/if_arp.h
 
183
===================================================================
 
184
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
 
185
+++ eglibc-2.16/sysdeps/gnu/net/if_arp.h        2012-07-23 00:21:13.000000000 +0200
 
186
@@ -0,0 +1,183 @@
182
187
+/* Definitions for Address Resolution Protocol.
183
188
+   Copyright (C) 1997,1999,2001,2006,2009 Free Software Foundation, Inc.
184
189
+   This file is part of the GNU C Library.
195
200
+   Lesser General Public License for more details.
196
201
+
197
202
+   You should have received a copy of the GNU Lesser General Public
198
 
+   License along with the GNU C Library; if not, write to the Free
199
 
+   Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
200
 
+   02111-1307 USA.  */
 
203
+   License along with the GNU C Library; if not, see
 
204
+   <http://www.gnu.org/licenses/>.  */
201
205
+
202
206
+/* Based on the 4.4BSD and Linux version of this file.  */
203
207
+
363
367
+__END_DECLS
364
368
+
365
369
+#endif /* net/if_arp.h */
366
 
--- /dev/null
367
 
+++ b/sysdeps/gnu/net/if_ether.h
368
 
@@ -0,0 +1,116 @@
 
370
Index: eglibc-2.16/sysdeps/gnu/net/if_ether.h
 
371
===================================================================
 
372
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
 
373
+++ eglibc-2.16/sysdeps/gnu/net/if_ether.h      2012-07-23 00:21:13.000000000 +0200
 
374
@@ -0,0 +1,115 @@
369
375
+/* Copyright (C) 1997,2010 Free Software Foundation, Inc.
370
376
+   This file is part of the GNU C Library.
371
377
+
380
386
+   Lesser General Public License for more details.
381
387
+
382
388
+   You should have received a copy of the GNU Lesser General Public
383
 
+   License along with the GNU C Library; if not, write to the Free
384
 
+   Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
385
 
+   02111-1307 USA.  */
 
389
+   License along with the GNU C Library; if not, see
 
390
+   <http://www.gnu.org/licenses/>.  */
386
391
+
387
392
+#ifndef _NET_IF_ETHER_H
388
393
+#define _NET_IF_ETHER_H        1
482
487
+} __attribute__((packed));
483
488
+
484
489
+#endif /* net/if_ether.h */
485
 
--- /dev/null
486
 
+++ b/sysdeps/gnu/net/if_ppp.h
 
490
Index: eglibc-2.16/sysdeps/gnu/net/if_ppp.h
 
491
===================================================================
 
492
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
 
493
+++ eglibc-2.16/sysdeps/gnu/net/if_ppp.h        2012-07-23 00:21:13.000000000 +0200
487
494
@@ -0,0 +1,169 @@
488
495
+/*     From: if_ppp.h,v 1.3 1995/06/12 11:36:50 paulus Exp */
489
496
+
654
661
+__END_DECLS
655
662
+
656
663
+#endif /* net/if_ppp.h */
657
 
--- /dev/null
658
 
+++ b/sysdeps/gnu/net/route.h
659
 
@@ -0,0 +1,145 @@
 
664
Index: eglibc-2.16/sysdeps/gnu/net/route.h
 
665
===================================================================
 
666
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
 
667
+++ eglibc-2.16/sysdeps/gnu/net/route.h 2012-07-23 00:21:13.000000000 +0200
 
668
@@ -0,0 +1,144 @@
660
669
+/* Copyright (C) 1997, 2002 Free Software Foundation, Inc.
661
670
+   This file is part of the GNU C Library.
662
671
+
671
680
+   Lesser General Public License for more details.
672
681
+
673
682
+   You should have received a copy of the GNU Lesser General Public
674
 
+   License along with the GNU C Library; if not, write to the Free
675
 
+   Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
676
 
+   02111-1307 USA.  */
 
683
+   License along with the GNU C Library; if not, see
 
684
+   <http://www.gnu.org/licenses/>.  */
677
685
+
678
686
+/* Based on the 4.4BSD and Linux version of this file.  */
679
687
+
802
810
+#define RTMSG_AR_FAILED                0x51    /* Address Resolution failed.  */
803
811
+
804
812
+#endif /* net/route.h */
805
 
--- /dev/null
806
 
+++ b/sysdeps/gnu/netinet/if_ether.h
807
 
@@ -0,0 +1,104 @@
 
813
Index: eglibc-2.16/sysdeps/gnu/netinet/if_ether.h
 
814
===================================================================
 
815
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
 
816
+++ eglibc-2.16/sysdeps/gnu/netinet/if_ether.h  2012-07-23 00:21:13.000000000 +0200
 
817
@@ -0,0 +1,103 @@
808
818
+/* Copyright (C) 1996, 1997, 1999 Free Software Foundation, Inc.
809
819
+   This file is part of the GNU C Library.
810
820
+
819
829
+   Lesser General Public License for more details.
820
830
+
821
831
+   You should have received a copy of the GNU Lesser General Public
822
 
+   License along with the GNU C Library; if not, write to the Free
823
 
+   Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
824
 
+   02111-1307 USA.  */
 
832
+   License along with the GNU C Library; if not, see
 
833
+   <http://www.gnu.org/licenses/>.  */
825
834
+
826
835
+#ifndef __NETINET_IF_ETHER_H
827
836
+
909
918
+#endif /* __USE_BSD */
910
919
+
911
920
+#endif /* netinet/if_ether.h */
912
 
--- a/sysdeps/mach/hurd/Makefile
913
 
+++ b/sysdeps/mach/hurd/Makefile
914
 
@@ -206,11 +206,6 @@
 
921
Index: eglibc-2.16/sysdeps/mach/hurd/Makefile
 
922
===================================================================
 
923
--- eglibc-2.16.orig/sysdeps/mach/hurd/Makefile 2012-07-22 23:38:01.000000000 +0200
 
924
+++ eglibc-2.16/sysdeps/mach/hurd/Makefile      2012-07-23 00:21:13.000000000 +0200
 
925
@@ -195,9 +195,4 @@
915
926
 sysdep_headers += nfs/nfs.h
916
927
 endif
917
928
 
920
931
-                 net/route.h
921
932
-endif
922
933
-
923
 
 ifeq ($(subdir),csu)
924
 
 routines += unwind-resume
925
 
 shared-only-routines += unwind-resume
926
 
--- a/sysdeps/mach/hurd/net/ethernet.h
927
 
+++ /dev/null
928
 
@@ -1,76 +0,0 @@
 
934
 endif  # in-Makerules
 
935
Index: eglibc-2.16/sysdeps/mach/hurd/net/ethernet.h
 
936
===================================================================
 
937
--- eglibc-2.16.orig/sysdeps/mach/hurd/net/ethernet.h   2012-02-18 03:24:59.000000000 +0100
 
938
+++ /dev/null   1970-01-01 00:00:00.000000000 +0000
 
939
@@ -1,75 +0,0 @@
929
940
-/* Copyright (C) 1997 Free Software Foundation, Inc.
930
941
-   This file is part of the GNU C Library.
931
942
-
940
951
-   Lesser General Public License for more details.
941
952
-
942
953
-   You should have received a copy of the GNU Lesser General Public
943
 
-   License along with the GNU C Library; if not, write to the Free
944
 
-   Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
945
 
-   02111-1307 USA.  */
 
954
-   License along with the GNU C Library; if not, see
 
955
-   <http://www.gnu.org/licenses/>.  */
946
956
-
947
957
-/* Based on the FreeBSD version of this file. Curiously, that file
948
958
-   lacks a copyright in the header. */
1002
1012
-__END_DECLS
1003
1013
-
1004
1014
-#endif /* net/ethernet.h */
1005
 
--- a/sysdeps/mach/hurd/net/if_arp.h
1006
 
+++ /dev/null
1007
 
@@ -1,145 +0,0 @@
 
1015
Index: eglibc-2.16/sysdeps/mach/hurd/net/if_arp.h
 
1016
===================================================================
 
1017
--- eglibc-2.16.orig/sysdeps/mach/hurd/net/if_arp.h     2012-02-18 03:24:59.000000000 +0100
 
1018
+++ /dev/null   1970-01-01 00:00:00.000000000 +0000
 
1019
@@ -1,144 +0,0 @@
1008
1020
-/* Definitions for Address Resolution Protocol.
1009
1021
-   Copyright (C) 1997 Free Software Foundation, Inc.
1010
1022
-   This file is part of the GNU C Library.
1021
1033
-   Lesser General Public License for more details.
1022
1034
-
1023
1035
-   You should have received a copy of the GNU Lesser General Public
1024
 
-   License along with the GNU C Library; if not, write to the Free
1025
 
-   Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
1026
 
-   02111-1307 USA.  */
 
1036
-   License along with the GNU C Library; if not, see
 
1037
-   <http://www.gnu.org/licenses/>.  */
1027
1038
-
1028
1039
-/* Based on the 4.4BSD and Linux version of this file.  */
1029
1040
-
1150
1161
-__END_DECLS
1151
1162
-
1152
1163
-#endif /* net/if_arp.h */
1153
 
--- a/sysdeps/mach/hurd/net/if_ether.h
1154
 
+++ /dev/null
1155
 
@@ -1,85 +0,0 @@
 
1164
Index: eglibc-2.16/sysdeps/mach/hurd/net/if_ether.h
 
1165
===================================================================
 
1166
--- eglibc-2.16.orig/sysdeps/mach/hurd/net/if_ether.h   2012-02-18 03:24:59.000000000 +0100
 
1167
+++ /dev/null   1970-01-01 00:00:00.000000000 +0000
 
1168
@@ -1,84 +0,0 @@
1156
1169
-/* Copyright (C) 1997 Free Software Foundation, Inc.
1157
1170
-   This file is part of the GNU C Library.
1158
1171
-
1167
1180
-   Lesser General Public License for more details.
1168
1181
-
1169
1182
-   You should have received a copy of the GNU Lesser General Public
1170
 
-   License along with the GNU C Library; if not, write to the Free
1171
 
-   Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
1172
 
-   02111-1307 USA.  */
 
1183
-   License along with the GNU C Library; if not, see
 
1184
-   <http://www.gnu.org/licenses/>.  */
1173
1185
-
1174
1186
-#ifndef _NET_IF_ETHER_H
1175
1187
-#define _NET_IF_ETHER_H        1
1238
1250
-};
1239
1251
-
1240
1252
-#endif /* net/if_ether.h */
1241
 
--- a/sysdeps/mach/hurd/net/if_ppp.h
1242
 
+++ /dev/null
 
1253
Index: eglibc-2.16/sysdeps/mach/hurd/net/if_ppp.h
 
1254
===================================================================
 
1255
--- eglibc-2.16.orig/sysdeps/mach/hurd/net/if_ppp.h     2006-08-17 03:18:26.000000000 +0200
 
1256
+++ /dev/null   1970-01-01 00:00:00.000000000 +0000
1243
1257
@@ -1,169 +0,0 @@
1244
1258
-/*     From: if_ppp.h,v 1.3 1995/06/12 11:36:50 paulus Exp */
1245
1259
-
1410
1424
-__END_DECLS
1411
1425
-
1412
1426
-#endif /* net/if_ppp.h */
1413
 
--- a/sysdeps/mach/hurd/net/route.h
1414
 
+++ /dev/null
1415
 
@@ -1,141 +0,0 @@
 
1427
Index: eglibc-2.16/sysdeps/mach/hurd/net/route.h
 
1428
===================================================================
 
1429
--- eglibc-2.16.orig/sysdeps/mach/hurd/net/route.h      2012-02-18 03:24:59.000000000 +0100
 
1430
+++ /dev/null   1970-01-01 00:00:00.000000000 +0000
 
1431
@@ -1,140 +0,0 @@
1416
1432
-/* Copyright (C) 1997 Free Software Foundation, Inc..
1417
1433
-   This file is part of the GNU C Library.
1418
1434
-
1427
1443
-   Lesser General Public License for more details.
1428
1444
-
1429
1445
-   You should have received a copy of the GNU Lesser General Public
1430
 
-   License along with the GNU C Library; if not, write to the Free
1431
 
-   Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
1432
 
-   02111-1307 USA.  */
 
1446
-   License along with the GNU C Library; if not, see
 
1447
-   <http://www.gnu.org/licenses/>.  */
1433
1448
-
1434
1449
-/* Based on the 4.4BSD and Linux version of this file.  */
1435
1450
-
1554
1569
-#define RTMSG_AR_FAILED                0x51    /* Address Resolution failed.  */
1555
1570
-
1556
1571
-#endif /* net/route.h */
1557
 
--- a/sysdeps/unix/sysv/linux/Makefile
1558
 
+++ b/sysdeps/unix/sysv/linux/Makefile
1559
 
@@ -102,8 +102,7 @@
 
1572
Index: eglibc-2.16/sysdeps/unix/sysv/linux/Makefile
 
1573
===================================================================
 
1574
--- eglibc-2.16.orig/sysdeps/unix/sysv/linux/Makefile   2012-06-01 15:59:14.000000000 +0200
 
1575
+++ eglibc-2.16/sysdeps/unix/sysv/linux/Makefile        2012-07-23 00:21:13.000000000 +0200
 
1576
@@ -110,8 +110,7 @@
1560
1577
 endif
1561
1578
 
1562
1579
 ifeq ($(subdir),socket)
1566
1583
                  net/if_slip.h net/if_packet.h net/if_shaper.h
1567
1584
 sysdep_routines += cmsg_nxthdr sa_len
1568
1585
 endif
1569
 
--- a/sysdeps/unix/sysv/linux/net/ethernet.h
1570
 
+++ /dev/null
1571
 
@@ -1,84 +0,0 @@
 
1586
Index: eglibc-2.16/sysdeps/unix/sysv/linux/net/ethernet.h
 
1587
===================================================================
 
1588
--- eglibc-2.16.orig/sysdeps/unix/sysv/linux/net/ethernet.h     2012-02-18 03:24:59.000000000 +0100
 
1589
+++ /dev/null   1970-01-01 00:00:00.000000000 +0000
 
1590
@@ -1,83 +0,0 @@
1572
1591
-/* Copyright (C) 1997, 1999, 2001, 2008 Free Software Foundation, Inc.
1573
1592
-   This file is part of the GNU C Library.
1574
1593
-
1583
1602
-   Lesser General Public License for more details.
1584
1603
-
1585
1604
-   You should have received a copy of the GNU Lesser General Public
1586
 
-   License along with the GNU C Library; if not, write to the Free
1587
 
-   Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
1588
 
-   02111-1307 USA.  */
 
1605
-   License along with the GNU C Library; if not, see
 
1606
-   <http://www.gnu.org/licenses/>.  */
1589
1607
-
1590
1608
-/* Based on the FreeBSD version of this file. Curiously, that file
1591
1609
-   lacks a copyright in the header. */
1653
1671
-__END_DECLS
1654
1672
-
1655
1673
-#endif /* net/ethernet.h */
1656
 
--- a/sysdeps/unix/sysv/linux/net/if_arp.h
1657
 
+++ /dev/null
1658
 
@@ -1,184 +0,0 @@
 
1674
Index: eglibc-2.16/sysdeps/unix/sysv/linux/net/if_arp.h
 
1675
===================================================================
 
1676
--- eglibc-2.16.orig/sysdeps/unix/sysv/linux/net/if_arp.h       2012-02-18 03:24:59.000000000 +0100
 
1677
+++ /dev/null   1970-01-01 00:00:00.000000000 +0000
 
1678
@@ -1,183 +0,0 @@
1659
1679
-/* Definitions for Address Resolution Protocol.
1660
1680
-   Copyright (C) 1997,1999,2001,2006,2009 Free Software Foundation, Inc.
1661
1681
-   This file is part of the GNU C Library.
1672
1692
-   Lesser General Public License for more details.
1673
1693
-
1674
1694
-   You should have received a copy of the GNU Lesser General Public
1675
 
-   License along with the GNU C Library; if not, write to the Free
1676
 
-   Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
1677
 
-   02111-1307 USA.  */
 
1695
-   License along with the GNU C Library; if not, see
 
1696
-   <http://www.gnu.org/licenses/>.  */
1678
1697
-
1679
1698
-/* Based on the 4.4BSD and Linux version of this file.  */
1680
1699
-
1840
1859
-__END_DECLS
1841
1860
-
1842
1861
-#endif /* net/if_arp.h */
1843
 
--- /dev/null
1844
 
+++ b/sysdeps/unix/sysv/linux/net/if_ether.h
 
1862
Index: eglibc-2.16/sysdeps/unix/sysv/linux/net/if_ether.h
 
1863
===================================================================
 
1864
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
 
1865
+++ eglibc-2.16/sysdeps/unix/sysv/linux/net/if_ether.h  2012-07-23 00:21:13.000000000 +0200
1845
1866
@@ -0,0 +1,7 @@
1846
1867
+#ifndef _NET_IF_ETHER_H
1847
1868
+#define _NET_IF_ETHER_H 1
1850
1871
+#include <linux/if_ether.h>
1851
1872
+
1852
1873
+#endif /* net/if_ether.h */
1853
 
--- a/sysdeps/unix/sysv/linux/net/if_ppp.h
1854
 
+++ /dev/null
 
1874
Index: eglibc-2.16/sysdeps/unix/sysv/linux/net/if_ppp.h
 
1875
===================================================================
 
1876
--- eglibc-2.16.orig/sysdeps/unix/sysv/linux/net/if_ppp.h       2006-08-17 03:18:26.000000000 +0200
 
1877
+++ /dev/null   1970-01-01 00:00:00.000000000 +0000
1855
1878
@@ -1,169 +0,0 @@
1856
1879
-/*     From: if_ppp.h,v 1.3 1995/06/12 11:36:50 paulus Exp */
1857
1880
-
2022
2045
-__END_DECLS
2023
2046
-
2024
2047
-#endif /* net/if_ppp.h */
2025
 
--- a/sysdeps/unix/sysv/linux/net/route.h
2026
 
+++ /dev/null
2027
 
@@ -1,145 +0,0 @@
 
2048
Index: eglibc-2.16/sysdeps/unix/sysv/linux/net/route.h
 
2049
===================================================================
 
2050
--- eglibc-2.16.orig/sysdeps/unix/sysv/linux/net/route.h        2012-02-18 03:24:59.000000000 +0100
 
2051
+++ /dev/null   1970-01-01 00:00:00.000000000 +0000
 
2052
@@ -1,144 +0,0 @@
2028
2053
-/* Copyright (C) 1997, 2002 Free Software Foundation, Inc.
2029
2054
-   This file is part of the GNU C Library.
2030
2055
-
2039
2064
-   Lesser General Public License for more details.
2040
2065
-
2041
2066
-   You should have received a copy of the GNU Lesser General Public
2042
 
-   License along with the GNU C Library; if not, write to the Free
2043
 
-   Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
2044
 
-   02111-1307 USA.  */
 
2067
-   License along with the GNU C Library; if not, see
 
2068
-   <http://www.gnu.org/licenses/>.  */
2045
2069
-
2046
2070
-/* Based on the 4.4BSD and Linux version of this file.  */
2047
2071
-
2170
2194
-#define RTMSG_AR_FAILED                0x51    /* Address Resolution failed.  */
2171
2195
-
2172
2196
-#endif /* net/route.h */
2173
 
--- a/sysdeps/unix/sysv/linux/netinet/if_ether.h
2174
 
+++ /dev/null
2175
 
@@ -1,105 +0,0 @@
 
2197
Index: eglibc-2.16/sysdeps/unix/sysv/linux/netinet/if_ether.h
 
2198
===================================================================
 
2199
--- eglibc-2.16.orig/sysdeps/unix/sysv/linux/netinet/if_ether.h 2012-02-18 03:24:59.000000000 +0100
 
2200
+++ /dev/null   1970-01-01 00:00:00.000000000 +0000
 
2201
@@ -1,104 +0,0 @@
2176
2202
-/* Copyright (C) 1996, 1997, 1999 Free Software Foundation, Inc.
2177
2203
-   This file is part of the GNU C Library.
2178
2204
-
2187
2213
-   Lesser General Public License for more details.
2188
2214
-
2189
2215
-   You should have received a copy of the GNU Lesser General Public
2190
 
-   License along with the GNU C Library; if not, write to the Free
2191
 
-   Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
2192
 
-   02111-1307 USA.  */
 
2216
-   License along with the GNU C Library; if not, see
 
2217
-   <http://www.gnu.org/licenses/>.  */
2193
2218
-
2194
2219
-#ifndef __NETINET_IF_ETHER_H
2195
2220
-