~ubuntu-branches/ubuntu/vivid/virtualbox-ose/vivid

« back to all changes in this revision

Viewing changes to debian/patches/13-module-mismatch.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Felix Geyer
  • Date: 2010-03-11 17:16:37 UTC
  • mfrom: (0.3.4 upstream) (0.4.8 sid)
  • Revision ID: james.westby@ubuntu.com-20100311171637-43z64ia3ccpj8vqn
Tags: 3.1.4-dfsg-2ubuntu1
* Merge from Debian unstable (LP: #528561), remaining changes:
  - VirtualBox should go in Accessories, not in System tools (LP: #288590)
    - debian/virtualbox-ose-qt.files/virtualbox-ose.desktop
  - Add Apport hook
    - debian/virtualbox-ose.files/source_virtualbox-ose.py
    - debian/virtualbox-ose.install
  - Add Launchpad integration
    - debian/control
    - debian/lpi-bug.xpm
    - debian/patches/u02-lp-integration.dpatch
  - Replace *-source packages with transitional packages for *-dkms
* Fix crash in vboxvideo_drm with kernel 2.6.33 / backported drm code
  (LP: #535297)
* Add a list of linux-headers packages to the apport hook
* Update debian/patches/u02-lp-integration.dpatch with a
  DEP-3 compliant header
* Add ${misc:Depends} to virtualbox-ose-source and virtualbox-ose-guest-source
  Depends

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
1
#!/bin/sh /usr/share/dpatch/dpatch-run
2
 
## 13-module-mismatch.dpatch by Daniel Baumann <daniel@debian.org>
3
 
##
4
 
## DP: Adjusts failure message with Ubuntu specific solution.
 
2
# Description: Adjusts failure message with Debian specific solution.
 
3
# Author: Daniel Baumann <daniel@debian.org>
5
4
 
6
5
@DPATCH@
7
6
diff -urNad virtualbox-ose-3.0.8-dfsg~/src/VBox/VMM/VM.cpp virtualbox-ose-3.0.8-dfsg/src/VBox/VMM/VM.cpp
8
7
--- virtualbox-ose-3.0.8-dfsg~/src/VBox/VMM/VM.cpp      2009-10-07 13:43:36.542988533 +0200
9
8
+++ virtualbox-ose-3.0.8-dfsg/src/VBox/VMM/VM.cpp       2009-10-07 13:43:37.342988388 +0200
10
 
@@ -383,9 +383,11 @@
 
9
@@ -383,9 +383,9 @@
11
10
                     break;
12
11
                 case VERR_VERSION_MISMATCH:
13
12
                 case VERR_VM_DRIVER_VERSION_MISMATCH:
15
14
-                                  "version of VirtualBox.  You can correct this by stopping all "
16
15
-                                  "running instances of VirtualBox and reinstalling the software.");
17
16
+                    pszError = N_("The version of the VirtualBox kernel modules and the version of "
18
 
+                                 "VirtualBox application are not matching. You can correct this by "
19
 
+                                 "installing the virtualbox-ose-source package "
20
 
+                                 "through apt-get or by building it manually with: "
21
 
+                                 "module-assistant auto-install virtualbox-ose");
 
17
+                                  "VirtualBox application are not matching. You can correct this by "
 
18
+                                  "installing the virtualbox-ose-dkms package through apt-get.");
22
19
                     break;
23
20
                 default:
24
21
                     pszError = N_("Unknown error initializing kernel driver");