~ubuntu-branches/ubuntu/vivid/virtualbox-ose/vivid

« back to all changes in this revision

Viewing changes to debian/patches/18-xorg-1.6.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Felix Geyer
  • Date: 2010-03-11 17:16:37 UTC
  • mfrom: (0.3.4 upstream) (0.4.8 sid)
  • Revision ID: james.westby@ubuntu.com-20100311171637-43z64ia3ccpj8vqn
Tags: 3.1.4-dfsg-2ubuntu1
* Merge from Debian unstable (LP: #528561), remaining changes:
  - VirtualBox should go in Accessories, not in System tools (LP: #288590)
    - debian/virtualbox-ose-qt.files/virtualbox-ose.desktop
  - Add Apport hook
    - debian/virtualbox-ose.files/source_virtualbox-ose.py
    - debian/virtualbox-ose.install
  - Add Launchpad integration
    - debian/control
    - debian/lpi-bug.xpm
    - debian/patches/u02-lp-integration.dpatch
  - Replace *-source packages with transitional packages for *-dkms
* Fix crash in vboxvideo_drm with kernel 2.6.33 / backported drm code
  (LP: #535297)
* Add a list of linux-headers packages to the apport hook
* Update debian/patches/u02-lp-integration.dpatch with a
  DEP-3 compliant header
* Add ${misc:Depends} to virtualbox-ose-source and virtualbox-ose-guest-source
  Depends

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
1
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## 18-xorg-1.6.dpatch by Michael Meskes <meskes@debian.org>
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: Use XServer-Xorg 1.6
 
2
# Description: Use XServer-Xorg 1.6
 
3
# Author: Michael Meskes <meskes@debian.org>
6
4
 
7
5
@DPATCH@
8
6
diff -urNad virtualbox-ose-3.1.0-dfsg~/src/VBox/Additions/common/crOpenGL/Makefile.kmk virtualbox-ose-3.1.0-dfsg/src/VBox/Additions/common/crOpenGL/Makefile.kmk
9
7
--- virtualbox-ose-3.1.0-dfsg~/src/VBox/Additions/common/crOpenGL/Makefile.kmk  2009-10-07 11:27:13.000000000 +0200
10
8
+++ virtualbox-ose-3.1.0-dfsg/src/VBox/Additions/common/crOpenGL/Makefile.kmk   2009-10-07 13:44:19.145463290 +0200
11
 
@@ -69,21 +69,16 @@
 
9
@@ -67,16 +67,11 @@
12
10
 VBoxOGL_INCS           = .
13
11
 if1of ($(KBUILD_TARGET),linux solaris)
14
12
  VBoxOGL_INCS     += \
23
21
+       /usr/include/x11 \
24
22
+       /usr/include/xorg \
25
23
+       /usr/include/pixman-1 \
26
 
        $(VBOX_PATH_MESA_SOURCE) \
27
 
        $(VBOX_PATH_MESA_SOURCE)/include \
28
 
        $(VBOX_PATH_MESA_SOURCE)/src/mesa/ \
29
 
        $(VBOX_PATH_MESA_SOURCE)/src/mesa/glapi \
30
 
        $(VBOX_PATH_MESA_SOURCE)/src/mesa/main \
31
 
        $(VBOX_PATH_MESA_SOURCE)/src/mesa/drivers/dri/common \
 
24
        $(VBOX_MESA_INCS) \
32
25
-       $(PATH_ROOT)/src/VBox/Additions/x11/x11include/libdrm-2.4.13
33
26
+       /usr/include/drm
34
27
  VBoxOGL_DEFS     += VBOX_NO_NATIVEGL
35
28
 endif
36
 
 ifdef VBoxOGL_DRI
 
29
 
37
30
diff -urNad virtualbox-ose-3.1.0-dfsg~/src/VBox/Additions/x11/vboxmouse/Makefile.kmk virtualbox-ose-3.1.0-dfsg/src/VBox/Additions/x11/vboxmouse/Makefile.kmk
38
31
--- virtualbox-ose-3.1.0-dfsg~/src/VBox/Additions/x11/vboxmouse/Makefile.kmk    2009-10-07 11:27:13.000000000 +0200
39
32
+++ virtualbox-ose-3.1.0-dfsg/src/VBox/Additions/x11/vboxmouse/Makefile.kmk     2009-10-07 13:44:19.145463290 +0200