~ubuntu-branches/ubuntu/vivid/virtualbox-ose/vivid

« back to all changes in this revision

Viewing changes to debian/patches/u03-vboxvideo_drm-2.6.33.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Felix Geyer
  • Date: 2010-03-11 17:16:37 UTC
  • mfrom: (0.3.4 upstream) (0.4.8 sid)
  • Revision ID: james.westby@ubuntu.com-20100311171637-43z64ia3ccpj8vqn
Tags: 3.1.4-dfsg-2ubuntu1
* Merge from Debian unstable (LP: #528561), remaining changes:
  - VirtualBox should go in Accessories, not in System tools (LP: #288590)
    - debian/virtualbox-ose-qt.files/virtualbox-ose.desktop
  - Add Apport hook
    - debian/virtualbox-ose.files/source_virtualbox-ose.py
    - debian/virtualbox-ose.install
  - Add Launchpad integration
    - debian/control
    - debian/lpi-bug.xpm
    - debian/patches/u02-lp-integration.dpatch
  - Replace *-source packages with transitional packages for *-dkms
* Fix crash in vboxvideo_drm with kernel 2.6.33 / backported drm code
  (LP: #535297)
* Add a list of linux-headers packages to the apport hook
* Update debian/patches/u02-lp-integration.dpatch with a
  DEP-3 compliant header
* Add ${misc:Depends} to virtualbox-ose-source and virtualbox-ose-guest-source
  Depends

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
# Description: Fix vboxvideo_drm crash with kernel 2.6.33 / backported drm code
 
3
# Bug: http://www.virtualbox.org/ticket/6198
 
4
# Bug-Ubuntu: https://bugs.launchpad.net/bugs/535297
 
5
 
 
6
@DPATCH@
 
7
 
 
8
Index: trunk/src/VBox/Additions/linux/drm/vboxvideo_drm.c
 
9
===================================================================
 
10
--- trunk/src/VBox/Additions/linux/drm/vboxvideo_drm.c (revision 25591)
 
11
+++ trunk/src/VBox/Additions/linux/drm/vboxvideo_drm.c (revision 27248)
 
12
@@ -88,5 +88,11 @@
 
13
                 .open = drm_open,
 
14
                 .release = drm_release,
 
15
+                 /* This was changed with Linux 2.6.33 but Fedora backported this
 
16
+                  * change to their 2.6.32 kernel. */
 
17
+#if defined(DRM_UNLOCKED) || LINUX_VERSION_CODE >= KERNEL_VERSION (2, 6, 33)
 
18
+                .unlocked_ioctl = drm_ioctl,
 
19
+#else
 
20
                 .ioctl = drm_ioctl,
 
21
+#endif
 
22
                 .mmap = drm_mmap,
 
23
                 .poll = drm_poll,