~ubuntu-branches/ubuntu/vivid/virtualbox-ose/vivid

« back to all changes in this revision

Viewing changes to debian/patches/16-no-update.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Felix Geyer
  • Date: 2010-03-11 17:16:37 UTC
  • mfrom: (0.3.4 upstream) (0.4.8 sid)
  • Revision ID: james.westby@ubuntu.com-20100311171637-43z64ia3ccpj8vqn
Tags: 3.1.4-dfsg-2ubuntu1
* Merge from Debian unstable (LP: #528561), remaining changes:
  - VirtualBox should go in Accessories, not in System tools (LP: #288590)
    - debian/virtualbox-ose-qt.files/virtualbox-ose.desktop
  - Add Apport hook
    - debian/virtualbox-ose.files/source_virtualbox-ose.py
    - debian/virtualbox-ose.install
  - Add Launchpad integration
    - debian/control
    - debian/lpi-bug.xpm
    - debian/patches/u02-lp-integration.dpatch
  - Replace *-source packages with transitional packages for *-dkms
* Fix crash in vboxvideo_drm with kernel 2.6.33 / backported drm code
  (LP: #535297)
* Add a list of linux-headers packages to the apport hook
* Update debian/patches/u02-lp-integration.dpatch with a
  DEP-3 compliant header
* Add ${misc:Depends} to virtualbox-ose-source and virtualbox-ose-guest-source
  Depends

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
1
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## 16-no-update.dpatch by Michael Meskes <meskes@debian.org>
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: Do not check for updates
 
2
# Description: Disable "Check for Updates" action.
 
3
# Bug-Ubuntu: https://bugs.launchpad.net/bugs/272212
 
4
# Author: Daniel Hahler <ubuntu@thequod.de>
6
5
 
7
6
@DPATCH@
8
 
diff -urNad virtualbox-ose-3.0.8-dfsg~/src/VBox/Main/VirtualBoxImpl.cpp virtualbox-ose-3.0.8-dfsg/src/VBox/Main/VirtualBoxImpl.cpp
9
 
--- virtualbox-ose-3.0.8-dfsg~/src/VBox/Main/VirtualBoxImpl.cpp 2009-10-07 11:27:14.000000000 +0200
10
 
+++ virtualbox-ose-3.0.8-dfsg/src/VBox/Main/VirtualBoxImpl.cpp  2009-10-07 13:44:02.835497353 +0200
11
 
@@ -90,6 +90,9 @@
12
 
     "<VirtualBox xmlns=\"" VBOX_XML_NAMESPACE "\" "
13
 
         "version=\"" VBOX_XML_VERSION_FULL "\">" RTFILE_LINEFEED
14
 
     "  <Global>"RTFILE_LINEFEED
15
 
+    "    <ExtraData>"RTFILE_LINEFEED
16
 
+    "      <ExtraDataItem name=\"GUI/UpdateDate\" value=\"never\"/>"RTFILE_LINEFEED
17
 
+    "    </ExtraData>"RTFILE_LINEFEED
18
 
     "    <MachineRegistry/>"RTFILE_LINEFEED
19
 
     "    <MediaRegistry/>"RTFILE_LINEFEED
20
 
     "    <NetserviceRegistry>"RTFILE_LINEFEED
 
7
diff -urNad virtualbox-ose-2.2.2-dfsg/src/VBox/Frontends/VirtualBox/src/globals/VBoxGlobal.cpp virtualbox-ose-2.2.2-dfsg.patch/src/VBox/Frontends/VirtualBox/src/globals/VBoxGlobal.cpp
 
8
--- virtualbox-ose-2.2.2-dfsg/src/VBox/Frontends/VirtualBox/src/globals/VBoxGlobal.cpp  2009-04-29 09:12:58.000000000 +0200
 
9
+++ virtualbox-ose-2.2.2-dfsg.patch/src/VBox/Frontends/VirtualBox/src/globals/VBoxGlobal.cpp    2009-05-16 16:07:45.094522826 +0200
 
10
@@ -4936,6 +4936,9 @@
 
11
  */
 
12
 void VBoxGlobal::showUpdateDialog (bool aForce)
 
13
 {
 
14
+    /* Update dialog disabled in Ubuntu: */
 
15
+    return;
 
16
+
 
17
     /* Silently check in one day after current time-stamp */
 
18
     QTimer::singleShot (24 /* hours */   * 60   /* minutes */ *
 
19
                         60 /* seconds */ * 1000 /* milliseconds */,
 
20
diff -urNad virtualbox-ose-2.2.2-dfsg/src/VBox/Frontends/VirtualBox/src/settings/global/VBoxGLSettingsUpdate.cpp virtualbox-ose-2.2.2-dfsg.patch/src/VBox/Frontends/VirtualBox/src/settings/global/VBoxGLSettingsUpdate.cpp
 
21
--- virtualbox-ose-2.2.2-dfsg/src/VBox/Frontends/VirtualBox/src/settings/global/VBoxGLSettingsUpdate.cpp        2009-04-29 09:12:58.000000000 +0200
 
22
+++ virtualbox-ose-2.2.2-dfsg.patch/src/VBox/Frontends/VirtualBox/src/settings/global/VBoxGLSettingsUpdate.cpp  2009-05-16 16:07:06.586518040 +0200
 
23
@@ -45,7 +45,7 @@
 
24
 {
 
25
     VBoxUpdateData data (vboxGlobal().virtualBox().GetExtraData (VBoxDefs::GUI_UpdateDate));
 
26
 
 
27
-    mCbCheck->setChecked (!data.isNoNeedToCheck());
 
28
+    mCbCheck->setChecked (false);
 
29
     if (mCbCheck->isChecked())
 
30
     {
 
31
         mCbOncePer->setCurrentIndex (data.periodIndex());
 
32
diff -urNad virtualbox-ose-2.2.2-dfsg/src/VBox/Frontends/VirtualBox/src/VBoxHelpActions.cpp virtualbox-ose-2.2.2-dfsg.patch/src/VBox/Frontends/VirtualBox/src/VBoxHelpActions.cpp
 
33
--- virtualbox-ose-2.2.2-dfsg/src/VBox/Frontends/VirtualBox/src/VBoxHelpActions.cpp     2009-04-29 09:12:58.000000000 +0200
 
34
+++ virtualbox-ose-2.2.2-dfsg.patch/src/VBox/Frontends/VirtualBox/src/VBoxHelpActions.cpp       2009-05-16 16:11:47.386517660 +0200
 
35
@@ -87,8 +87,7 @@
 
36
 #endif
 
37
 
 
38
     aMenu->addAction (updateAction);
 
39
-    updateAction->setEnabled (vboxGlobal().virtualBox().
 
40
-        GetExtraData (VBoxDefs::GUI_UpdateDlgWinID).isEmpty());
 
41
+    updateAction->setEnabled (false);
 
42
 
 
43
 #ifndef Q_WS_MAC
 
44
     aMenu->addSeparator();
 
45
diff -urNad virtualbox-ose-2.2.2-dfsg/src/VBox/Frontends/VirtualBox/src/settings/global/VBoxGLSettingsUpdate.ui virtualbox-ose-2.2.2-dfsg.patch/src/VBox/Frontends/VirtualBox/src/settings/global/VBoxGLSettingsUpdate.ui
 
46
--- virtualbox-ose-2.2.2-dfsg/src/VBox/Frontends/VirtualBox/src/settings/global/VBoxGLSettingsUpdate.ui 2009-04-29 09:12:58.000000000 +0200
 
47
+++ virtualbox-ose-2.2.2-dfsg.patch/src/VBox/Frontends/VirtualBox/src/settings/global/VBoxGLSettingsUpdate.ui   2009-05-16 16:12:57.066517714 +0200
 
48
@@ -18,6 +18,9 @@
 
49
  </comment>
 
50
  <class>VBoxGLSettingsUpdate</class>
 
51
  <widget class="QWidget" name="VBoxGLSettingsUpdate" >
 
52
+  <property name="enabled" >
 
53
+   <bool>false</bool>
 
54
+  </property>
 
55
   <property name="geometry" >
 
56
    <rect>
 
57
     <x>0</x>
 
58
@@ -48,7 +51,7 @@
 
59
       <string>&amp;Check for updates</string>
 
60
      </property>
 
61
      <property name="checked" >
 
62
-      <bool>true</bool>
 
63
+      <bool>false</bool>
 
64
      </property>
 
65
     </widget>
 
66
    </item>