~serge-hallyn/ubuntu/raring/libvirt/libvirt-hugepages

« back to all changes in this revision

Viewing changes to debian/patches/debian/Allow-libvirt-group-to-access-the-socket.patch

  • Committer: Package Import Robot
  • Author(s): Chuck Short
  • Date: 2012-05-13 15:44:12 UTC
  • mfrom: (1.2.13)
  • Revision ID: package-import@ubuntu.com-20120513154412-fgmn5sxqdzgnzlx3
Tags: 0.9.12-0ubuntu1
* New upstream version:
  * Synchronize with debian packaging:
    - debian/control: Update build depends.
    - debian/libvirt-bin.postrm: Cleanup /var/log/libvirt
      on purge.
    - Bump standards verson (no changes).
    - debian/patches/Don-t-fail-if-we-can-t-setup-avahi.patch: Added
  * Dropped patches:
    - debian/patches/Debianize-libvirt-guests.patch
    - debian/patches/rewrite-lxc-controller-eof-handling-yet-again
    - debian/patches/ubuntu/libnl13.patch
    - debian/patches/ubuntu/fix-lxc-startup-error.patch
    - debian/patches/ubuntu/fix-bridge-fd.patch
    - debian/patches/ubuntu/skip-labelling-network-disks.patch
    - debian/patches/ubuntu/xen-xend-shutdown-detection.patch
    - debian/patches/ubuntu/xen-config-no-vfb-for-hvm.patch
    - debian/patches/debian/Disable-daemon-start-test.patch
    - debian/patches/debian/Disable-gnulib-s-test-nonplocking-pipe.sh.patch
    - debian/patches/ubuntu/9006-default-config-test-case.patch
    - debian/patches/fix-block-migration.patch
    - debian/patches/ubuntu/9022-qemu-unescape-HMP-commands-before-converting-them-to.patch
    - debian/patches/ubuntu/9023-qemu-change-rbd-auth_supported-separation-character-.patch
    - debian/patches/ubuntu/9024-qemu-allow-snapshotting-of-sheepdog-and-rbd-disks.patch
    - debian/patches/9025-qemu-change-rbd-auth_supported-separation-character-.patch
    - debian/patches/ubuntu/arm-gcc-workaround.patch
  * Rediffed:
    - debian/patches/Allow-libvirt-group-to-access-the-socket.patch
    - debian/patches/Disable-failing-virnetsockettest.patch
    - debian/patches/dnsmasq-as-priv-user
    - debian/patches/9002-better_default_uri_virsh.patch
  * debian/control: Add libnl-route-3-dev ass a build depends.
  * debian/patches/libnl3-build-fix.patch: Fix build with libnl3.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From: Guido Guenther <agx@sigxcpu.org>
2
 
Date: Thu, 26 Jun 2008 20:01:38 +0200
3
 
Subject: Allow libvirt group to access the socket
4
 
 
5
 
---
6
 
 daemon/libvirtd.conf |    8 ++++----
7
 
 tests/daemon-conf    |    7 ++++++-
8
 
 2 files changed, 10 insertions(+), 5 deletions(-)
9
 
 
10
 
diff --git a/daemon/libvirtd.conf b/daemon/libvirtd.conf
11
 
index f218454..bb3efd1 100644
12
 
--- a/daemon/libvirtd.conf
13
 
+++ b/daemon/libvirtd.conf
14
 
@@ -78,7 +78,7 @@
15
 
 # without becoming root.
16
 
 #
17
 
 # This is restricted to 'root' by default.
18
 
-#unix_sock_group = "libvirt"
19
 
+unix_sock_group = "libvirt"
20
 
 
21
 
 # Set the UNIX socket permissions for the R/O socket. This is used
22
 
 # for monitoring VM status only
23
 
@@ -95,7 +95,7 @@
24
 
 #
25
 
 # If not using PolicyKit and setting group ownership for access
26
 
 # control then you may want to relax this to:
27
 
-#unix_sock_rw_perms = "0770"
28
 
+unix_sock_rw_perms = "0770"
29
 
 
30
 
 # Set the name of the directory in which sockets will be found/created.
31
 
 #unix_sock_dir = "/var/run/libvirt"
32
 
@@ -126,7 +126,7 @@
33
 
 #
34
 
 # To restrict monitoring of domains you may wish to enable
35
 
 # an authentication mechanism here
36
 
-#auth_unix_ro = "none"
37
 
+auth_unix_ro = "none"
38
 
 
39
 
 # Set an authentication scheme for UNIX read-write sockets
40
 
 # By default socket permissions only allow root. If PolicyKit
41
 
@@ -135,7 +135,7 @@
42
 
 #
43
 
 # If the unix_sock_rw_perms are changed you may wish to enable
44
 
 # an authentication mechanism here
45
 
-#auth_unix_rw = "none"
46
 
+auth_unix_rw = "none"
47
 
 
48
 
 # Change the authentication scheme for TCP sockets.
49
 
 #
50
 
diff --git a/tests/daemon-conf b/tests/daemon-conf
51
 
index f2b513d..6aa3269 100755
52
 
--- a/tests/daemon-conf
53
 
+++ b/tests/daemon-conf
54
 
@@ -19,7 +19,12 @@ grep '^#define WITH_QEMU 1' "$CONFIG_HEADER" > /dev/null ||
55
 
 conf="$abs_top_srcdir/daemon/libvirtd.conf"
56
 
 
57
 
 # Ensure that each commented out PARAMETER = VALUE line has the expected form.
58
 
-grep -v '\"PARAMETER = VALUE\"' "$conf" | grep '[a-z_]  *=  *[^ ]' | grep -vE '^#[a-z_]+ = ' \
59
 
+grep -v -e '\"PARAMETER = VALUE\"' \
60
 
+     -e 'unix_sock_group = \"libvirt\"' \
61
 
+     -e 'unix_sock_rw_perms = \"0770\"' \
62
 
+     -e 'auth_unix_ro = \"none\"' \
63
 
+     -e 'auth_unix_rw = \"none\"' \
64
 
+  "$conf" | grep '[a-z_]  *=  *[^ ]' | grep -vE '^#[a-z_]+ = ' \
65
 
   && { echo "$0: found unexpected lines (above) in $conf" 1>&2; exit 1; }
66
 
 
67
 
 # Start with the sample libvirtd.conf file, uncommenting all real directives.