~serge-hallyn/ubuntu/raring/libvirt/libvirt-hugepages

« back to all changes in this revision

Viewing changes to debian/patches/ubuntu/9020-lp545795.patch

  • Committer: Package Import Robot
  • Author(s): Chuck Short
  • Date: 2012-05-13 15:44:12 UTC
  • mfrom: (1.2.13)
  • Revision ID: package-import@ubuntu.com-20120513154412-fgmn5sxqdzgnzlx3
Tags: 0.9.12-0ubuntu1
* New upstream version:
  * Synchronize with debian packaging:
    - debian/control: Update build depends.
    - debian/libvirt-bin.postrm: Cleanup /var/log/libvirt
      on purge.
    - Bump standards verson (no changes).
    - debian/patches/Don-t-fail-if-we-can-t-setup-avahi.patch: Added
  * Dropped patches:
    - debian/patches/Debianize-libvirt-guests.patch
    - debian/patches/rewrite-lxc-controller-eof-handling-yet-again
    - debian/patches/ubuntu/libnl13.patch
    - debian/patches/ubuntu/fix-lxc-startup-error.patch
    - debian/patches/ubuntu/fix-bridge-fd.patch
    - debian/patches/ubuntu/skip-labelling-network-disks.patch
    - debian/patches/ubuntu/xen-xend-shutdown-detection.patch
    - debian/patches/ubuntu/xen-config-no-vfb-for-hvm.patch
    - debian/patches/debian/Disable-daemon-start-test.patch
    - debian/patches/debian/Disable-gnulib-s-test-nonplocking-pipe.sh.patch
    - debian/patches/ubuntu/9006-default-config-test-case.patch
    - debian/patches/fix-block-migration.patch
    - debian/patches/ubuntu/9022-qemu-unescape-HMP-commands-before-converting-them-to.patch
    - debian/patches/ubuntu/9023-qemu-change-rbd-auth_supported-separation-character-.patch
    - debian/patches/ubuntu/9024-qemu-allow-snapshotting-of-sheepdog-and-rbd-disks.patch
    - debian/patches/9025-qemu-change-rbd-auth_supported-separation-character-.patch
    - debian/patches/ubuntu/arm-gcc-workaround.patch
  * Rediffed:
    - debian/patches/Allow-libvirt-group-to-access-the-socket.patch
    - debian/patches/Disable-failing-virnetsockettest.patch
    - debian/patches/dnsmasq-as-priv-user
    - debian/patches/9002-better_default_uri_virsh.patch
  * debian/control: Add libnl-route-3-dev ass a build depends.
  * debian/patches/libnl3-build-fix.patch: Fix build with libnl3.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Author: John Ferlito <johnf@inodes.org>
2
 
Description: add vendor and device to pciDeviceFileIterate(). Patch submitted
3
 
 upstream and they feel it is reasonable, but not committed yet.
4
 
Bug: https://bugzilla.redhat.com/show_bug.cgi?id=624151
5
 
Bug-Ubuntu: https://bugs.launchpad.net/ubuntu/maverick/+source/libvirt/+bug/545795
6
 
 
7
 
Index: libvirt-0.9.7/src/util/pci.c
8
 
===================================================================
9
 
--- libvirt-0.9.7.orig/src/util/pci.c   2011-10-30 22:46:04.000000000 -0500
10
 
+++ libvirt-0.9.7/src/util/pci.c        2011-11-16 07:38:39.040557653 -0600
11
 
@@ -1602,6 +1602,8 @@
12
 
          */
13
 
         if (STREQ(ent->d_name, "config") ||
14
 
             STRPREFIX(ent->d_name, "resource") ||
15
 
+            STREQ(ent->d_name, "vendor") ||
16
 
+            STREQ(ent->d_name, "device") ||
17
 
             STREQ(ent->d_name, "rom") ||
18
 
             STREQ(ent->d_name, "reset")) {
19
 
             if (virAsprintf(&file, "%s/%s", pcidir, ent->d_name) < 0) {