~serge-hallyn/ubuntu/raring/libvirt/libvirt-hugepages

« back to all changes in this revision

Viewing changes to debian/patches/ubuntu/xen-config-no-vfb-for-hvm.patch

  • Committer: Package Import Robot
  • Author(s): Chuck Short
  • Date: 2012-05-13 15:44:12 UTC
  • mfrom: (1.2.13)
  • Revision ID: package-import@ubuntu.com-20120513154412-fgmn5sxqdzgnzlx3
Tags: 0.9.12-0ubuntu1
* New upstream version:
  * Synchronize with debian packaging:
    - debian/control: Update build depends.
    - debian/libvirt-bin.postrm: Cleanup /var/log/libvirt
      on purge.
    - Bump standards verson (no changes).
    - debian/patches/Don-t-fail-if-we-can-t-setup-avahi.patch: Added
  * Dropped patches:
    - debian/patches/Debianize-libvirt-guests.patch
    - debian/patches/rewrite-lxc-controller-eof-handling-yet-again
    - debian/patches/ubuntu/libnl13.patch
    - debian/patches/ubuntu/fix-lxc-startup-error.patch
    - debian/patches/ubuntu/fix-bridge-fd.patch
    - debian/patches/ubuntu/skip-labelling-network-disks.patch
    - debian/patches/ubuntu/xen-xend-shutdown-detection.patch
    - debian/patches/ubuntu/xen-config-no-vfb-for-hvm.patch
    - debian/patches/debian/Disable-daemon-start-test.patch
    - debian/patches/debian/Disable-gnulib-s-test-nonplocking-pipe.sh.patch
    - debian/patches/ubuntu/9006-default-config-test-case.patch
    - debian/patches/fix-block-migration.patch
    - debian/patches/ubuntu/9022-qemu-unescape-HMP-commands-before-converting-them-to.patch
    - debian/patches/ubuntu/9023-qemu-change-rbd-auth_supported-separation-character-.patch
    - debian/patches/ubuntu/9024-qemu-allow-snapshotting-of-sheepdog-and-rbd-disks.patch
    - debian/patches/9025-qemu-change-rbd-auth_supported-separation-character-.patch
    - debian/patches/ubuntu/arm-gcc-workaround.patch
  * Rediffed:
    - debian/patches/Allow-libvirt-group-to-access-the-socket.patch
    - debian/patches/Disable-failing-virnetsockettest.patch
    - debian/patches/dnsmasq-as-priv-user
    - debian/patches/9002-better_default_uri_virsh.patch
  * debian/control: Add libnl-route-3-dev ass a build depends.
  * debian/patches/libnl3-build-fix.patch: Fix build with libnl3.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
UBUNTU: xen: Do not use vfb device in HVM definitions
2
 
 
3
 
When talking to xend to create or modify an HVM instance,
4
 
graphics should be defined outside (without) any vfb device.
5
 
(see http://lists.xen.org/archives/html/xen-users/2011-11/msg00119.html)
6
 
 
7
 
The vfb definition works just out of luck, but doing so also defines
8
 
a vkbd device which causes xenbus init to fail after a long
9
 
time retrying.
10
 
 
11
 
Signed-off-by: Stefan Bader <stefan.bader@canonical.com>
12
 
Index: libvirt-0.9.8/src/xenxs/xen_xm.c
13
 
===================================================================
14
 
--- libvirt-0.9.8.orig/src/xenxs/xen_xm.c       2012-04-03 17:09:59.000000000 +0200
15
 
+++ libvirt-0.9.8/src/xenxs/xen_xm.c    2012-04-04 14:36:38.434001687 +0200
16
 
@@ -1669,7 +1669,7 @@ virConfPtr xenFormatXM(virConnectPtr con
17
 
     }
18
 
 
19
 
     if (def->ngraphics == 1) {
20
 
-        if (xendConfigVersion < (hvm ? 4 : XEND_CONFIG_MIN_VERS_PVFB_NEWCONF)) {
21
 
+        if (hvm || (xendConfigVersion < XEND_CONFIG_MIN_VERS_PVFB_NEWCONF)) {
22
 
             if (def->graphics[0]->type == VIR_DOMAIN_GRAPHICS_TYPE_SDL) {
23
 
                 if (xenXMConfigSetInt(conf, "sdl", 1) < 0)
24
 
                     goto no_memory;
25
 
Index: libvirt-0.9.8/src/xenxs/xen_sxpr.c
26
 
===================================================================
27
 
--- libvirt-0.9.8.orig/src/xenxs/xen_sxpr.c     2012-04-03 17:09:59.000000000 +0200
28
 
+++ libvirt-0.9.8/src/xenxs/xen_sxpr.c  2012-04-04 17:41:41.228280488 +0200
29
 
@@ -2296,9 +2296,8 @@ xenFormatSxpr(virConnectPtr conn,
30
 
             }
31
 
         }
32
 
 
33
 
-        /* PV graphics for xen <= 3.0.4, or HVM graphics for xen <= 3.1.0 */
34
 
-        if ((!hvm && xendConfigVersion < XEND_CONFIG_MIN_VERS_PVFB_NEWCONF) ||
35
 
-            (hvm && xendConfigVersion < 4)) {
36
 
+        /* PV graphics for xen <= 3.0.4, or HVM graphics */
37
 
+        if (hvm || (xendConfigVersion < XEND_CONFIG_MIN_VERS_PVFB_NEWCONF)) {
38
 
             if ((def->ngraphics == 1) &&
39
 
                 xenFormatSxprGraphicsOld(def->graphics[0],
40
 
                                          &buf, xendConfigVersion) < 0)
41
 
@@ -2327,10 +2326,8 @@ xenFormatSxpr(virConnectPtr conn,
42
 
     if (xenFormatSxprAllPCI(def, &buf) < 0)
43
 
         goto error;
44
 
 
45
 
-    /* New style PV graphics config xen >= 3.0.4,
46
 
-     * or HVM graphics config xen >= 3.0.5 */
47
 
-    if ((xendConfigVersion >= XEND_CONFIG_MIN_VERS_PVFB_NEWCONF && !hvm) ||
48
 
-        (xendConfigVersion >= 4 && hvm)) {
49
 
+    /* New style PV graphics config xen >= 3.0.4 */
50
 
+    if (!hvm && (xendConfigVersion >= XEND_CONFIG_MIN_VERS_PVFB_NEWCONF)) {
51
 
         if ((def->ngraphics == 1) &&
52
 
             xenFormatSxprGraphicsNew(def->graphics[0], &buf) < 0)
53
 
             goto error;