~ubuntu-branches/debian/sid/file-roller/sid

« back to all changes in this revision

Viewing changes to debian/patches/03_tar_xz_update.patch

  • Committer: Package Import Robot
  • Author(s): Michael Biebl, Josselin Mouette, Michael Biebl
  • Date: 2011-10-13 22:43:53 UTC
  • mfrom: (5.1.5 experimental)
  • Revision ID: package-import@ubuntu.com-20111013224353-7fub412oa8jwkcgt
Tags: 3.0.2-2
[ Josselin Mouette ]
* file-roller.mime: dropped. We don’t do necromancy anymore.
* Drop desktop-check-mime-types call too.

[ Michael Biebl ]
* Upload to unstable.
* debian/control.in:
  - Set pkg-gnome-maintainers@lists.alioth.debian.org as Maintainer.
* debian/watch:
  - Switch to .xz tarballs.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From c668bfe6175ed0891dd2a42bfe590a8adf7be8de Mon Sep 17 00:00:00 2001
2
 
From: Paolo Bacchilega <paobac@src.gnome.org>
3
 
Date: Fri, 03 Sep 2010 18:09:04 +0000
4
 
Subject: fixed update of files in .tar.xz archives
5
 
 
6
 
[bug #628717]
7
 
---
8
 
diff --git a/src/fr-command-tar.c b/src/fr-command-tar.c
9
 
index 53ab601..650a197 100644
10
 
--- a/src/fr-command-tar.c
11
 
+++ b/src/fr-command-tar.c
12
 
@@ -769,7 +769,7 @@ get_uncompressed_name (FrCommandTar *c_tar,
13
 
                /* X.tar.xz --> X.tar
14
 
                 * (There doesn't seem to be a shorthand suffix) */
15
 
                if (file_extension_is (e_filename, ".tar.xz"))
16
 
-                       new_name[l - 5] = 0;
17
 
+                       new_name[l - 3] = 0;
18
 
        }
19
 
        else if (is_mime_type (comm->mime_type, "application/x-lzop-compressed-tar")) {
20
 
                /* X.tzo     -->  X.tar
21
 
--
22
 
cgit v0.8.3.1