~ubuntu-branches/ubuntu/hardy/mailman/hardy-updates

« back to all changes in this revision

Viewing changes to debian/patches/61_fix_ru_siteowner.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Martin Pitt
  • Date: 2006-10-30 13:00:30 UTC
  • mfrom: (1.1.2 upstream)
  • Revision ID: james.westby@ubuntu.com-20061030130030-hvz4ipqc82e3wbi6
Tags: 1:2.1.9-2ubuntu1
* Synchronize to Debian; remaining Ubuntu change:
  - debian/control: exim4 -> postfix.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh -e
2
 
## 61_fix_ru_siteowner.dpatch, by L�szl� 'GCS' B�sz�rm�nyi <gcs@lsc.hu>
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: Correct siteowner variable in ru template for newer Mailman versions.
6
 
 
7
 
[ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts
8
 
patch_opts="${patch_opts:--f --no-backup-if-mismatch ${2:+-d $2}}"
9
 
 
10
 
if [ $# -lt 1 ]; then
11
 
    echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
12
 
    exit 1
13
 
fi
14
 
case "$1" in
15
 
    -patch) patch $patch_opts -p1 < $0;;
16
 
    -unpatch) patch $patch_opts -p1 -R < $0;;
17
 
    *)
18
 
        echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
19
 
        exit 1;;
20
 
esac
21
 
 
22
 
exit 0
23
 
@DPATCH@
24
 
diff -urNad pkg-mailman/templates/ru/newlist.txt.orig pkg-mailman/templates/ru/newlist.txt
25
 
--- pkg-mailman/templates/ru/newlist.txt.orig 2004-09-25 18:05:09.000000000 +0000
26
 
+++ pkg-mailman/templates/ru/newlist.txt 2004-09-25 18:05:37.000000000 +0000
27
 
@@ -37,4 +37,4 @@
28
 
 ������������.
29
 
 
30
 
 ��� ������� � ������� �� ������ ������, �������� ������ �� ������
31
 
-mailman-owner@%(hostname)s.
32
 
+    %(siteowner)s.