~ubuntu-branches/ubuntu/hardy/mailman/hardy-updates

« back to all changes in this revision

Viewing changes to debian/patches/80_fix_string_search.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Martin Pitt
  • Date: 2006-10-30 13:00:30 UTC
  • mfrom: (1.1.2 upstream)
  • Revision ID: james.westby@ubuntu.com-20061030130030-hvz4ipqc82e3wbi6
Tags: 1:2.1.9-2ubuntu1
* Synchronize to Debian; remaining Ubuntu change:
  - debian/control: exim4 -> postfix.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## fix_admin.py.dpatch by  <giskard@localhost.localdomain>
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: Debian Bug #359721
6
 
## DP: Improve the search method in the admin page wich list members
7
 
 
8
 
 
9
 
 
10
 
@DPATCH@
11
 
diff -urNad mailman-2.1.8~/Mailman/Cgi/admin.py mailman-2.1.8/Mailman/Cgi/admin.py
12
 
--- mailman-2.1.8~/Mailman/Cgi/admin.py        2006-08-09 21:19:38.000000000 +0200
13
 
+++ mailman-2.1.8/Mailman/Cgi/admin.py 2006-08-09 21:23:01.000000000 +0200
14
 
@@ -944,7 +944,7 @@
15
 
         for letter in digits + lowercase:
16
 
             if not buckets.get(letter):
17
 
                 continue
18
 
-            url = adminurl + '/members?letter=%s' % letter
19
 
+            url = adminurl + '/members?findmember=%s&letter=%s' %(urllib.quote(regexp) ,letter)
20
 
             if letter == bucket:
21
 
                 show = Bold('[%s]' % letter.upper()).Format()
22
 
             else:
23