~ubuntu-branches/ubuntu/intrepid/gparted/intrepid

« back to all changes in this revision

Viewing changes to debian/patches/05_GParted_Core.cc.diff

  • Committer: Bazaar Package Importer
  • Author(s): Alan Baghumian
  • Date: 2008-02-07 09:43:11 UTC
  • mfrom: (1.2.2 upstream)
  • Revision ID: james.westby@ubuntu.com-20080207094311-a87w1vg3tx94ewck
Tags: 0.3.5-1
* New upstream bugfix release (Closes: #451723).
* Dropped 02_fix-build-failure-with-g++-4.3,
  03_fdi_robustification and 04_Win_GParted.cc
  patches, merged upstream
* Updated debian/control:
  - bump standards version to 3.7.3
  - wrapped deps and build-deps
* Added gparted.manpages and gparted.links, (Closes: #460801).
* Refreshed 05_GParted_Core.cc to be applied properly
* Added 06_fix-hal-policy-path patch to fix
  gparted-disable-automount.fdi policy path, thanks
  Sjoerd Simons (Closes: #454977).
* Refreshed 01_fix-desktop.patch to use 01_fix-desktop.patch,
  (Closes: 454050).
* Updated menu file to fix lintian errors.  

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=449546
2
 
 
3
 
--- gparted-0.3.3/src/GParted_Core.cc.old       2007-11-06 03:11:14.000000000 +0000
4
 
+++ gparted-0.3.3/src/GParted_Core.cc   2007-11-06 03:25:38.000000000 +0000
5
 
@@ -1698,7 +1698,7 @@ bool GParted_Core::copy_filesystem( cons
 
1
diff -urpN gparted-0.3.5/src/GParted_Core.cc gparted-0.3.5.new/src/GParted_Core.cc
 
2
--- gparted-0.3.5/src/GParted_Core.cc   2008-02-04 18:05:47.000000000 +0330
 
3
+++ gparted-0.3.5.new/src/GParted_Core.cc       2008-02-05 14:51:30.000000000 +0330
 
4
@@ -1711,7 +1711,7 @@ bool GParted_Core::copy_filesystem( cons
6
5
 
7
6
        while ( succes &&
8
7
                timer .elapsed() <= smallest_time && 
11
10
                optimal_blocksize * 2 < N )
12
11
        {
13
12
                if ( done != 0 ) 
14
 
@@ -1742,7 +1742,7 @@ bool GParted_Core::copy_filesystem( cons
 
13
@@ -1755,7 +1755,7 @@ bool GParted_Core::copy_filesystem( cons
15
14
                                    dst_device,
16
15
                                    src_start + ( dst_start > src_start ? 0 : done ),
17
16
                                    dst_start + ( dst_start > src_start ? 0 : done ),
20
19
                                    optimal_blocksize,
21
20
                                    operationdetail,
22
21
                                    readonly,
23
 
@@ -1916,7 +1916,7 @@ bool GParted_Core::copy_blocks( const Gl
 
22
@@ -1929,7 +1929,7 @@ bool GParted_Core::copy_blocks( const Gl
24
23
        if ( lp_device_src && lp_device_dst && ped_device_open( lp_device_src ) && ped_device_open( lp_device_dst ) )
25
24
        {
26
25
                Glib::ustring error_message ;
29
28
                if ( buf )
30
29
                {
31
30
                        ped_device_sync( lp_device_dst ) ;
32
 
@@ -1937,7 +1937,7 @@ bool GParted_Core::copy_blocks( const Gl
 
31
@@ -1950,7 +1950,7 @@ bool GParted_Core::copy_blocks( const Gl
33
32
                        operationdetail .get_last_child() .add_child( OperationDetail( "", STATUS_NONE ) ) ;
34
33
                        
35
34
                        Glib::Timer timer_progress_timeout, timer_total ;
38
37
                        {
39
38
                                succes = copy_block( lp_device_src,
40
39
                                                     lp_device_dst,
41
 
@@ -1952,7 +1952,7 @@ bool GParted_Core::copy_blocks( const Gl
 
40
@@ -1965,7 +1965,7 @@ bool GParted_Core::copy_blocks( const Gl
42
41
                                if ( timer_progress_timeout .elapsed() >= 0.5 )
43
42
                                {
44
43
                                        set_progress_info( length,
47
46
                                                           timer_total,
48
47
                                                           operationdetail .get_last_child() .get_last_child(),
49
48
                                                           readonly ) ;
50
 
@@ -1971,13 +1971,13 @@ bool GParted_Core::copy_blocks( const Gl
 
49
@@ -1984,13 +1984,13 @@ bool GParted_Core::copy_blocks( const Gl
51
50
 
52
51
                //final description
53
52
                operationdetail .get_last_child() .get_last_child() .set_description( 
63
62
        
64
63
                //close and destroy the devices..
65
64
                ped_device_close( lp_device_src ) ;
66
 
@@ -2004,7 +2004,7 @@ bool GParted_Core::copy_block( PedDevice
 
65
@@ -2017,7 +2017,7 @@ bool GParted_Core::copy_block( PedDevice
67
66
 {
68
67
        if ( blocksize < 0 )
69
68
        {