~ubuntu-branches/ubuntu/precise/mutt/precise

« back to all changes in this revision

Viewing changes to debian/patches/features/compressed-folders

  • Committer: Bazaar Package Importer
  • Author(s): Christoph Berg, Adeodato Simó, Christoph Berg
  • Date: 2007-11-03 23:00:04 UTC
  • mfrom: (1.1.7 upstream)
  • Revision ID: james.westby@ubuntu.com-20071103230004-43e36pnhub87junc
Tags: 1.5.17-1
[ Adeodato Simó ]
* Move the packaging back to Bazaar, adjust X-VCS-* accordingly.

[ Christoph Berg ]
* Mention libsasl2-modules-gssapi-mit in README.Debian. (Closes: #433425)
* Call autoreconf at build time, drop the autotools-update patch.
* Update menu file, add lintian override file.
* Refresh patches.

* New upstream version:
  + fix segfaults with single byte 8-bit characters in index_format.
    (Closes: #420598, Mutt: #2882)
  + properly render subject headers with encoded linefeeds.
    (Closes: #264014, Mutt: #1810)
  + only calls gnutls_error_is_fatal when gnutls_record_recv returns a
    negative value. (Closes: #439775, Mutt: #2954)
  + Large file support for mutt_pretty_size().
    (Closes: #352478, #416555, Mutt: #2191)
  + Do not consider empty pipes for filtering in format strings.
    (Closes: #447340)

Show diffs side-by-side

added added

removed removed

Lines of Context:
14
14
  - 2007-06-14 myon: remove hunks for Muttrc*
15
15
 
16
16
== END PATCH
17
 
Index: debian-mutt/compress.c
18
 
===================================================================
19
 
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
20
 
+++ debian-mutt/compress.c      2007-06-14 10:57:02.000000000 +0200
 
17
--- /dev/null
 
18
+++ b/compress.c
21
19
@@ -0,0 +1,499 @@
22
20
+/*
23
21
+ * Copyright (C) 1997 Alain Penders <Alain@Finale-Dev.com>
518
516
+}
519
517
+
520
518
+#endif /* USE_COMPRESSED */
521
 
Index: debian-mutt/compress.h
522
 
===================================================================
523
 
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
524
 
+++ debian-mutt/compress.h      2007-06-14 10:57:02.000000000 +0200
 
519
--- /dev/null
 
520
+++ b/compress.h
525
521
@@ -0,0 +1,27 @@
526
522
+/*
527
523
+ * Copyright (C) 1997 Alain Penders <Alain@Finale-Dev.com>
550
546
+int mutt_test_compress_command (const char *);
551
547
+int mutt_check_mailbox_compressed (CONTEXT *);
552
548
+void mutt_fast_close_compressed (CONTEXT *);
553
 
Index: debian-mutt/config.h.in
554
 
===================================================================
555
 
--- debian-mutt.orig/config.h.in        2007-06-14 10:54:19.000000000 +0200
556
 
+++ debian-mutt/config.h.in     2007-06-14 10:57:02.000000000 +0200
557
 
@@ -513,6 +513,9 @@
558
 
 /* Define to enable Sun mailtool attachments support. */
559
 
 #undef SUN_ATTACHMENT
560
 
 
561
 
+/* Define to enable compressed mailboxes support */
562
 
+#undef USE_COMPRESSED
563
 
+
564
 
 /* Define to use dotlocking for mailboxes. */
565
 
 #undef USE_DOTLOCK
566
 
 
567
 
Index: debian-mutt/configure
568
 
===================================================================
569
 
--- debian-mutt.orig/configure  2007-06-14 10:54:19.000000000 +0200
570
 
+++ debian-mutt/configure       2007-06-14 10:57:02.000000000 +0200
571
 
@@ -1371,6 +1371,7 @@ Optional Features:
572
 
   --enable-hcache         Enable header caching
573
 
   --disable-iconv         Disable iconv support
574
 
   --disable-nls           Do not use Native Language Support
575
 
+  --enable-compressed     Enable compressed folders support
576
 
 
577
 
 Optional Packages:
578
 
   --with-PACKAGE[=ARG]    use PACKAGE [ARG=yes]
579
 
@@ -15105,6 +15106,17 @@ _ACEOF
580
 
 fi
581
 
 
582
 
 
583
 
+# Check whether --enable-compressed or --disable-compressed was given.
584
 
+if test "${enable_compressed+set}" = set; then
585
 
+  enableval="$enable_compressed"; if test x$enableval = xyes; then
586
 
+
587
 
+cat >>confdefs.h <<\_ACEOF
588
 
+#define USE_COMPRESSED 1
589
 
+_ACEOF
590
 
+
591
 
+        fi
592
 
+fi
593
 
+
594
 
 
595
 
 # Check whether --with-exec-shell was given.
596
 
 if test "${with_exec_shell+set}" = set; then
597
 
Index: debian-mutt/configure.ac
598
 
===================================================================
599
 
--- debian-mutt.orig/configure.ac       2007-06-14 10:54:19.000000000 +0200
600
 
+++ debian-mutt/configure.ac    2007-06-14 10:57:02.000000000 +0200
601
 
@@ -785,6 +785,11 @@ AC_ARG_ENABLE(locales-fix, AC_HELP_STRIN
 
549
--- a/configure.ac
 
550
+++ b/configure.ac
 
551
@@ -792,6 +792,11 @@ AC_ARG_ENABLE(locales-fix, AC_HELP_STRIN
602
552
                 AC_DEFINE(LOCALES_HACK,1,[ Define if the result of isprint() is unreliable. ])
603
553
         fi])
604
554
 
610
560
 AC_ARG_WITH(exec-shell, AC_HELP_STRING([--with-exec-shell=SHELL], [Specify alternate shell (ONLY if /bin/sh is broken)]),
611
561
         [if test $withval != yes; then
612
562
                 AC_DEFINE_UNQUOTED(EXECSHELL, "$withval",
613
 
Index: debian-mutt/curs_main.c
614
 
===================================================================
615
 
--- debian-mutt.orig/curs_main.c        2007-06-14 10:54:19.000000000 +0200
616
 
+++ debian-mutt/curs_main.c     2007-06-14 10:57:02.000000000 +0200
617
 
@@ -1111,6 +1111,11 @@ int mutt_index_menu (void)
 
563
--- a/curs_main.c
 
564
+++ b/curs_main.c
 
565
@@ -1131,6 +1131,11 @@ int mutt_index_menu (void)
618
566
         {
619
567
          int check;
620
568
 
626
574
          mutt_str_replace (&LastFolder, Context->path);
627
575
          oldcount = Context ? Context->msgcount : 0;
628
576
 
629
 
Index: debian-mutt/doc/manual.xml.head
630
 
===================================================================
631
 
--- debian-mutt.orig/doc/manual.xml.head        2007-06-14 10:54:19.000000000 +0200
632
 
+++ debian-mutt/doc/manual.xml.head     2007-06-14 10:57:02.000000000 +0200
633
 
@@ -4910,6 +4910,205 @@ becomes an issue as mutt will silently f
 
577
--- a/doc/manual.xml.head
 
578
+++ b/doc/manual.xml.head
 
579
@@ -4676,6 +4676,205 @@ macro pager \cb |urlview\n
634
580
 
635
581
 </chapter>
636
582
 
836
782
 <chapter id="mimesupport">
837
783
 <title>Mutt's MIME Support</title>
838
784
 
839
 
Index: debian-mutt/doc/muttrc.man.head
840
 
===================================================================
841
 
--- debian-mutt.orig/doc/muttrc.man.head        2007-06-14 10:54:19.000000000 +0200
842
 
+++ debian-mutt/doc/muttrc.man.head     2007-06-14 10:57:02.000000000 +0200
 
785
--- a/doc/muttrc.man.head
 
786
+++ b/doc/muttrc.man.head
843
787
@@ -345,6 +345,24 @@ specify the ID of the public key to be u
844
788
 to a certain recipient.  The meaning of "key ID" is to be taken
845
789
 broadly: This can be a different e-mail address, a numerical key ID,
865
809
 .TP
866
810
 \fBpush\fP \fIstring\fP
867
811
 This command adds the named \fIstring\fP to the keyboard buffer.
868
 
Index: debian-mutt/hook.c
869
 
===================================================================
870
 
--- debian-mutt.orig/hook.c     2007-06-14 10:54:19.000000000 +0200
871
 
+++ debian-mutt/hook.c  2007-06-14 10:57:02.000000000 +0200
 
812
--- a/hook.c
 
813
+++ b/hook.c
872
814
@@ -24,6 +24,10 @@
873
815
 #include "mailbox.h"
874
816
 #include "mutt_crypt.h"
897
839
   else if (DefaultHook && !(data & (M_CHARSETHOOK | M_ICONVHOOK | M_ACCOUNTHOOK))
898
840
            && (!WithCrypto || !(data & M_CRYPTHOOK))
899
841
       )
900
 
Index: debian-mutt/init.h
901
 
===================================================================
902
 
--- debian-mutt.orig/init.h     2007-06-14 10:54:19.000000000 +0200
903
 
+++ debian-mutt/init.h  2007-06-14 10:57:02.000000000 +0200
904
 
@@ -3129,6 +3129,11 @@ struct command_t Commands[] = {
 
842
--- a/init.h
 
843
+++ b/init.h
 
844
@@ -3210,6 +3210,11 @@ struct command_t Commands[] = {
905
845
   { "fcc-hook",                mutt_parse_hook,        M_FCCHOOK },
906
846
   { "fcc-save-hook",   mutt_parse_hook,        M_FCCHOOK | M_SAVEHOOK },
907
847
   { "folder-hook",     mutt_parse_hook,        M_FOLDERHOOK },
913
853
   { "group",           parse_group,            0 },
914
854
   { "ungroup",         parse_ungroup,          0 },
915
855
   { "hdr_order",       parse_list,             UL &HeaderOrderList },
916
 
Index: debian-mutt/main.c
917
 
===================================================================
918
 
--- debian-mutt.orig/main.c     2007-06-14 10:54:19.000000000 +0200
919
 
+++ debian-mutt/main.c  2007-06-14 10:57:02.000000000 +0200
920
 
@@ -401,6 +401,12 @@ static void show_version (void)
 
856
--- a/main.c
 
857
+++ b/main.c
 
858
@@ -409,6 +409,12 @@ static void show_version (void)
921
859
 #else
922
860
        "-LOCALES_HACK  "
923
861
 #endif
930
868
              
931
869
 #ifdef HAVE_WC_FUNCS
932
870
        "+HAVE_WC_FUNCS  "
933
 
Index: debian-mutt/Makefile.am
934
 
===================================================================
935
 
--- debian-mutt.orig/Makefile.am        2007-06-14 10:54:19.000000000 +0200
936
 
+++ debian-mutt/Makefile.am     2007-06-14 10:57:02.000000000 +0200
 
871
--- a/Makefile.am
 
872
+++ b/Makefile.am
937
873
@@ -18,7 +18,7 @@ BUILT_SOURCES = keymap_defs.h patchlist.
938
874
 bin_PROGRAMS = mutt @DOTLOCK_TARGET@ @PGPAUX_TARGET@
939
875
 mutt_SOURCES = $(BUILT_SOURCES) \
943
879
        commands.c complete.c compose.c copy.c curs_lib.c curs_main.c date.c \
944
880
        edit.c enter.c flags.c init.c filter.c from.c \
945
881
        getdomain.c group.c \
946
 
@@ -66,7 +66,7 @@ EXTRA_mutt_SOURCES = account.c md5c.c mu
947
 
        utf8.c wcwidth.c 
948
 
 
949
 
 EXTRA_DIST = COPYRIGHT GPL OPS OPS.PGP OPS.CRYPT OPS.SMIME TODO UPDATING \
950
 
-       configure account.h \
951
 
+       configure account.h compress.h \
952
 
        attach.h buffy.h charset.h copy.h crypthash.h dotlock.h functions.h gen_defs \
953
 
        globals.h hash.h history.h init.h keymap.h mutt_crypt.h \
954
 
        mailbox.h mapping.h md5.h mime.h mutt.h mutt_curses.h mutt_menu.h \
955
 
Index: debian-mutt/Makefile.in
956
 
===================================================================
957
 
--- debian-mutt.orig/Makefile.in        2007-06-14 10:54:19.000000000 +0200
958
 
+++ debian-mutt/Makefile.in     2007-06-14 10:57:02.000000000 +0200
959
 
@@ -74,7 +74,7 @@ am_mutt_OBJECTS = $(am__objects_1) addrb
960
 
        attach.$(OBJEXT) base64.$(OBJEXT) browser.$(OBJEXT) \
961
 
        buffy.$(OBJEXT) color.$(OBJEXT) crypt.$(OBJEXT) \
962
 
        cryptglue.$(OBJEXT) commands.$(OBJEXT) complete.$(OBJEXT) \
963
 
-       compose.$(OBJEXT) copy.$(OBJEXT) curs_lib.$(OBJEXT) \
964
 
+       compose.$(OBJEXT) compress.$(OBJEXT) copy.$(OBJEXT) curs_lib.$(OBJEXT) \
965
 
        curs_main.$(OBJEXT) date.$(OBJEXT) edit.$(OBJEXT) \
966
 
        enter.$(OBJEXT) flags.$(OBJEXT) init.$(OBJEXT) \
967
 
        filter.$(OBJEXT) from.$(OBJEXT) getdomain.$(OBJEXT) \
968
 
@@ -302,7 +302,7 @@ bin_SCRIPTS = muttbug flea @SMIMEAUX_TAR
969
 
 BUILT_SOURCES = keymap_defs.h patchlist.c reldate.h hcversion.h
970
 
 mutt_SOURCES = $(BUILT_SOURCES) \
971
 
        addrbook.c alias.c attach.c base64.c browser.c buffy.c color.c \
972
 
-       crypt.c cryptglue.c \
973
 
+       crypt.c cryptglue.c compress.c \
974
 
        commands.c complete.c compose.c copy.c curs_lib.c curs_main.c date.c \
975
 
        edit.c enter.c flags.c init.c filter.c from.c \
976
 
        getdomain.c group.c \
977
 
@@ -335,7 +335,7 @@ EXTRA_mutt_SOURCES = account.c md5c.c mu
978
 
        utf8.c wcwidth.c 
979
 
 
980
 
 EXTRA_DIST = COPYRIGHT GPL OPS OPS.PGP OPS.CRYPT OPS.SMIME TODO UPDATING \
981
 
-       configure account.h \
982
 
+       configure account.h compress.h \
983
 
        attach.h buffy.h charset.h copy.h crypthash.h dotlock.h functions.h gen_defs \
984
 
        globals.h hash.h history.h init.h keymap.h mutt_crypt.h \
985
 
        mailbox.h mapping.h md5.h mime.h mutt.h mutt_curses.h mutt_menu.h \
986
 
@@ -507,6 +507,7 @@ distclean-compile:
987
 
 @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/commands.Po@am__quote@
988
 
 @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/complete.Po@am__quote@
989
 
 @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/compose.Po@am__quote@
990
 
+@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/compress.Po@am__quote@
991
 
 @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/copy.Po@am__quote@
992
 
 @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/crypt-gpgme.Po@am__quote@
993
 
 @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/crypt-mod-pgp-classic.Po@am__quote@
994
 
Index: debian-mutt/mbox.c
995
 
===================================================================
996
 
--- debian-mutt.orig/mbox.c     2007-06-14 10:54:19.000000000 +0200
997
 
+++ debian-mutt/mbox.c  2007-06-14 10:57:02.000000000 +0200
 
882
@@ -66,7 +66,7 @@ EXTRA_mutt_SOURCES = account.c md5.c mut
 
883
        utf8.c wcwidth.c 
 
884
 
 
885
 EXTRA_DIST = COPYRIGHT GPL OPS OPS.PGP OPS.CRYPT OPS.SMIME TODO UPDATING \
 
886
-       configure account.h \
 
887
+       configure account.h compress.h \
 
888
        attach.h buffy.h charset.h copy.h crypthash.h dotlock.h functions.h gen_defs \
 
889
        globals.h hash.h history.h init.h keymap.h mutt_crypt.h \
 
890
        mailbox.h mapping.h md5.h mime.h mutt.h mutt_curses.h mutt_menu.h \
 
891
--- a/mbox.c
 
892
+++ b/mbox.c
998
893
@@ -29,6 +29,10 @@
999
894
 #include "copy.h"
1000
895
 #include "mutt_curses.h"
1019
914
   mutt_unblock_signals ();
1020
915
   mx_fastclose_mailbox (ctx);
1021
916
   return 0;
1022
 
Index: debian-mutt/mutt.h
1023
 
===================================================================
1024
 
--- debian-mutt.orig/mutt.h     2007-06-14 10:54:19.000000000 +0200
1025
 
+++ debian-mutt/mutt.h  2007-06-14 10:57:02.000000000 +0200
 
917
--- a/mutt.h
 
918
+++ b/mutt.h
1026
919
@@ -160,6 +160,11 @@ typedef enum
1027
920
 #define M_ACCOUNTHOOK  (1<<9)
1028
921
 #define M_REPLYHOOK    (1<<10)
1035
928
 
1036
929
 /* tree characters for linearize_tree and print_enriched_string */
1037
930
 #define M_TREE_LLCORNER                1
1038
 
@@ -885,6 +890,11 @@ typedef struct _context
 
931
@@ -892,6 +897,11 @@ typedef struct _context
1039
932
   int flagged;                 /* how many flagged messages */
1040
933
   int msgnotreadyet;           /* which msg "new" in pager, -1 if none */
1041
934
 
1047
940
   short magic;                 /* mailbox type */
1048
941
 
1049
942
   unsigned char rights[(RIGHTSMAX + 7)/8];     /* ACL bits */
1050
 
Index: debian-mutt/mx.c
1051
 
===================================================================
1052
 
--- debian-mutt.orig/mx.c       2007-06-14 10:54:19.000000000 +0200
1053
 
+++ debian-mutt/mx.c    2007-06-14 10:57:02.000000000 +0200
 
943
--- a/mx.c
 
944
+++ b/mx.c
1054
945
@@ -30,6 +30,10 @@
1055
946
 #include "keymap.h"
1056
947
 #include "url.h"
1062
953
 #ifdef USE_IMAP
1063
954
 #include "imap.h"
1064
955
 #endif
1065
 
@@ -450,6 +454,10 @@ int mx_get_magic (const char *path)
 
956
@@ -445,6 +449,10 @@ int mx_get_magic (const char *path)
1066
957
     return (-1);
1067
958
   }
1068
959
 
1073
964
   return (magic);
1074
965
 }
1075
966
 
1076
 
@@ -489,6 +497,13 @@ static int mx_open_mailbox_append (CONTE
 
967
@@ -484,6 +492,13 @@ static int mx_open_mailbox_append (CONTE
1077
968
 {
1078
969
   struct stat sb;
1079
970
 
1087
978
   ctx->append = 1;
1088
979
 
1089
980
 #ifdef USE_IMAP
1090
 
@@ -652,7 +667,12 @@ CONTEXT *mx_open_mailbox (const char *pa
 
981
@@ -647,7 +662,12 @@ CONTEXT *mx_open_mailbox (const char *pa
1091
982
   }
1092
983
 
1093
984
   ctx->magic = mx_get_magic (path);
1101
992
   if(ctx->magic == 0)
1102
993
     mutt_error (_("%s is not a mailbox."), path);
1103
994
 
1104
 
@@ -753,6 +773,10 @@ void mx_fastclose_mailbox (CONTEXT *ctx)
 
995
@@ -748,6 +768,10 @@ void mx_fastclose_mailbox (CONTEXT *ctx)
1105
996
     mutt_free_header (&ctx->hdrs[i]);
1106
997
   FREE (&ctx->hdrs);
1107
998
   FREE (&ctx->v2r);
1112
1003
   FREE (&ctx->path);
1113
1004
   FREE (&ctx->pattern);
1114
1005
   if (ctx->limit_pattern) 
1115
 
@@ -805,6 +829,12 @@ static int sync_mailbox (CONTEXT *ctx, i
 
1006
@@ -800,6 +824,12 @@ static int sync_mailbox (CONTEXT *ctx, i
1116
1007
   
1117
1008
   if (tmp && tmp->new == 0)
1118
1009
     mutt_update_mailbox (tmp);
1125
1016
   return rc;
1126
1017
 }
1127
1018
 
1128
 
@@ -1006,6 +1036,11 @@ int mx_close_mailbox (CONTEXT *ctx, int 
 
1019
@@ -1058,6 +1088,11 @@ int mx_close_mailbox (CONTEXT *ctx, int 
1129
1020
       !mutt_is_spool(ctx->path) && !option (OPTSAVEEMPTY))
1130
1021
     mx_unlink_empty (ctx->path);
1131
1022
 
1137
1028
   mx_fastclose_mailbox (ctx);
1138
1029
 
1139
1030
   return 0;
1140
 
@@ -1315,6 +1350,11 @@ int mx_check_mailbox (CONTEXT *ctx, int 
 
1031
@@ -1373,6 +1408,11 @@ int mx_check_mailbox (CONTEXT *ctx, int 
1141
1032
 {
1142
1033
   int rc;
1143
1034
 
1149
1040
   if (ctx)
1150
1041
   {
1151
1042
     if (ctx->locked) lock = 0;
1152
 
Index: debian-mutt/mx.h
1153
 
===================================================================
1154
 
--- debian-mutt.orig/mx.h       2007-06-14 10:54:19.000000000 +0200
1155
 
+++ debian-mutt/mx.h    2007-06-14 10:57:02.000000000 +0200
 
1043
--- a/mx.h
 
1044
+++ b/mx.h
1156
1045
@@ -40,6 +40,9 @@ enum
1157
1046
 #ifdef USE_POP
1158
1047
   , M_POP
1163
1052
 };
1164
1053
 
1165
1054
 WHERE short DefaultMagic INITVAL (M_MBOX);
1166
 
Index: debian-mutt/PATCHES
1167
 
===================================================================
1168
 
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
1169
 
+++ debian-mutt/PATCHES 2007-06-14 10:57:02.000000000 +0200
1170
 
@@ -0,0 +1 @@
1171
 
+patch-1.5.16.rr.compressed.1
1172
 
Index: debian-mutt/po/de.po
1173
 
===================================================================
1174
 
--- debian-mutt.orig/po/de.po   2007-06-14 10:54:19.000000000 +0200
1175
 
+++ debian-mutt/po/de.po        2007-06-14 10:57:02.000000000 +0200
 
1055
--- a/po/de.po
 
1056
+++ b/po/de.po
1176
1057
@@ -1279,6 +1279,48 @@ msgstr "Pr�fung des Absenders fehlgeschl
1177
1058
 msgid "Failed to figure out sender"
1178
1059
 msgstr "Kann Absender nicht ermitteln"
1233
1114
 #: hook.c:251
1234
1115
 #, c-format
1235
1116
 msgid "unhook: Can't do unhook * from within a hook."
1236
 
@@ -3452,18 +3498,10 @@ msgstr "Lese %s..."
 
1117
@@ -3463,18 +3509,10 @@ msgstr "Lese %s..."
1237
1118
 msgid "Mailbox is corrupt!"
1238
1119
 msgstr "Mailbox fehlerhaft!"
1239
1120
 
1252
1133
 #. this means ctx->changed or ctx->deleted was set, but no
1253
1134
 #. * messages were found to be changed or deleted.  This should
1254
1135
 #. * never happen, is we presume it is a bug in mutt.
1255
 
Index: debian-mutt/po/POTFILES.in
1256
 
===================================================================
1257
 
--- debian-mutt.orig/po/POTFILES.in     2007-06-14 10:54:19.000000000 +0200
1258
 
+++ debian-mutt/po/POTFILES.in  2007-06-14 10:57:02.000000000 +0200
 
1136
--- a/po/POTFILES.in
 
1137
+++ b/po/POTFILES.in
1259
1138
@@ -8,6 +8,7 @@ charset.c
1260
1139
 color.c
1261
1140
 commands.c
1264
1143
 crypt-gpgme.c
1265
1144
 crypt.c
1266
1145
 cryptglue.c
1267
 
Index: debian-mutt/status.c
1268
 
===================================================================
1269
 
--- debian-mutt.orig/status.c   2007-06-14 10:54:19.000000000 +0200
1270
 
+++ debian-mutt/status.c        2007-06-14 10:57:02.000000000 +0200
 
1146
--- a/status.c
 
1147
+++ b/status.c
1271
1148
@@ -99,6 +99,14 @@ status_format_str (char *buf, size_t buf
1272
1149
 
1273
1150
     case 'f':