~ubuntu-branches/ubuntu/precise/stellarium/precise

« back to all changes in this revision

Viewing changes to debian/patches/gettext

  • Committer: Bazaar Package Importer
  • Author(s): Cédric Delfosse
  • Date: 2008-05-19 21:28:23 UTC
  • mfrom: (3.1.5 intrepid)
  • Revision ID: james.westby@ubuntu.com-20080519212823-m5nfiuntxstxzxj7
Tags: 0.9.1-4
Add libxcursor-dev, libxfixes-dev, libxinerama-dev, libqt4-opengl-dev to
build-deps (Closes: #479906)

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Index: stellarium-0.9.0/po/Makefile.in.in
 
2
===================================================================
 
3
--- stellarium-0.9.0.orig/po/Makefile.in.in     2007-06-25 21:30:43.772725500 +0200
 
4
+++ stellarium-0.9.0/po/Makefile.in.in  2007-06-25 21:30:51.977238250 +0200
 
5
@@ -1,5 +1,5 @@
 
6
 # Makefile for PO directory in any package using GNU gettext.
 
7
-# Copyright (C) 1995-1997, 2000-2004 by Ulrich Drepper <drepper@gnu.ai.mit.edu>
 
8
+# Copyright (C) 1995-1997, 2000-2006 by Ulrich Drepper <drepper@gnu.ai.mit.edu>
 
9
 #
 
10
 # This file can be copied and used freely without restrictions.  It can
 
11
 # be used in projects which are not available under the GNU General Public
 
12
@@ -8,10 +8,11 @@
 
13
 # Please note that the actual code of GNU gettext is covered by the GNU
 
14
 # General Public License and is *not* in the public domain.
 
15
 #
 
16
-# Origin: gettext-0.14
 
17
+# Origin: gettext-0.16
 
18
 
 
19
 PACKAGE = @PACKAGE@
 
20
 VERSION = @VERSION@
 
21
+PACKAGE_BUGREPORT = @PACKAGE_BUGREPORT@
 
22
 
 
23
 SHELL = /bin/sh
 
24
 @SET_MAKE@
 
25
@@ -22,18 +23,38 @@
 
26
 
 
27
 prefix = @prefix@
 
28
 exec_prefix = @exec_prefix@
 
29
+datarootdir = @datarootdir@
 
30
 datadir = @datadir@
 
31
-localedir = $(datadir)/locale
 
32
+localedir = @localedir@
 
33
 gettextsrcdir = $(datadir)/gettext/po
 
34
 
 
35
 INSTALL = @INSTALL@
 
36
 INSTALL_DATA = @INSTALL_DATA@
 
37
-MKINSTALLDIRS = @MKINSTALLDIRS@
 
38
-mkinstalldirs = $(SHELL) $(MKINSTALLDIRS)
 
39
 
 
40
-GMSGFMT = @GMSGFMT@
 
41
-MSGFMT = @MSGFMT@
 
42
-XGETTEXT = @XGETTEXT@
 
43
+# We use $(mkdir_p).
 
44
+# In automake <= 1.9.x, $(mkdir_p) is defined either as "mkdir -p --" or as
 
45
+# "$(mkinstalldirs)" or as "$(install_sh) -d". For these automake versions,
 
46
+# @install_sh@ does not start with $(SHELL), so we add it.
 
47
+# In automake >= 1.10, @mkdir_p@ is derived from ${MKDIR_P}, which is defined
 
48
+# either as "/path/to/mkdir -p" or ".../install-sh -c -d". For these automake
 
49
+# versions, $(mkinstalldirs) and $(install_sh) are unused.
 
50
+mkinstalldirs = $(SHELL) @install_sh@ -d
 
51
+install_sh = $(SHELL) @install_sh@
 
52
+MKDIR_P = @MKDIR_P@
 
53
+mkdir_p = @mkdir_p@
 
54
+
 
55
+GMSGFMT_ = @GMSGFMT@
 
56
+GMSGFMT_no = @GMSGFMT@
 
57
+GMSGFMT_yes = @GMSGFMT_015@
 
58
+GMSGFMT = $(GMSGFMT_$(USE_MSGCTXT))
 
59
+MSGFMT_ = @MSGFMT@
 
60
+MSGFMT_no = @MSGFMT@
 
61
+MSGFMT_yes = @MSGFMT_015@
 
62
+MSGFMT = $(MSGFMT_$(USE_MSGCTXT))
 
63
+XGETTEXT_ = @XGETTEXT@
 
64
+XGETTEXT_no = @XGETTEXT@
 
65
+XGETTEXT_yes = @XGETTEXT_015@
 
66
+XGETTEXT = $(XGETTEXT_$(USE_MSGCTXT))
 
67
 MSGMERGE = msgmerge
 
68
 MSGMERGE_UPDATE = @MSGMERGE@ --update
 
69
 MSGINIT = msginit
 
70
@@ -46,7 +67,7 @@
 
71
 DUMMYPOFILES = @DUMMYPOFILES@
 
72
 DISTFILES.common = Makefile.in.in remove-potcdate.sin \
 
73
 $(DISTFILES.common.extra1) $(DISTFILES.common.extra2) $(DISTFILES.common.extra3)
 
74
-DISTFILES = $(DISTFILES.common) Makevars POTFILES.in $(DOMAIN).pot stamp-po \
 
75
+DISTFILES = $(DISTFILES.common) Makevars POTFILES.in \
 
76
 $(POFILES) $(GMOFILES) \
 
77
 $(DISTFILES.extra1) $(DISTFILES.extra2) $(DISTFILES.extra3)
 
78
 
 
79
@@ -79,6 +100,12 @@
 
80
 all-yes: stamp-po
 
81
 all-no:
 
82
 
 
83
+# $(srcdir)/$(DOMAIN).pot is only created when needed. When xgettext finds no
 
84
+# internationalized messages, no $(srcdir)/$(DOMAIN).pot is created (because
 
85
+# we don't want to bother translators with empty POT files). We assume that
 
86
+# LINGUAS is empty in this case, i.e. $(POFILES) and $(GMOFILES) are empty.
 
87
+# In this case, stamp-po is a nop (i.e. a phony target).
 
88
+
 
89
 # stamp-po is a timestamp denoting the last time at which the CATALOGS have
 
90
 # been loosely updated. Its purpose is that when a developer or translator
 
91
 # checks out the package via CVS, and the $(DOMAIN).pot file is not in CVS,
 
92
@@ -88,10 +115,13 @@
 
93
 # $(POFILES) has been designed to not touch files that don't need to be
 
94
 # changed.
 
95
 stamp-po: $(srcdir)/$(DOMAIN).pot
 
96
-       test -z "$(GMOFILES)" || $(MAKE) $(GMOFILES)
 
97
-       @echo "touch stamp-po"
 
98
-       @echo timestamp > stamp-poT
 
99
-       @mv stamp-poT stamp-po
 
100
+       test ! -f $(srcdir)/$(DOMAIN).pot || \
 
101
+         test -z "$(GMOFILES)" || $(MAKE) $(GMOFILES)
 
102
+       @test ! -f $(srcdir)/$(DOMAIN).pot || { \
 
103
+         echo "touch stamp-po" && \
 
104
+         echo timestamp > stamp-poT && \
 
105
+         mv stamp-poT stamp-po; \
 
106
+       }
 
107
 
 
108
 # Note: Target 'all' must not depend on target '$(DOMAIN).pot-update',
 
109
 # otherwise packages like GCC can not be built if only parts of the source
 
110
@@ -100,11 +130,16 @@
 
111
 # This target rebuilds $(DOMAIN).pot; it is an expensive operation.
 
112
 # Note that $(DOMAIN).pot is not touched if it doesn't need to be changed.
 
113
 $(DOMAIN).pot-update: $(POTFILES) $(srcdir)/POTFILES.in remove-potcdate.sed
 
114
+       if test -n '$(MSGID_BUGS_ADDRESS)' || test '$(PACKAGE_BUGREPORT)' = '@'PACKAGE_BUGREPORT'@'; then \
 
115
+         msgid_bugs_address='$(MSGID_BUGS_ADDRESS)'; \
 
116
+       else \
 
117
+         msgid_bugs_address='$(PACKAGE_BUGREPORT)'; \
 
118
+       fi; \
 
119
        $(XGETTEXT) --default-domain=$(DOMAIN) --directory=$(top_srcdir) \
 
120
          --add-comments=TRANSLATORS: $(XGETTEXT_OPTIONS) \
 
121
          --files-from=$(srcdir)/POTFILES.in \
 
122
          --copyright-holder='$(COPYRIGHT_HOLDER)' \
 
123
-         --msgid-bugs-address='$(MSGID_BUGS_ADDRESS)'
 
124
+         --msgid-bugs-address="$$msgid_bugs_address"
 
125
        test ! -f $(DOMAIN).po || { \
 
126
          if test -f $(srcdir)/$(DOMAIN).pot; then \
 
127
            sed -f remove-potcdate.sed < $(srcdir)/$(DOMAIN).pot > $(DOMAIN).1po && \
 
128
@@ -143,7 +178,7 @@
 
129
 install-exec:
 
130
 install-data: install-data-@USE_NLS@
 
131
        if test "$(PACKAGE)" = "gettext-tools"; then \
 
132
-         $(mkinstalldirs) $(DESTDIR)$(gettextsrcdir); \
 
133
+         $(mkdir_p) $(DESTDIR)$(gettextsrcdir); \
 
134
          for file in $(DISTFILES.common) Makevars.template; do \
 
135
            $(INSTALL_DATA) $(srcdir)/$$file \
 
136
                            $(DESTDIR)$(gettextsrcdir)/$$file; \
 
137
@@ -156,13 +191,13 @@
 
138
        fi
 
139
 install-data-no: all
 
140
 install-data-yes: all
 
141
-       $(mkinstalldirs) $(DESTDIR)$(datadir)
 
142
+       $(mkdir_p) $(DESTDIR)$(datadir)
 
143
        @catalogs='$(CATALOGS)'; \
 
144
        for cat in $$catalogs; do \
 
145
          cat=`basename $$cat`; \
 
146
          lang=`echo $$cat | sed -e 's/\.gmo$$//'`; \
 
147
          dir=$(localedir)/$$lang/LC_MESSAGES; \
 
148
-         $(mkinstalldirs) $(DESTDIR)$$dir; \
 
149
+         $(mkdir_p) $(DESTDIR)$$dir; \
 
150
          if test -r $$cat; then realcat=$$cat; else realcat=$(srcdir)/$$cat; fi; \
 
151
          $(INSTALL_DATA) $$realcat $(DESTDIR)$$dir/$(DOMAIN).mo; \
 
152
          echo "installing $$realcat as $(DESTDIR)$$dir/$(DOMAIN).mo"; \
 
153
@@ -202,19 +237,19 @@
 
154
 installdirs-exec:
 
155
 installdirs-data: installdirs-data-@USE_NLS@
 
156
        if test "$(PACKAGE)" = "gettext-tools"; then \
 
157
-         $(mkinstalldirs) $(DESTDIR)$(gettextsrcdir); \
 
158
+         $(mkdir_p) $(DESTDIR)$(gettextsrcdir); \
 
159
        else \
 
160
          : ; \
 
161
        fi
 
162
 installdirs-data-no:
 
163
 installdirs-data-yes:
 
164
-       $(mkinstalldirs) $(DESTDIR)$(datadir)
 
165
+       $(mkdir_p) $(DESTDIR)$(datadir)
 
166
        @catalogs='$(CATALOGS)'; \
 
167
        for cat in $$catalogs; do \
 
168
          cat=`basename $$cat`; \
 
169
          lang=`echo $$cat | sed -e 's/\.gmo$$//'`; \
 
170
          dir=$(localedir)/$$lang/LC_MESSAGES; \
 
171
-         $(mkinstalldirs) $(DESTDIR)$$dir; \
 
172
+         $(mkdir_p) $(DESTDIR)$$dir; \
 
173
          for lc in '' $(EXTRA_LOCALE_CATEGORIES); do \
 
174
            if test -n "$$lc"; then \
 
175
              if (cd $(DESTDIR)$(localedir)/$$lang && LC_ALL=C ls -l -d $$lc 2>/dev/null) | grep ' -> ' >/dev/null; then \
 
176
@@ -289,11 +324,14 @@
 
177
        $(MAKE) update-po
 
178
        @$(MAKE) dist2
 
179
 # This is a separate target because 'update-po' must be executed before.
 
180
-dist2: $(DISTFILES)
 
181
+dist2: stamp-po $(DISTFILES)
 
182
        dists="$(DISTFILES)"; \
 
183
        if test "$(PACKAGE)" = "gettext-tools"; then \
 
184
          dists="$$dists Makevars.template"; \
 
185
        fi; \
 
186
+       if test -f $(srcdir)/$(DOMAIN).pot; then \
 
187
+         dists="$$dists $(DOMAIN).pot stamp-po"; \
 
188
+       fi; \
 
189
        if test -f $(srcdir)/ChangeLog; then \
 
190
          dists="$$dists ChangeLog"; \
 
191
        fi; \
 
192
@@ -305,9 +343,9 @@
 
193
        if test -f $(srcdir)/LINGUAS; then dists="$$dists LINGUAS"; fi; \
 
194
        for file in $$dists; do \
 
195
          if test -f $$file; then \
 
196
-           cp -p $$file $(distdir); \
 
197
+           cp -p $$file $(distdir) || exit 1; \
 
198
          else \
 
199
-           cp -p $(srcdir)/$$file $(distdir); \
 
200
+           cp -p $(srcdir)/$$file $(distdir) || exit 1; \
 
201
          fi; \
 
202
        done
 
203
 
 
204
@@ -354,10 +392,9 @@
 
205
 update-gmo: Makefile $(GMOFILES)
 
206
        @:
 
207
 
 
208
-Makefile: Makefile.in.in $(top_builddir)/config.status @POMAKEFILEDEPS@
 
209
+Makefile: Makefile.in.in Makevars $(top_builddir)/config.status @POMAKEFILEDEPS@
 
210
        cd $(top_builddir) \
 
211
-         && CONFIG_FILES=$(subdir)/$@.in CONFIG_HEADERS= \
 
212
-              $(SHELL) ./config.status
 
213
+         && $(SHELL) ./config.status $(subdir)/$@.in po-directories
 
214
 
 
215
 force:
 
216