~ubuntu-branches/ubuntu/precise/virt-manager/precise-proposed

« back to all changes in this revision

Viewing changes to debian/patches/0002-console-Don-t-throw-traceback-if-we-can-t-read-error.patch

  • Committer: Bazaar Package Importer
  • Author(s): Marc Deslauriers
  • Date: 2011-02-03 10:35:22 UTC
  • mfrom: (2.3.3 experimental)
  • Revision ID: james.westby@ubuntu.com-20110203103522-j8and6dsy3taczbj
Tags: 0.8.6-1ubuntu1
* Merge from debian experimental. Remaining changes:
  - Depend on python-appindicator for appindicator support.
  - Add a /usr/share/pixmaps/virt-manager-icon.svg symlink to link icon to
    where the Application Indicator can find it.
  - Add patch da_l10n.patch since it is not integrated. (refreshed)
  - Add patch show_session_or_system_in_console to make the overview
    screen show which local qemu session you're connected to. (refreshed)
  - Add patch more_helpful_error_message to explain to the user why he
    can't connect to qemu:///system and what he can do fix it.
  - Add patch qemu-system-by-default to automatically add qemu:///system
    to the list of hypervisors if the user has write access to the UNIX
    socket.
  - Drop patchsys-quilt include since dpkg-source does the quilt dance for
    us.
  - debian/control: lower libvirt-bin from Recommends to Suggests; seems
    some users (like netbooks) want to manage VMs, but not host them; see
    meta packages (ubuntu-virt, ubuntu-virt-server, ubuntu-virt-mgmt) for
    group installation of virt package sets.
* Removed patches:
  - debian/patches/custom-icon-installation.patch: Upstream.
  - debian/patches/remove-appindicator-workarounds.patch: Upstream.
  - debian/patches/fix-nc-with-zsh.patch: Upstream
* Removed python-ipy dependency as it is in universe:
  - debian/control: remove python-ipy from Depends
  - debian/series: disable 0002-Use-IPy-from-python-ipy.patch patch so
    we use the one that's included in the virt-manager source.
  - debian/rules: don't delete the IPy file.
* debian/patches/fix-cpu-wrong-types.patch: fix "value is of wrong type
  for this column" error by making sure we are using strings in
  src/virtManager/details.py.
* debian/patches/dont-always-launch-consoles.patch: Don't always launch
  consoles for running domains in src/virtManager/manager.py.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From: Cole Robinson <crobinso@redhat.com>
2
 
Date: Wed, 28 Apr 2010 20:07:09 +0200
3
 
Subject: [PATCH] console: Don't throw traceback if we can't read error fd.
4
 
 
5
 
This is racy and best effort, so don't log errors if we fail.
6
 
 
7
 
Origin: Upstream, http://hg.fedorahosted.org/hg/virt-manager/rev/c206b12a8c7a
8
 
---
9
 
 src/virtManager/console.py |    6 +++++-
10
 
 1 files changed, 5 insertions(+), 1 deletions(-)
11
 
 
12
 
diff --git a/src/virtManager/console.py b/src/virtManager/console.py
13
 
index cbefcb3..2333bc4 100644
14
 
--- a/src/virtManager/console.py
15
 
+++ b/src/virtManager/console.py
16
 
@@ -573,7 +573,11 @@ class vmmConsolePages(gobject.GObject):
17
 
         errfd = self.vncTunnel[1]
18
 
         errout = ""
19
 
         while True:
20
 
-            new = errfd.recv(1024)
21
 
+            try:
22
 
+                new = errfd.recv(1024)
23
 
+            except:
24
 
+                break
25
 
+
26
 
             if not new:
27
 
                 break
28