~ubuntu-branches/ubuntu/raring/sunpinyin/raring

« back to all changes in this revision

Viewing changes to debian/patches/remove-10-candidate-words-limitation.patch

  • Committer: Package Import Robot
  • Author(s): YunQiang Su
  • Date: 2012-03-30 15:31:55 UTC
  • mfrom: (1.1.3) (1.2.7 sid)
  • Revision ID: package-import@ubuntu.com-20120330153155-qgls77sogzgtg9zp
Tags: 2.0.3+git20120222-1
* Team upload: git snapshot 20120222.
   - fix breaks if LDFLAGS in environment contains
       multiple words (Closese #646001).
   - rm patches merged to upstream:
       append-os-environ-toenv.patch
       fix-ftbfs-on-sh.patch
       remove-10-candidate-words-limitation.patch
   - refresh disable-lm-dict-compile.patch.
* Bump stardard version to 3.9.3: no modify needed.
* add libsunpinyin3-dbg and python-sunpinyin packages.
* debian/compat to 9, multiarch it.
* rewrite debian/rules with dh 7 format.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From: Weng Xuetian <wengxt@gmail.com>
2
 
Description: remove 10 candidate words limitation
3
 
Origin: vendor, https://github.com/sunpinyin/sunpinyin/commit/ecd26da914d672193149af651d6f01647fde7f88
4
 
 
5
 
--- a/src/ime-core/imi_view.h
6
 
+++ b/src/ime-core/imi_view.h
7
 
@@ -188,7 +188,7 @@
8
 
     CIMIWinHandler* getWinHandler(void) {return m_pWinHandler;}
9
 
 
10
 
     void setHotkeyProfile (CHotkeyProfile *prof) { m_pHotkeyProfile = prof;}
11
 
-    void setCandiWindowSize (unsigned size) {m_candiWindowSize = size<10? size: 10;}
12
 
+    void setCandiWindowSize (unsigned size) {m_candiWindowSize = size;}
13
 
     CHotkeyProfile* getHotkeyProfile() { return m_pHotkeyProfile; }
14
 
     unsigned getCandiWindowSize() { return m_candiWindowSize; }
15